]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
- up to 1.12.0,NFY
[packages/gammu.git] / gammu.spec
1 Summary:        GNU tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi GNU dla telefonów komórkowych
3 Name:           gammu
4 Version:        1.12.0
5 Release:        0.1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  260035c1647bab396dfd9b35d78a3ad8
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake
15 BuildRequires:  gettext-devel
16 BuildRequires:  mysql-devel
17 BuildRequires:  postgresql-devel
18 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
19 Provides:       mygnokii2
20 Obsoletes:      mygnokii2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Gammu (formerly known as MyGnokii2) is cellular manager for various
25 mobile phones and modems. It currently supports Nokia 3210, 33xx,
26 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
27 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
28 WaveCom, IPAQ, and other). It has a command line version with many
29 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
30 calls, etc. It can also make full backups and restore them.
31
32 %description -l pl.UTF-8
33 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
34 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
35 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
36 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
37 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
38 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
39 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
40 kopie zapasowe danych i odtwarzać je.
41
42 %package libs
43 Summary:        Gammu library
44 Summary(pl.UTF-8):      Biblioteka Gammu
45 Group:          Libraries
46
47 %description libs
48 Gammu tool suite library.
49
50 %description libs -l pl.UTF-8
51 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
52
53 %package devel
54 Summary:        Header files for Gammu tool suite for mobile phones
55 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
56 Group:          Development/Libraries
57 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
58
59 %description devel
60 Header files for Gammu tool suite for mobile phones.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
64
65 %package static
66 Summary:        Gammu static library
67 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
70
71 %description static
72 Gammu static library.
73
74 %description static -l pl.UTF-8
75 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
76
77 %prep
78 %setup -q
79 #%patch0 -p1
80
81 %build
82 mkdir -p build
83 cd build
84 %cmake ../ \
85         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
86         -DENABLE_SHARED=OFF \
87         %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
88 %{__make}
89 mv common/libGammu.a ..
90 %cmake ../ \
91         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
92         -DENABLE_SHARED=ON \
93         %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
99
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
104 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
105 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
106 %find_lang %{name}
107 cd $RPM_BUILD_ROOT%{_libdir}
108 ln -sf libGammu.so.1.11.92 libGammu.so
109
110 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
121 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
122 %attr(755,root,root) %{_bindir}/%{name}
123 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
124 %{_examplesdir}/%{name}-%{version}
125 %{_mandir}/man1/*
126
127 %files libs
128 %defattr(755,root,root,755)
129 %attr(755,root,root) %{_libdir}/*.so.*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_bindir}/%{name}-config
134 %attr(755,root,root) %{_libdir}/*.so
135 %{_includedir}/*
136 %{_pkgconfigdir}/*
137
138 %files static
139 %defattr(755,root,root,755)
140 %{_libdir}/*.a
This page took 0.04305 seconds and 4 git commands to generate.