]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
- updated to 1.24.90; cosmetics
[packages/gammu.git] / gammu.spec
1 Summary:        Tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi do telefonów komórkowych
3 Name:           gammu
4 Version:        1.24.90
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  b128b05c1808fa1e887647eefa1830f1
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake >= 2.4.6
15 BuildRequires:  curl-devel
16 BuildRequires:  gettext-devel
17 BuildRequires:  mysql-devel
18 BuildRequires:  postgresql-devel
19 BuildRequires:  python-devel >= 1:2.5
20 BuildRequires:  rpmbuild(macros) >= 1.293
21 BuildRequires:  rpm-pythonprov
22 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
23 Provides:       mygnokii2
24 Obsoletes:      mygnokii2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Gammu (formerly known as MyGnokii2) is cellular manager for various
29 mobile phones and modems. It currently supports Nokia 3210, 33xx,
30 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
31 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
32 WaveCom, IPAQ, and other). It has a command line version with many
33 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
34 calls, etc. It can also make full backups and restore them.
35
36 %description -l pl.UTF-8
37 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
38 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
39 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
40 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
41 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
42 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
43 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
44 kopie zapasowe danych i odtwarzać je.
45
46 %package libs
47 Summary:        Gammu library
48 Summary(pl.UTF-8):      Biblioteka Gammu
49 Group:          Libraries
50
51 %description libs
52 Gammu tool suite library.
53
54 %description libs -l pl.UTF-8
55 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
56
57 %package devel
58 Summary:        Header files for Gammu tool suite for mobile phones
59 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
62 Requires:       bluez-libs-devel
63
64 %description devel
65 Header files for Gammu tool suite for mobile phones.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
69
70 %package -n python-gammu
71 Summary:        Python bingings for Gammu library
72 Summary(pl.UTF-8):      Wiązania języka Python dla biblioteki Gammu
73 Group:          Development/Languages/Python
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75 %pyrequires_eq  python-modules
76
77 %description -n python-gammu
78 Python bingings for Gammu library.
79
80 %description -l pl.UTF-8 -n python-gammu
81 Wiązania języka Python dla biblioteki Gammu.
82
83 %package static
84 Summary:        Gammu static library
85 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
88
89 %description static
90 Gammu static library.
91
92 %description static -l pl.UTF-8
93 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 mkdir -p build
101 cd build
102 %cmake .. \
103         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
104         -DCMAKE_VERBOSE_MAKEFILE=ON \
105         -DBUILD_SHARED_LIBS=OFF \
106         -DINSTALL_LIB_DIR=%{_lib} \
107         -DINSTALL_LIBDATA_DIR=%{_libdir} \
108         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
109 %{__make}
110 mv libgammu/libGammu.a ..
111 mv smsd/libgsmsd.a ..
112 %cmake .. \
113         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
114         -DCMAKE_VERBOSE_MAKEFILE=ON \
115         -DBUILD_SHARED_LIBS=ON \
116         -DINSTALL_LIB_DIR=%{_lib} \
117         -DINSTALL_LIBDATA_DIR=%{_libdir} \
118         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
124
125 %{__make} -C build install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install docs/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
129 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
130 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
131 install libgsmsd.a $RPM_BUILD_ROOT%{_libdir}
132
133 %find_lang %{name}
134
135 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
136
137 # for rpm autodeps
138 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   libs -p /sbin/ldconfig
144 %postun libs -p /sbin/ldconfig
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS BUGS ChangeLog docs/user/gammu.html docs/user/readme.html README README.Python SUPPORTERS
149 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
150 %attr(755,root,root) %{_bindir}/%{name}
151 %attr(755,root,root) %{_bindir}/gammu-smsd
152 %attr(755,root,root) %{_bindir}/gammu-smsd-inject
153 %attr(755,root,root) %{_bindir}/gammu-smsd-monitor
154 %attr(755,root,root) %{_bindir}/jadmaker
155 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
156 %{_examplesdir}/%{name}-%{version}
157 %{_mandir}/man[157]/*
158 %lang(cs) %{_mandir}/cs/man[157]/*
159
160 %files libs
161 %defattr(755,root,root,755)
162 %attr(755,root,root) %{_libdir}/libGammu.so.*.*
163 %attr(755,root,root) %{_libdir}/libgsmsd.so.*.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libgsmsd.so.6
165 %attr(755,root,root) %ghost %{_libdir}/libGammu.so.6
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/%{name}-config
170 %attr(755,root,root) %{_libdir}/libGammu.so
171 %attr(755,root,root) %{_libdir}/libgsmsd.so
172 %{_includedir}/*
173 %dir %{py_sitedir}/gammu/
174 %attr(755,root,root) %{py_sitedir}/gammu/_gammu.so
175 %{_pkgconfigdir}/gammu.pc
176 %{_pkgconfigdir}/gammu-smsd.pc
177
178 %files -n python-gammu
179 %defattr(644,root,root,755)
180 %dir %{py_sitedir}/gammu
181 %attr(755,root,root) %{py_sitedir}/gammu/*.so
182 %{py_sitedir}/gammu/*.py
183
184 %files static
185 %defattr(755,root,root,755)
186 %{_libdir}/libgsmsd.a
187 %{_libdir}/libGammu.a
This page took 0.048476 seconds and 4 git commands to generate.