]> git.pld-linux.org Git - packages/gammu.git/blob - gammu.spec
67634616de59fe58ba365506ed76da6ff62e88ad
[packages/gammu.git] / gammu.spec
1 Summary:        GNU tool suite for mobile phones
2 Summary(pl.UTF-8):      Zestaw narzędzi GNU dla telefonów komórkowych
3 Name:           gammu
4 Version:        1.12.92
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Applications/Communications
9 Source0:        http://dl.cihar.com/gammu/releases/%{name}-%{version}.tar.bz2
10 # Source0-md5:  5bcb87a39e9004c654e080bf8df7cd43
11 Patch0:         %{name}-etc_dir.patch
12 URL:            http://www.gammu.org/
13 BuildRequires:  bluez-libs-devel
14 BuildRequires:  cmake
15 BuildRequires:  gettext-devel
16 BuildRequires:  mysql-devel
17 BuildRequires:  postgresql-devel
18 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
19 Provides:       mygnokii2
20 Obsoletes:      mygnokii2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Gammu (formerly known as MyGnokii2) is cellular manager for various
25 mobile phones and modems. It currently supports Nokia 3210, 33xx,
26 3410, 3510, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110, 82xx,
27 8310, 9110, and 9210, and AT devices (such as Siemens, Alcatel,
28 WaveCom, IPAQ, and other). It has a command line version with many
29 functions for ringtones, phonebook, SMS, logos, WAP, date/time, alarm,
30 calls, etc. It can also make full backups and restore them.
31
32 %description -l pl.UTF-8
33 Gammu (poprzednio znany jako MyGnokii2) jest narzędziem do zarządzania
34 różnymi telefonami komórkowymi i modemami. Aktualnie obsługuje Nokie
35 3210, 33xx, 3410, 51xx, 5210, 5510, 61xx, 62xx, 63xx, 6510, 7110,
36 82xx, 8310, 9110 i 3210 oraz urządzenia AT (takie jak Siemens,
37 Alcatel, WaveCom, IPAQ i inne). Ma wersję działającą z linii poleceń z
38 wieloma funkcjami do dzwonków, książki telefonicznej, SMS-ów, logo,
39 WAP, daty/czasu, budzika, dzwonienia itp. Może także wykonywać pełne
40 kopie zapasowe danych i odtwarzać je.
41
42 %package libs
43 Summary:        Gammu library
44 Summary(pl.UTF-8):      Biblioteka Gammu
45 Group:          Libraries
46
47 %description libs
48 Gammu tool suite library.
49
50 %description libs -l pl.UTF-8
51 Biblioteka zestawu narzędzi dla telefonów komórkowych Gammu.
52
53 %package devel
54 Summary:        Header files for Gammu tool suite for mobile phones
55 Summary(pl.UTF-8):      Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu
56 Group:          Development/Libraries
57 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
58
59 %description devel
60 Header files for Gammu tool suite for mobile phones.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe zestawu narzędzi dla telefonów komórkowych Gammu.
64
65 %package static
66 Summary:        Gammu static library
67 Summary(pl.UTF-8):      Biblioteka statyczna Gammu
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
70
71 %description static
72 Gammu static library.
73
74 %description static -l pl.UTF-8
75 Biblioteka statyczna zestawu narzędzi dla telefonów komórkowych Gammu.
76
77 %prep
78 %setup -q
79 #%patch0 -p1
80
81 %build
82 mkdir -p build
83 cd build
84 %cmake ../ \
85         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
86         -DENABLE_SHARED=OFF \
87         %{?debug:-DCMAKE_BUILD_TYPE="Debug"} 
88 %{__make} \
89         LDFLAGS="%{rpmldflags} -lm" \
90         LIBS=" -lm"
91 mv common/libGammu.a ..
92 %cmake ../ \
93         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
94         -DENABLE_SHARED=ON \
95         %{?debug:-DCMAKE_BUILD_TYPE="Debug"}  
96 %{__make} \
97         LDFLAGS="%{rpmldflags} -lm" \
98         LIBS=" -lm"
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
103
104 %{__make} -C build install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install docs/examples/config/gammurc $RPM_BUILD_ROOT%{_sysconfdir}
108 cp -r docs/{examples,develop} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109 install libGammu.a $RPM_BUILD_ROOT%{_libdir}
110 %find_lang %{name}
111
112 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %doc ChangeLog docs/user/gammu.htm docs/user/readme.htm other/bash README SUPPORTERS
123 %doc %lang(it) docs/user/gammu.it.txt docs/user/readme.it.txt
124 %attr(755,root,root) %{_bindir}/%{name}
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gammurc
126 %{_examplesdir}/%{name}-%{version}
127 %{_mandir}/man1/*
128
129 %files libs
130 %defattr(755,root,root,755)
131 %attr(755,root,root) %{_libdir}/*.so.*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/%{name}-config
136 %attr(755,root,root) %{_libdir}/*.so
137 %{_includedir}/*
138 %{_pkgconfigdir}/*
139
140 %files static
141 %defattr(755,root,root,755)
142 %{_libdir}/*.a
This page took 0.026778 seconds and 2 git commands to generate.