]> git.pld-linux.org Git - packages/gamin.git/blob - gamin.spec
- set proper libdir in gamin inetd config file
[packages/gamin.git] / gamin.spec
1 Summary:        Library providing the gamin File Alteration Monitor API
2 Summary(pl):    Biblioteka dostarczaj±ca File Alternation Monitor Api gamina
3 Name:           gamin
4 Version:        0.0.6
5 Release:        1
6 License:        LGPL
7 Group:          Networking/Daemons
8 Source0:        http://www.gnome.org/~veillard/gamin/sources/%{name}-%{version}.tar.gz
9 # Source0-md5:  8f8841ed896cd11a96ad2089ab7326b8
10 Source1:        %{name}.inetd
11 BuildRequires:  autoconf >= 2.52
12 BuildRequires:  automake
13 BuildRequires:  glib2-devel
14 BuildRequires:  libtool
15 PreReq:         rc-inetd
16 Requires:       %{name}-libs = %{version}-%{release}
17 Requires:       inetdaemon
18 Requires:       portmap
19 Provides:       fam
20 Obsoletes:      fam
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This C library provides an API and ABI compatible file alteration
25 monitor mechanism compatible with gamin but not dependant on a system
26 wide daemon.
27
28 %description -l pl
29 Ta biblioteka C dostarcza mechanizm monitorowania zmian plików
30 kompatybilny na poziomie API i ABI z gaminem, ale niezale¿ny od
31 ogólnosystemowego demona.
32
33 %package libs
34 Summary:        Libraries for gamin
35 Summary(pl):    Biblioteki dla gamina
36 Group:          Libraries
37 Provides:       fam-libs
38 Obsoletes:      fam-libs
39
40 %description libs
41 Libraries for gamin.
42
43 %description libs -l pl
44 Biblioteki dla gamina.
45
46 %package devel
47 Summary:        Includes to develop using gamin
48 Summary(pl):    Pliki nag³ówkowe do tworzenia programów z u¿yciem gamina
49 Group:          Development/Libraries
50 Requires:       %{name}-libs = %{version}-%{release}
51 Requires:       glib2-devel
52 Provides:       fam-devel
53 Obsoletes:      fam-devel
54
55 %description devel
56 Includes to develop using gamin.
57
58 %description devel -l pl
59 Pliki nag³ówkowe do tworzenia programów z u¿yciem gamina.
60
61 %package static
62 Summary:        gamin static libraries
63 Summary(pl):    Statyczne biblioteki gamina
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66 Provides:       fam-static
67 Obsoletes:      fam-static
68
69 %description static
70 gamin static libraries.
71
72 %description static -l pl
73 Statyczne biblioteki gamina.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__automake}
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 cat %{SOURCE1} | sed -e 's@/usr/lib@%{_libdir}@' > \
94         $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/gamin
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 if [ -f /var/lock/subsys/rc-inetd ]; then
101         /etc/rc.d/init.d/rc-inetd reload 1>&2
102 else
103         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
104 fi
105
106 %postun
107 if [ -f /var/lock/subsys/rc-inetd ]; then
108         /etc/rc.d/init.d/rc-inetd reload
109 fi
110
111 %post   libs -p /sbin/ldconfig
112 %postun libs -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog README TODO
117 %attr(755,root,root) %{_libdir}/gam_server
118 %attr(640,root,root) /etc/sysconfig/rc-inetd/gamin
119
120 %files libs
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/lib*.so.*.*
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/lib*.so
127 %{_libdir}/lib*.la
128 %{_includedir}/*.h
129 %{_pkgconfigdir}/*.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/*.a
This page took 0.109756 seconds and 3 git commands to generate.