]> git.pld-linux.org Git - packages/gambas2.git/blob - gambas2.spec
- updated sf URL
[packages/gambas2.git] / gambas2.spec
1 #
2 # Conditional build:
3 %bcond_without  bzip2           # gb.compress.bzlib2 module
4 %bcond_without  zlib            # gb.compress.zlib module
5 %bcond_without  mysql           # gb.db.mysql module
6 %bcond_without  odbc            # gb.db.odbc module
7 %bcond_without  pgsql           # gb.db.postgresql module
8 %bcond_without  sqlite2         # gb.db.sqlite2 module
9 %bcond_without  sqlite3         # gb.db.sqlite3 module
10 %bcond_without  firebird        # gb.db.firebird module
11 %bcond_without  gtk             # gb.gtk module
12 %bcond_without  librsvg         # gb.gtk.svg module (depends on gtk)
13 %bcond_without  pdf             # gb.pdf module
14 %bcond_without  net             # gb.net module
15 %bcond_without  curl            # gb.net.curl module
16 %bcond_without  smtp            # gb.net.smtp module
17 %bcond_without  pcre            # gb.pcre module
18 %bcond_without  qt              # gb.qt module
19 %bcond_with     qte             # gb.qte module
20 %bcond_without  kde             # gb.qt.kde module
21 %bcond_without  sdl             # gb.sdl module
22 %bcond_without  sdlsound        # gb.sdl.sound module
23 %bcond_without  xml             # gb.xml module
24 %bcond_without  v4l             # gb.v4l module
25 %bcond_without  crypt           # gb.crypt module
26 %bcond_without  opengl          # gb.opengl module
27 %bcond_without  corba           # gb.corba module
28 %bcond_without  image           # gb.image module
29 #bcond_without  desktop         # gb.desktop module
30 #
31 %if %{without gtk}
32 %undefine       with_librsvg
33 %endif
34 %if %{without opengl}
35 %undefine       with_sdl
36 %endif
37 %if %{without sdl}
38 %undefine       with_SDL_mixer
39 %endif
40 Summary:        Gambas - a free VB-like language
41 Summary(pl.UTF-8):      Gambas - wolnodostępny język podobny do VB
42 Name:           gambas2
43 Version:        2.8.2
44 Release:        0.1
45 License:        GPL v2
46 Group:          Development/Languages
47 Source0:        http://downloads.sourceforge.net/gambas/%{name}-%{version}.tar.bz2
48 # Source0-md5:  9f0d1c450b22580eccf3a0e3619a9d7c
49 Source1:        %{name}.desktop
50 Patch0:         %{name}-avoid-version.patch
51 URL:            http://gambas.sourceforge.net/
52 %{?with_firebird:BuildRequires: Firebird-devel}
53 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
54 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
55 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.8}
56 %{?with_sdl:BuildRequires:      SDL_image-devel}
57 %{?with_SDL_mixer:BuildRequires:        SDL_mixer-devel}
58 %{?with_bzip2:BuildRequires:    bzip2-devel}
59 %{?with_curl:BuildRequires:     curl-devel >= 7.13}
60 BuildRequires:  gettext-tools
61 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2:2.10.0}
62 %{?with_smtp:BuildRequires:     glib2-devel >= 2.0}
63 %{?with_kde:BuildRequires:      kdelibs-devel >= 3}
64 %{?with_v4l:BuildRequires:      libjpeg-devel}
65 %{?with_v4l:BuildRequires:      libpng-devel}
66 %{?with_librsvg:BuildRequires:  librsvg-devel >= 1:2.14.3}
67 %{?with_mysql:BuildRequires:    mysql-devel}
68 %{?with_corba:BuildRequires:    omniORB-devel >= 4}
69 %{?with_pcre:BuildRequires:     pcre-devel}
70 BuildRequires:  pkgconfig
71 %{?with_pdf:BuildRequires:      poppler-devel >= 0.8.0}
72 %{?with_pgsql:BuildRequires:    postgresql-backend-devel}
73 %{?with_pgsql:BuildRequires:    postgresql-devel}
74 %{?with_qt:BuildRequires:       qt-devel >= 3}
75 %{?with_qte:BuildRequires:      qte-devel >= 3}
76 %{?with_sqlite2:BuildRequires:  sqlite-devel >= 2}
77 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
78 %{?with_xml:BuildRequires:      libxml2-devel >= 2.0}
79 %{?with_xls:BuildRequires:      libxslt-devel}
80 %{?with_sdl:BuildRequires:      xorg-lib-libXcursor-devel}
81 %{?with_sdl:BuildRequires:      xorg-lib-libXft-devel}
82 %{?with_desktop:BuildRequires:  xorg-lib-libXtst-devel}
83 %{?with_zlib:BuildRequires:     zlib-devel}
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 Gambas is a free development environment based on a Basic interpreter
88 with object extensions, like Visual Basic(tm). With Gambas, you can
89 quickly design your program GUI, access MySQL or PostgreSQL databases,
90 pilot KDE applications with DCOP, translate your program into many
91 languages, and so on...
92
93 This package provides the command-line utilities, as well as the
94 Gambas interpreter needed to run Gambas applications.
95
96 %description -l pl.UTF-8
97 Gambas to wolnodostępne środowisko programistyczne oparte na
98 interpreterze Basica z rozszerzeniami obiektowymi, podobnym do Visual
99 Basica(TM). Przy pomocy Gambasa można szybko projektować graficzne
100 interfejsy użytkownika, odwoływać się do baz danych MySQL i
101 PostgreSQL, sterować aplikacjami KDE poprzez DCOP, tłumaczyć
102 program na wiele języków itd.
103
104 Ten pakiet dostarcza narzędzia działające z linii poleceń, a
105 także interpreter potrzebny do uruchamiania aplikacji Gambas.
106
107 %package doc
108 Summary:        Documentation for Gambas language
109 Summary(pl.UTF-8):      Dokumentacja dla języka Gambas
110 Group:          Development/Languages
111
112 %description doc
113 Gambas is a free development environment based on a Basic interpreter
114 with object extensions, like Visual Basic(tm). With Gambas, you can
115 quickly design your program GUI, access MySQL or PostgreSQL databases,
116 pilot KDE applications with DCOP, translate your program into many
117 languages, and so on...
118
119 This package contains Gambas language documentation.
120
121 %description doc -l pl.UTF-8
122 Gambas to wolnodostępne środowisko programistyczne oparte na
123 interpreterze Basica z rozszerzeniami obiektowymi, podobnym do Visual
124 Basica(TM). Przy pomocy Gambasa można szybko projektować graficzne
125 interfejsy użytkownika, odwoływać się do baz danych MySQL i
126 PostgreSQL, sterować aplikacjami KDE poprzez DCOP, tłumaczyć
127 program na wiele języków itd.
128
129 Ten pakiet zawiera dokumentację dla języka Gambas.
130
131 %package ide
132 Summary:        The Gambas IDE
133 Summary(pl.UTF-8):      IDE dla Gambas
134 Group:          Development/Languages
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       %{name}-gb-db = %{version}-%{release}
137 Requires:       %{name}-gb-debug = %{version}-%{release}
138 Requires:       %{name}-gb-qt = %{version}-%{release}
139 Requires:       %{name}-gb-qt-editor = %{version}-%{release}
140 Requires:       %{name}-gb-qt-ext = %{version}-%{release}
141
142 %description ide
143 This package includes the complete Gambas Development Environment,
144 with the database manager and all necessary components.
145
146 %description ide -l pl.UTF-8
147 Ten pakiet zawiera kompletne środowisko programistyczne, łącznie z
148 menedżerem baz danych i wszystkimi niezbędnymi komponentami.
149
150 %package examples
151 Summary:        The examples for Gambas language
152 Summary(pl.UTF-8):      Przykłady dla języka Gambas
153 Group:          Development/Languages
154 Requires:       %{name}-ide = %{version}-%{release}
155
156 %description examples
157 The gambas-examples package contains some examples for Gambas.
158
159 %description examples -l pl.UTF-8
160 Ten pakiet zawiera kilka przykładów dla Gambas.
161
162 %if 0
163 %package gb-compress
164 Summary:        The Gambas compression component
165 Summary(pl.UTF-8):      Gambas - komponent do kompresji
166 Group:          Development/Languages
167 Requires:       %{name} = %{version}-%{release}
168
169 %description gb-compress
170 This component allows you to compress/uncompress data or files with
171 the bzip2 and zip algorithms.
172
173 %description gb-compress -l pl.UTF-8
174 Ten komponent pozwala pakować/rozpakowywać dane lub pliki przy
175 użyciu algorytmów bzip2 i zip.
176
177 %package gb-db
178 Summary:        The Gambas database component
179 Summary(pl.UTF-8):      Gambas - komponent bazodanowy
180 Group:          Development/Languages
181 Requires:       %{name} = %{version}-%{release}
182
183 %description gb-db
184 This component allows you to access many databases management systems,
185 provided that you install the needed driver packages.
186
187 %description gb-db -l pl.UTF-8
188 Ten komponent pozwala na dostęp do wielu systemów bazodanowych pod
189 warunkiem doinstalowania wymaganych pakietów sterowników.
190
191 %package gb-db-mysql
192 Summary:        The MySQL driver for the Gambas database component
193 Summary(pl.UTF-8):      Gambas - sterownik do MySQL dla komponentu bazodanowego
194 Group:          Development/Languages
195 Requires:       %{name}-gb-db = %{version}-%{release}
196
197 %description gb-db-mysql
198 This component allows you to access MySQL databases.
199
200 %description gb-db-mysql -l pl.UTF-8
201 Ten komponent pozwala na dostęp do bazy danych MySQL.
202
203 %package gb-db-postgresql
204 Summary:        The PostgreSQL driver for the Gambas database component
205 Summary(pl.UTF-8):      Gambas - sterownik do PostgreSQL dla komponentu bazodanowego
206 Group:          Development/Languages
207 Requires:       %{name}-gb-db = %{version}-%{release}
208
209 %description gb-db-postgresql
210 This component allows you to access PostgreSQL databases.
211
212 %description gb-db-postgresql -l pl.UTF-8
213 Ten komponent pozwala na dostęp do bazy danych PostgreSQL.
214
215 %package gb-db-sqlite
216 Summary:        The SQLite driver for the Gambas database component
217 Summary(pl.UTF-8):      Gambas - sterownik do SQLite dla komponentu bazodanowego
218 Group:          Development/Languages
219 Requires:       %{name}-gb-db = %{version}-%{release}
220
221 %description gb-db-sqlite
222 This component allows you to access SQLite databases.
223
224 %description gb-db-sqlite -l pl.UTF-8
225 Ten komponent pozwala na dostęp do bazy danych SQLite.
226
227 %package gb-debug
228 Summary:        The debugger helper component for the Gambas IDE
229 Summary(pl.UTF-8):      Gambas - komponent debuggera dla IDE
230 Group:          Development/Languages
231 Requires:       %{name} = %{version}-%{release}
232
233 %description gb-debug
234 This component helps the IDE to debug Gambas programs.
235
236 %description gb-debug -l pl.UTF-8
237 Komponent przeznaczony dla IDE Gambasa, przydatny przy odpluskwianiu
238 programów.
239
240 %package gb-eval
241 Summary:        The Gambas expression evaluator component
242 Summary(pl.UTF-8):      Gambas - komponent do obliczania wyrażeń
243 Group:          Development/Languages
244 Requires:       %{name} = %{version}-%{release}
245
246 %description gb-eval
247 This component allows you to evaluate expressions at runtime. It is
248 used by the Gambas Eval() function.
249
250 %description gb-eval -l pl.UTF-8
251 Ten komponent pozwala na obliczanie wyrażeń w programach. Jest
252 używany przez funkcję Gambasa Eval().
253
254 %package gb-net
255 Summary:        The Gambas networking component
256 Summary(pl.UTF-8):      Komponent sieciowy Gambasa
257 Group:          Development/Languages
258 Requires:       %{name} = %{version}-%{release}
259
260 %description gb-net
261 This component allows you to use TCP/IP and UDP sockets, and to access
262 any serial ports.
263
264 %description gb-net -l pl.UTF-8
265 Ten komponent pozwala na używanie gniazd TCP/IP i UDP oraz na dostęp
266 do portów szeregowych.
267
268 %package gb-net-curl
269 Summary:        The Gambas advanced networking component
270 Summary(pl.UTF-8):      Zaawansowany komponent sieciowy Gambasa
271 Group:          Development/Languages
272 Requires:       %{name}-gb-net = %{version}-%{release}
273
274 %description gb-net-curl
275 This component allows your programs to easily become FTP or HTTP
276 clients.
277
278 %description gb-net-curl -l pl.UTF-8
279 Ten komponent pozwala programom w łatwy sposób stać się klientami
280 FTP lub HTTP.
281
282 %package gb-qt
283 Summary:        The Gambas Qt GUI component
284 Summary(pl.UTF-8):      Komponent graficznego interfejsu użytkownika Qt dla Gambasa
285 Group:          Development/Languages
286 Requires:       %{name} = %{version}-%{release}
287
288 %description gb-qt
289 This package includes the Gambas Qt GUI component.
290
291 %description gb-qt -l pl.UTF-8
292 Ten pakiet zawiera komponent graficznego interfejsu użytkownika Qt
293 dla Gambasa.
294
295 %package gb-qt-ext
296 Summary:        The Gambas extended Qt GUI component
297 Summary(pl.UTF-8):      Komponent rozszerzonego graficznego interfejsu Qt dla Gambasa
298 Group:          Development/Languages
299 Requires:       %{name}-gb-qt = %{version}-%{release}
300
301 %description gb-qt-ext
302 This component includes some uncommon Qt controls.
303
304 %description gb-qt-ext -l pl.UTF-8
305 Ten komponent zawiera niektóre mało popularne kontrolki Qt.
306
307 %package gb-qt-editor
308 Summary:        The Gambas source code editor component
309 Summary(pl.UTF-8):      Komponent edytora kodu źródłowego Gambasa
310 Group:          Development/Languages
311 Requires:       %{name}-gb-qt = %{version}-%{release}
312
313 %description gb-qt-editor
314 This component includes a Gambas source code editor with syntax
315 highlighting. It is used by the IDE.
316
317 %description gb-qt-editor -l pl.UTF-8
318 Ten komponent zawiera edytor kodu źródłowego Gambasa z
319 podświetlaniem składni. Jest używany przez IDE.
320
321 %package gb-qt-kde
322 Summary:        The Gambas KDE component
323 Summary(pl.UTF-8):      Komponent KDE dla Gambasa
324 Group:          Development/Languages
325 Requires:       %{name}-gb-qt = %{version}-%{release}
326
327 %description gb-qt-kde
328 This component transforms your Qt application in a KDE application,
329 and allows you to pilot any other KDE application with the DCOP
330 protocol.
331
332 %description gb-qt-kde -l pl.UTF-8
333 Ten komponent zamienia aplikację Qt w aplikację KDE i pozwala na
334 sterowanie dowolnymi aplikacjami KDE poprzez protokół DCOP.
335
336 %package gb-qt-kde-html
337 Summary:        The Gambas KHTML component
338 Summary(pl.UTF-8):      Komponent KHTML dla Gambasa
339 Group:          Development/Languages
340 Requires:       %{name}-gb-qt-kde = %{version}-%{release}
341
342 %description gb-qt-kde-html
343 This component allows you to use the KHTML Web Browser widget included
344 in KDE.
345
346 %description gb-qt-kde-html -l pl.UTF-8
347 Ten komponent pozwala na używanie widgetu przeglądarki WWW KHTML
348 zawartego w KDE.
349
350 %package gb-sdl
351 Summary:        The Gambas SDL component
352 Summary(pl.UTF-8):      Komponent SDL dla Gambasa
353 Group:          Development/Languages
354 Requires:       %{name} = %{version}-%{release}
355
356 %description gb-sdl
357 This component uses only the sound part of the SDL library. It allows
358 you to simultaneously play many sounds and a music stored in a file.
359
360 %description gb-sdl -l pl.UTF-8
361 Ten komponent używa tylko części dźwiękowej biblioteki SDL.
362 Pozwala na jednoczesne odtwarzanie wielu dźwięków i muzyki
363 zapisanej w pliku.
364
365 %package gb-vb
366 Summary:        The Gambas Visual Basic(TM) compatibility component
367 Summary(pl.UTF-8):      Komponent zgodności z Visual Basicem(TM) dla Gambasa
368 Group:          Development/Languages
369 Requires:       %{name} = %{version}-%{release}
370
371 %description gb-vb
372 This component aims at including some functions that imitate the
373 behaviour of Visual Basic(TM) functions. Use it only if you try to
374 port some VB projects.
375
376 %description gb-vb -l pl.UTF-8
377 Ten komponent zawiera trochę funkcji, których celem jest imitowanie
378 zachowania funkcji Visual Basica(TM). Należy go używać wyłącznie
379 przy próbach sportowania projektów VB.
380
381 %package gb-xml
382 Summary:        The Gambas XML components based on the libxml and libxslt libraries
383 Summary(pl.UTF-8):      Komponenty XML Gambasa oparte na bibliotekach libxml i libxslt
384 Group:          Development/Languages
385 Requires:       %{name} = %{version}-%{release}
386
387 %description gb-xml
388 These components brings the power of the libxml and libxslt libraries
389 to Gambas.
390
391 %description gb-xml -l pl.UTF-8
392 Te komponenty pozwalają na korzystanie z potęgi bibliotek libxml i
393 libxslt z poziomu Gambasa.
394 %endif
395
396 %prep
397 %setup -q
398 %patch0 -p1
399
400 %build
401 ./reconf-all
402 %configure \
403         --enable-bzlib2=%{?with_bzip2:yes}%{!?with_bzip2:no} \
404         --enable-zlib=%{?with_zlib:yes}%{!?with_zlib:no} \
405         --enable-mysql=%{?with_mysql:yes}%{!?with_mysql:no} \
406         --enable-odbc=%{?with_odbc:yes}%{!?with_odbc:no} \
407         --enable-postgresql=%{?with_pgsql:yes}%{!?with_pgsql:no} \
408         --enable-sqlite2=%{?with_sqlite2:yes}%{!?with_sqlite2:no} \
409         --enable-sqlite3=%{?with_sqlite3:yes}%{!?with_sqlite3:no} \
410         --enable-firebird=%{?with_firebird:yes}%{!?with_firebird:no} \
411         --enable-gtk=%{?with_gtk:yes}%{!?with_gtk:no} \
412         --enable-gtksvg=%{?with_librsvg:yes}%{!?with_librsvg:no} \
413         --enable-pdf=%{?with_pdf:yes}%{!?with_pdf:no} \
414         --enable-net=%{?with_net:yes}%{!?with_net:no} \
415         --enable-curl=%{?with_curl:yes}%{!?with_curl:no} \
416         --enable-smtp=%{?with_smtp:yes}%{!?with_smtp:no} \
417         --enable-pcre=%{?with_pcre:yes}%{!?with_pcre:no} \
418         --enable-qt=%{?with_qt:yes}%{!?with_qt:no} \
419         --enable-qte=%{?with_qte:yes}%{!?with_qte:no} \
420         --enable-kde=%{?with_kde:yes}%{!?with_kde:no} \
421         --enable-sdl=%{?with_sdl:yes}%{!?with_sdl:no} \
422         --enable-sdlsound=%{?with_SDL_mixer:yes}%{!?with_SDL_mixer:no} \
423         --enable-xml=%{?with_xml:yes}%{!?with_xml:no} \
424         --enable-v4l=%{?with_v4l:yes}%{!?with_v4l:no} \
425         --enable-crypt=%{?with_crypt:yes}%{!?with_crypt:no} \
426         --enable-opengl=%{?with_opengl:yes}%{!?with_opengl:no} \
427         --enable-corba=%{?with_corba:yes}%{!?with_corba:no} \
428         --enable-image=%{?with_image:yes}%{!?with_image:no} \
429
430 #       --enable-desktop=%{?with_desktop:yes}%{!?with_desktop:no} \
431
432 %{__make}
433
434 %install
435 rm -rf $RPM_BUILD_ROOT
436
437 %{__make} -j1 install \
438         DESTDIR=$RPM_BUILD_ROOT
439
440 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
441 install -D app/src/gambas2/img/logo/new-logo.png \
442         $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
443
444 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
445
446 %clean
447 rm -rf $RPM_BUILD_ROOT
448
449 %files
450 %defattr(644,root,root,755)
451 %doc AUTHORS ChangeLog README
452 %attr(755,root,root) %{_bindir}/gbc2
453 %attr(755,root,root) %{_bindir}/gbi2
454 %attr(755,root,root) %{_bindir}/gbr2
455 %attr(755,root,root) %{_bindir}/gbs2
456 %attr(755,root,root) %{_bindir}/gbs2.gambas
457 %attr(755,root,root) %{_bindir}/gbx2
458 %dir %{_libdir}/%{name}
459 %dir %{_datadir}/%{name}
460 %dir %{_datadir}/%{name}/info
461 %{_datadir}/%{name}/info/gb.info
462 %{_datadir}/%{name}/info/gb.list
463 %attr(755,root,root) %{_libdir}/%{name}/gb.so
464 %attr(755,root,root) %{_libdir}/%{name}/gb.compress.so
465 %attr(755,root,root) %{_libdir}/%{name}/gb.compress.bzlib2.so
466 %attr(755,root,root) %{_libdir}/%{name}/gb.compress.zlib.so
467 %attr(755,root,root) %{_libdir}/%{name}/gb.corba.so
468 %attr(755,root,root) %{_libdir}/%{name}/gb.crypt.so
469 %attr(755,root,root) %{_libdir}/%{name}/gb.db.so
470 %attr(755,root,root) %{_libdir}/%{name}/gb.db.firebird.so
471 %attr(755,root,root) %{_libdir}/%{name}/gb.db.mysql.so
472 %attr(755,root,root) %{_libdir}/%{name}/gb.db.odbc.so
473 %attr(755,root,root) %{_libdir}/%{name}/gb.db.postgresql.so
474 %attr(755,root,root) %{_libdir}/%{name}/gb.db.sqlite2.so
475 %attr(755,root,root) %{_libdir}/%{name}/gb.db.sqlite3.so
476 %attr(755,root,root) %{_libdir}/%{name}/gb.debug.so
477 %attr(755,root,root) %{_libdir}/%{name}/gb.desktop.so
478 %attr(755,root,root) %{_libdir}/%{name}/gb.draw.so
479 %attr(755,root,root) %{_libdir}/%{name}/gb.eval.so
480 %attr(755,root,root) %{_libdir}/%{name}/gb.gtk.so
481 %attr(755,root,root) %{_libdir}/%{name}/gb.gtk.ext.so
482 #%%attr(755,root,root) %{_libdir}/%{name}/gb.gtk.svg.so
483 %attr(755,root,root) %{_libdir}/%{name}/gb.gui.so
484 %attr(755,root,root) %{_libdir}/%{name}/gb.image.so
485 %attr(755,root,root) %{_libdir}/%{name}/gb.net.so
486 %attr(755,root,root) %{_libdir}/%{name}/gb.net.curl.so
487 %attr(755,root,root) %{_libdir}/%{name}/gb.net.smtp.so
488 %attr(755,root,root) %{_libdir}/%{name}/gb.opengl.so
489 %attr(755,root,root) %{_libdir}/%{name}/gb.option.so
490 %attr(755,root,root) %{_libdir}/%{name}/gb.pcre.so
491 %attr(755,root,root) %{_libdir}/%{name}/gb.pdf.so
492 %attr(755,root,root) %{_libdir}/%{name}/gb.qt.so
493 %attr(755,root,root) %{_libdir}/%{name}/gb.qt.ext.so
494 %attr(755,root,root) %{_libdir}/%{name}/gb.qt.kde.html.so
495 %attr(755,root,root) %{_libdir}/%{name}/gb.qt.kde.so
496 %attr(755,root,root) %{_libdir}/%{name}/gb.qt.opengl.so
497 %attr(755,root,root) %{_libdir}/%{name}/gb.sdl.so
498 %attr(755,root,root) %{_libdir}/%{name}/gb.sdl.sound.so
499 %attr(755,root,root) %{_libdir}/%{name}/gb.v4l.so
500 %attr(755,root,root) %{_libdir}/%{name}/gb.vb.so
501 %attr(755,root,root) %{_libdir}/%{name}/gb.xml.so
502 %attr(755,root,root) %{_libdir}/%{name}/gb.xml.xslt.so
503
504 %{_libdir}/%{name}/gb.component
505 %{_libdir}/%{name}/gb.chart.component
506 %{_libdir}/%{name}/gb.chart.gambas
507 %{_libdir}/%{name}/gb.compress.component
508 %{_libdir}/%{name}/gb.corba.component
509 %{_libdir}/%{name}/gb.crypt.component
510 %{_libdir}/%{name}/gb.db.component
511 %{_libdir}/%{name}/gb.db.form.component
512 %{_libdir}/%{name}/gb.db.form.gambas
513 %{_libdir}/%{name}/gb.debug.component
514 %{_libdir}/%{name}/gb.desktop.component
515 %{_libdir}/%{name}/gb.desktop.gambas
516 %{_libdir}/%{name}/gb.eval.component
517 %{_libdir}/%{name}/gb.form.component
518 %{_libdir}/%{name}/gb.form.gambas
519 %{_libdir}/%{name}/gb.form.dialog.component
520 %{_libdir}/%{name}/gb.form.dialog.gambas
521 %{_libdir}/%{name}/gb.form.mdi.component
522 %{_libdir}/%{name}/gb.form.mdi.gambas
523 %{_libdir}/%{name}/gb.gtk.component
524 %{_libdir}/%{name}/gb.gtk.ext.component
525 %{_libdir}/%{name}/gb.gtk.gambas
526 #%%{_libdir}/%{name}/gb.gtk.svg.component
527 %{_libdir}/%{name}/gb.gui.component
528 %{_libdir}/%{name}/gb.image.component
529 %{_libdir}/%{name}/gb.info.component
530 %{_libdir}/%{name}/gb.info.gambas
531 %{_libdir}/%{name}/gb.net.component
532 %{_libdir}/%{name}/gb.net.curl.component
533 %{_libdir}/%{name}/gb.net.smtp.component
534 %{_libdir}/%{name}/gb.opengl.component
535 %{_libdir}/%{name}/gb.option.component
536 %{_libdir}/%{name}/gb.pcre.component
537 %{_libdir}/%{name}/gb.pdf.component
538 %{_libdir}/%{name}/gb.qt.component
539 %{_libdir}/%{name}/gb.qt.gambas
540 %{_libdir}/%{name}/gb.qt.ext.component
541 %{_libdir}/%{name}/gb.qt.kde.component
542 %{_libdir}/%{name}/gb.qt.kde.html.component
543 %{_libdir}/%{name}/gb.qt.opengl.component
544 %{_libdir}/%{name}/gb.report.component
545 %{_libdir}/%{name}/gb.report.gambas
546 %{_libdir}/%{name}/gb.sdl.component
547 %{_libdir}/%{name}/gb.sdl.sound.component
548 %{_libdir}/%{name}/gb.settings.component
549 %{_libdir}/%{name}/gb.settings.gambas
550 %{_libdir}/%{name}/gb.v4l.component
551 %{_libdir}/%{name}/gb.vb.component
552 %{_libdir}/%{name}/gb.web.component
553 %{_libdir}/%{name}/gb.web.gambas
554 %{_libdir}/%{name}/gb.xml.component
555 %{_libdir}/%{name}/gb.xml.rpc.component
556 %{_libdir}/%{name}/gb.xml.rpc.gambas
557 %{_libdir}/%{name}/gb.xml.xslt.component
558 %{_datadir}/%{name}/info/gb.chart.info
559 %{_datadir}/%{name}/info/gb.chart.list
560 %{_datadir}/%{name}/info/gb.compress.info
561 %{_datadir}/%{name}/info/gb.compress.list
562 %{_datadir}/%{name}/info/gb.corba.info
563 %{_datadir}/%{name}/info/gb.corba.list
564 %{_datadir}/%{name}/info/gb.crypt.info
565 %{_datadir}/%{name}/info/gb.crypt.list
566 %{_datadir}/%{name}/info/gb.db.form.info
567 %{_datadir}/%{name}/info/gb.db.form.list
568 %{_datadir}/%{name}/info/gb.db.info
569 %{_datadir}/%{name}/info/gb.db.list
570 %{_datadir}/%{name}/info/gb.debug.info
571 %{_datadir}/%{name}/info/gb.debug.list
572 %{_datadir}/%{name}/info/gb.desktop.info
573 %{_datadir}/%{name}/info/gb.desktop.list
574 %{_datadir}/%{name}/info/gb.eval.info
575 %{_datadir}/%{name}/info/gb.eval.list
576 %{_datadir}/%{name}/info/gb.form.dialog.info
577 %{_datadir}/%{name}/info/gb.form.dialog.list
578 %{_datadir}/%{name}/info/gb.form.info
579 %{_datadir}/%{name}/info/gb.form.list
580 %{_datadir}/%{name}/info/gb.form.mdi.info
581 %{_datadir}/%{name}/info/gb.form.mdi.list
582 %{_datadir}/%{name}/info/gb.gtk.ext.info
583 %{_datadir}/%{name}/info/gb.gtk.ext.list
584 %{_datadir}/%{name}/info/gb.gtk.info
585 %{_datadir}/%{name}/info/gb.gtk.list
586 #%%{_datadir}/%{name}/info/gb.gtk.svg.info
587 #%%{_datadir}/%{name}/info/gb.gtk.svg.list
588 %{_datadir}/%{name}/info/gb.gui.info
589 %{_datadir}/%{name}/info/gb.gui.list
590 %{_datadir}/%{name}/info/gb.image.info
591 %{_datadir}/%{name}/info/gb.image.list
592 %{_datadir}/%{name}/info/gb.info.info
593 %{_datadir}/%{name}/info/gb.info.list
594 %{_datadir}/%{name}/info/gb.net.curl.info
595 %{_datadir}/%{name}/info/gb.net.curl.list
596 %{_datadir}/%{name}/info/gb.net.info
597 %{_datadir}/%{name}/info/gb.net.list
598 %{_datadir}/%{name}/info/gb.net.smtp.info
599 %{_datadir}/%{name}/info/gb.net.smtp.list
600 %{_datadir}/%{name}/info/gb.opengl.info
601 %{_datadir}/%{name}/info/gb.opengl.list
602 %{_datadir}/%{name}/info/gb.option.info
603 %{_datadir}/%{name}/info/gb.option.list
604 %{_datadir}/%{name}/info/gb.pcre.info
605 %{_datadir}/%{name}/info/gb.pcre.list
606 %{_datadir}/%{name}/info/gb.pdf.info
607 %{_datadir}/%{name}/info/gb.pdf.list
608 %{_datadir}/%{name}/info/gb.qt.ext.info
609 %{_datadir}/%{name}/info/gb.qt.ext.list
610 %{_datadir}/%{name}/info/gb.qt.info
611 %{_datadir}/%{name}/info/gb.qt.kde.html.info
612 %{_datadir}/%{name}/info/gb.qt.kde.html.list
613 %{_datadir}/%{name}/info/gb.qt.kde.info
614 %{_datadir}/%{name}/info/gb.qt.kde.list
615 %{_datadir}/%{name}/info/gb.qt.list
616 %{_datadir}/%{name}/info/gb.qt.opengl.info
617 %{_datadir}/%{name}/info/gb.qt.opengl.list
618 %{_datadir}/%{name}/info/gb.report.info
619 %{_datadir}/%{name}/info/gb.report.list
620 %{_datadir}/%{name}/info/gb.sdl.info
621 %{_datadir}/%{name}/info/gb.sdl.list
622 %{_datadir}/%{name}/info/gb.sdl.sound.info
623 %{_datadir}/%{name}/info/gb.sdl.sound.list
624 %{_datadir}/%{name}/info/gb.settings.info
625 %{_datadir}/%{name}/info/gb.settings.list
626 %{_datadir}/%{name}/info/gb.v4l.info
627 %{_datadir}/%{name}/info/gb.v4l.list
628 %{_datadir}/%{name}/info/gb.vb.info
629 %{_datadir}/%{name}/info/gb.vb.list
630 %{_datadir}/%{name}/info/gb.web.info
631 %{_datadir}/%{name}/info/gb.web.list
632 %{_datadir}/%{name}/info/gb.xml.info
633 %{_datadir}/%{name}/info/gb.xml.list
634 %{_datadir}/%{name}/info/gb.xml.rpc.info
635 %{_datadir}/%{name}/info/gb.xml.rpc.list
636 %{_datadir}/%{name}/info/gb.xml.xslt.info
637 %{_datadir}/%{name}/info/gb.xml.xslt.list
638
639 %files doc
640 %defattr(644,root,root,755)
641 %{_datadir}/%{name}/help
642
643 %files ide
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_bindir}/gambas2
646 %attr(755,root,root) %{_bindir}/gambas2.gambas
647 %attr(755,root,root) %{_bindir}/gambas2-database-manager.gambas
648 %attr(755,root,root) %{_bindir}/gba2
649 %{_desktopdir}/%{name}.desktop
650 %{_pixmapsdir}/%{name}.png
651
652 %files examples
653 %defattr(644,root,root,755)
654 %{_datadir}/%{name}/examples
655
656 %if 0
657 %files gb-compress
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.compress.*
660 %{_datadir}/%{name}/info/gb.compress.*
661
662 %files gb-db
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.db.so*
665 %{_libdir}/%{name}/lib.gb.db.component
666 %{_datadir}/%{name}/info/gb.db.info
667 %{_datadir}/%{name}/info/gb.db.list
668
669 %files gb-db-mysql
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.db.mysql.*
672
673 %files gb-db-postgresql
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.db.postgresql.*
676
677 %files gb-db-sqlite
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.db.sqlite.*
680
681 %files gb-debug
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.debug.*
684 %{_datadir}/%{name}/info/gb.debug.*
685
686 %files gb-eval
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.eval.*
689 %{_datadir}/%{name}/info/gb.eval.*
690
691 %files gb-net
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.net.so*
694 %{_libdir}/%{name}/lib.gb.net.component
695 %{_datadir}/%{name}/info/gb.net.info
696 %{_datadir}/%{name}/info/gb.net.list
697
698 %files gb-net-curl
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.net.curl.so*
701 %{_libdir}/%{name}/lib.gb.net.curl.component
702 %{_datadir}/%{name}/info/gb.net.curl.info
703 %{_datadir}/%{name}/info/gb.net.curl.list
704
705 %files gb-qt
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.qt.so*
708 %{_libdir}/%{name}/lib.gb.qt.component
709 %{_datadir}/%{name}/info/gb.qt.info
710 %{_datadir}/%{name}/info/gb.qt.list
711
712 %files gb-qt-ext
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.qt.ext.so*
715 %{_libdir}/%{name}/lib.gb.qt.ext.component
716 %{_datadir}/%{name}/info/gb.qt.ext.info
717 %{_datadir}/%{name}/info/gb.qt.ext.list
718
719 %files gb-qt-editor
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.qt.editor.so*
722 %{_libdir}/%{name}/lib.gb.qt.editor.component
723 %{_datadir}/%{name}/info/gb.qt.editor.info
724 %{_datadir}/%{name}/info/gb.qt.editor.list
725
726 %files gb-qt-kde
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.qt.kde.so*
729 %{_libdir}/%{name}/lib.gb.qt.kde.component
730 %{_datadir}/%{name}/info/gb.qt.kde.info
731 %{_datadir}/%{name}/info/gb.qt.kde.list
732
733 %files gb-qt-kde-html
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.qt.kde.html.so*
736 %{_libdir}/%{name}/lib.gb.qt.kde.html.component
737 %{_datadir}/%{name}/info/gb.qt.kde.html.info
738 %{_datadir}/%{name}/info/gb.qt.kde.html.list
739
740 %files gb-sdl
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.sdl.so*
743 %{_libdir}/%{name}/lib.gb.sdl.component
744 %{_datadir}/%{name}/info/gb.sdl.info
745 %{_datadir}/%{name}/info/gb.sdl.list
746
747 %files gb-vb
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.vb.so*
750 %{_libdir}/%{name}/lib.gb.vb.component
751 %{_datadir}/%{name}/info/gb.vb.info
752 %{_datadir}/%{name}/info/gb.vb.list
753
754 %files gb-xml
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_libdir}/%{name}/lib.gb.xml.libxml.*
757 %{_datadir}/%{name}/info/gb.xml.libxml.*
758 %endif
This page took 3.077579 seconds and 4 git commands to generate.