]> git.pld-linux.org Git - packages/gambas.git/blob - gambas.spec
- some cleanups
[packages/gambas.git] / gambas.spec
1 Summary:        Gambas - a free VB-like language
2 Summary(pl):    Gambas - wolnodostêpny jêzyk VB-podobny
3 Name:           gambas
4 License:        GPL
5 Group:          Development/Languages
6 Version:        0.90
7 Release:        0.1     
8 Source0:        http://gambas.sourceforge.net/%{name}-%{version}.tar.bz2
9 # Source0-md5:  1f3211e2c97a354205123a71441e6ced
10 URL:            http://gambas.sf.net/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 Gambas is a free development environment based on a Basic interpreter
15 with object extensions, like Visual Basic(tm). With Gambas, you can
16 quickly design your program GUI, access MySQL or PostgreSQL databases,
17 pilot KDE applications with DCOP, translate your program into many
18 languages, and so on...
19
20 This package only provides the command-line utilities. You will need
21 gambas-lib for the required components and gambas-gui for the actual
22 VB-like environment.
23
24 %package doc
25 Summary:        Documentation for Gambas language
26 Summary(pl):    Dokumentacja dla jêzyka Gambas
27 Group:          Development/Languages
28
29 %description doc
30 Gambas is a free development environment based on a Basic interpreter
31 with object extensions, like Visual Basic(tm). With Gambas, you can
32 quickly design your program GUI, access MySQL or PostgreSQL databases,
33 pilot KDE applications with DCOP, translate your program into many
34 languages, and so on...
35
36 This package contains Gambas language documentation.
37
38 %package libs
39 Summary:        Gambas language components and libraries
40 Summary(pl):    Komponenty i biblioteki jêzyka Gambas
41 Group:          Development/Languages
42 Requires:       %{name} = %{version}-%{release}
43
44 %description libs
45 This package provides the components for Gambas language. You will
46 need the gambas package for the compiler/interpreter and gambas-gui
47 for the actual VB-like environment.
48
49 %package devel
50 Summary:        Header file for Gambas component development
51 Summary(pl):    Pliki nag³ówkowe do tworzenia komponentów jêzyka Gambas
52 Group:          Development/Languages
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 This package includes the header file necessary for writing your own
57 Gambas components, as well as the source for the Gambas GUI components
58 necessary for building the gambas-gui package.
59
60 %prep
61 %setup -q
62
63 %build
64 #%{__libtoolize}
65 #%{__aclocal}
66 #%{__autoconf}
67 #%{__automake}
68 cp -f /usr/share/automake/config.sub .
69 %configure2_13
70 %{__make}
71
72 %install
73 # workaround for broken libtool
74 rm -rf $RPM_BUILD_ROOT
75 export SED=sed
76 export PATH=${RPM_BUILD_ROOT}%{_bindir}:$PWD/src/comp:$PATH
77 #make DESTDIR=${RPM_BUILD_ROOT} install
78 #install -d ${RPM_BUILD_ROOT}%{_bindir}/
79 #install -d ${RPM_BUILD_ROOT}%{_datadir}/doc/%{name}-%{version}
80 #install -d ${RPM_BUILD_ROOT}%{_includedir}/
81 #install -d ${RPM_BUILD_ROOT}%{_includedir}/%{name}
82 #install -d ${RPM_BUILD_ROOT}%appdir/
83 #install -d ${RPM_BUILD_ROOT}%appdir/lib/
84 #install -s -m 0755 src/exec/gbx ${RPM_BUILD_ROOT}%{_bindir}/
85 #install -s -m 0755 src/comp/gba ${RPM_BUILD_ROOT}%{_bindir}/
86 #install -s -m 0755 src/comp/gbi ${RPM_BUILD_ROOT}%{_bindir}/
87 #install -s -m 0755 src/comp/gbc ${RPM_BUILD_ROOT}%{_bindir}/
88 #find src -name *.la -exec cp {} ${RPM_BUILD_ROOT}%appdir/lib \;
89 #find src -name *.so* -exec cp -a {} ${RPM_BUILD_ROOT}%appdir/lib \;
90 #cp -a src/share/gambas.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}
91 #cp -av examples ${RPM_BUILD_ROOT}/usr/share/doc/%{name}-%{version}
92 ##cp -av help ${RPM_BUILD_ROOT}/usr/share/doc/%{name}-%{version}
93 #find ${RPM_BUILD_ROOT} -size 0 -exec rm -f {} \;
94 #tar cjvf ${RPM_BUILD_ROOT}%appdir/gambas-gui-%{version}.tar.bz2 app/ `find src/ -name *.component`
95 #
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files libs
100 %defattr(644,root,root,755)
101 %doc AUTHORS COPYING ChangeLog INSTALL README
102 #%appdir/lib/*.so.*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc AUTHORS COPYING ChangeLog INSTALL README
107 #%appdir/lib/*.so
108 #%appdir/lib/*.la
109 #%{_includedir}/%{name}
110 #%appdir/gambas-gui-%{version}.tar.bz2
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING ChangeLog INSTALL README
115 %attr(755,root,root) %{_bindir}/*
116
117 %post libs -p /sbin/ldconfig
118
119 %postun libs -p /sbin/ldconfig
120
121 #%post -n gambas-doc
122 #ln -s /usr/share/doc/%{name}-doc-%{version}/examples %{appdir}/
123 #mkdir -p %{appdir}/share
124 #ln -s /usr/share/doc/%{name}-doc-%{version}/help %{appdir}/share/help
125
126 #%postun -n gambas-doc
127 #rm -f %{appdir}/examples
128 #rm -f %{appdir}/share/help
129 #rmdir %{appdir}/share
130
131 #%post -n gambas
132 #mkdir -p %appdir/bin/
133 #mv -f /usr/bin/gbx %appdir/bin/gbx-real
134 #ln -s %appdir/bin/gbx-real /usr/bin/gbx
This page took 0.092417 seconds and 3 git commands to generate.