]> git.pld-linux.org Git - packages/gallery.git/blob - gallery.spec
- update webapp triggers due apache1 package split
[packages/gallery.git] / gallery.spec
1 Summary:        Web based photo album viewer and creator
2 Summary(pl):    Przegl±darka i generator albumów zdjêæ w postaci stron WWW
3 Name:           gallery
4 Version:        1.5.3
5 Release:        3
6 License:        GPL
7 Group:          Applications/Publishing
8 Source0:        http://dl.sourceforge.net/gallery/%{name}-%{version}.tar.gz
9 # Source0-md5:  ed5fd4aeff5146552eaba5ff6d0de576
10 Source1:        http://dl.sourceforge.net/gallery/pl_PL-1.5.1.tar.gz
11 # Source1-md5:  efe8e359041c2c07463132ad0f7a8bea
12 Source2:        %{name}-apache.conf
13 Patch0:         %{name}-PLD.patch
14 URL:            http://gallery.sourceforge.net/
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires:       webapps
17 Requires:       php-gettext
18 Requires:       php >= 3:4.1.0
19 #Suggests:      apache(mod_rewrite)
20 #Suggests:      jhead
21 #Suggests:      jpegtran
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _webapps        /etc/webapps
26 %define         _webapp         %{name}
27 %define         _sysconfdir     %{_webapps}/%{_webapp}
28 %define         _appdir %{_datadir}/%{_webapp}
29
30 %description
31 Gallery is a photo album that includes a config wizard and lets users
32 create and maintain albums via an intuitive Web interface. Photo
33 management includes automatic thumbnail creation, image resizing,
34 rotation, ordering and more. Albums can have read, write, and caption
35 permissions per individual.
36
37 %description -l pl
38 Gallery jest albumem zdjêæ, który posiadaj kreatora konfiguracji i
39 pozwala u¿ytkownikom tworzyæ i zarz±dzaæ albumami przez intuicyjny
40 interfejs WWW. Zarz±dzanie zdjêciami umo¿liwia automatyczne tworzenie
41 miniatur, zmianê wielko¶ci obrazów, obrót, zmianê kolejno¶ci
42 wy¶wietlania, itp. Albumy mog± posiadaæ indywidualne uprawnienia.
43
44 %package setup
45 Summary:        Gallery setup package
46 Summary(pl):    Pakiet do wstêpnej konfiguracji Gallery
47 Group:          Applications/WWW
48 Requires:       %{name} = %{version}-%{release}
49
50 %description setup
51 Install this package to configure initial Gallery installation. You
52 should uninstall this package when you're done, as it considered
53 insecure to keep the setup files in place.
54
55 %description setup -l pl
56 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfigurac Gallery po
57 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
58 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
59
60 %prep
61 %setup -q -n %{name}
62 %patch0 -p1
63
64 tar zxf %{SOURCE1} -C locale
65 rm -f LICENSE.txt *.bat
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir},/var/lib/gallery/albums}
70
71 cp -a *.{php,inc,sh} $RPM_BUILD_ROOT%{_appdir}
72 cp -a classes contrib css docs help html html_wrap images $RPM_BUILD_ROOT%{_appdir}
73 cp -a includes java js layout lib locale platform skins tools $RPM_BUILD_ROOT%{_appdir}
74 # in /var because of setup/resetadmin file
75 cp -a setup $RPM_BUILD_ROOT/var/lib/gallery
76 ln -s /var/lib/gallery/setup $RPM_BUILD_ROOT%{_appdir}
77 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
78 rm -f $RPM_BUILD_ROOT%{_appdir}/{AUTHORS,ChangeLog*,README}
79
80 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
81 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/config.php
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/htaccess
84 ln -s %{_sysconfdir}/htaccess $RPM_BUILD_ROOT%{_appdir}/.htaccess
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %triggerin -- apache1 < 1.3.37-3, apache1-base
90 %webapp_register apache %{_webapp}
91
92 %triggerun -- apache1 < 1.3.37-3, apache1-base
93 %webapp_unregister apache %{_webapp}
94
95 %triggerin -- apache < 2.2.0, apache-base
96 %webapp_register httpd %{_webapp}
97
98 %triggerun -- apache < 2.2.0, apache-base
99 %webapp_unregister httpd %{_webapp}
100
101 %triggerpostun -- %{name} < 1.5.2-0.13
102 /usr/sbin/webapp register httpd %{_webapp}
103 %service -q httpd reload
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS ChangeLog* README
108 %dir %attr(750,root,http) %{_sysconfdir}
109 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
110 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
111 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
112 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/htaccess
113 %dir %{_appdir}
114 %dir /var/lib/gallery
115 %dir %attr(770,root,http) /var/lib/gallery/albums
116 %{_appdir}/.htaccess
117 %{_appdir}/*.php
118 %{_appdir}/*.inc
119 %{_appdir}/classes
120 %{_appdir}/contrib
121 %{_appdir}/css
122 %{_appdir}/docs
123 %{_appdir}/html*
124 %{_appdir}/help
125 %{_appdir}/images
126 %{_appdir}/includes
127 %{_appdir}/java
128 %{_appdir}/js
129 %{_appdir}/layout
130 %{_appdir}/lib
131 %{_appdir}/platform
132 %{_appdir}/skins
133 %{_appdir}/tools
134
135 %dir %{_appdir}/locale
136 %{_appdir}/locale/en_US
137 %lang(pl) %{_appdir}/locale/pl_PL
138
139 %files setup
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_appdir}/*.sh
142 %{_appdir}/setup
143 %{_appdir}/config.php
144 /var/lib/gallery/setup
This page took 0.894927 seconds and 3 git commands to generate.