]> git.pld-linux.org Git - packages/gallery.git/blob - gallery.spec
9d3a0c5ec1105e200c913743bb10d309e2167139
[packages/gallery.git] / gallery.spec
1 Summary:        Web based photo album viewer and creator
2 Summary(pl):    Przegl±darka i generator albumów zdjêæ w postaci stron WWW
3 Name:           gallery
4 Version:        1.5.10
5 Release:        1
6 License:        GPL
7 Group:          Applications/Publishing
8 Source0:        http://dl.sourceforge.net/gallery/%{name}-%{version}.tar.gz
9 # Source0-md5:  a8147e62b248baf25cdd2a79a63453eb
10 Source1:        http://dl.sourceforge.net/gallery/pl_PL-1.5.2.tar.gz
11 # Source1-md5:  1dd07a63d96299d8f5e4cc03342d318e
12 Source2:        %{name}-apache.conf
13 Patch0:         %{name}-PLD.patch
14 URL:            http://gallery.menalto.com/
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires:       php(gettext)
17 Requires:       webapps
18 Requires:       webserver(php) >= 4.1.0
19 #Suggests:      apache(mod_rewrite)
20 #Suggests:      jhead
21 #Suggests:      jpegtran
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _webapps        /etc/webapps
26 %define         _webapp         %{name}
27 %define         _sysconfdir     %{_webapps}/%{_webapp}
28 %define         _appdir %{_datadir}/%{_webapp}
29
30 %description
31 Gallery is a photo album that includes a config wizard and lets users
32 create and maintain albums via an intuitive Web interface. Photo
33 management includes automatic thumbnail creation, image resizing,
34 rotation, ordering and more. Albums can have read, write, and caption
35 permissions per individual.
36
37 %description -l pl
38 Gallery jest albumem zdjêæ, który posiadaj kreatora konfiguracji i
39 pozwala u¿ytkownikom tworzyæ i zarz±dzaæ albumami przez intuicyjny
40 interfejs WWW. Zarz±dzanie zdjêciami umo¿liwia automatyczne tworzenie
41 miniatur, zmianê wielko¶ci obrazów, obrót, zmianê kolejno¶ci
42 wy¶wietlania, itp. Albumy mog± posiadaæ indywidualne uprawnienia.
43
44 %package setup
45 Summary:        Gallery setup package
46 Summary(pl):    Pakiet do wstêpnej konfiguracji Gallery
47 Group:          Applications/WWW
48 Requires:       %{name} = %{version}-%{release}
49
50 %description setup
51 Install this package to configure initial Gallery installation. You
52 should uninstall this package when you're done, as it considered
53 insecure to keep the setup files in place.
54
55 %description setup -l pl
56 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfigurac Gallery po
57 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
58 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63
64 tar zxf %{SOURCE1} -C locale
65 rm -f LICENSE.txt *.bat
66
67 # cleanup backups after patching
68 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir},/var/lib/gallery/albums}
73
74 cp -a *.{php,inc,sh} $RPM_BUILD_ROOT%{_appdir}
75 cp -a classes contrib css docs help html html_wrap images $RPM_BUILD_ROOT%{_appdir}
76 cp -a includes java js layout lib locale platform skins tools $RPM_BUILD_ROOT%{_appdir}
77 # in /var because of setup/resetadmin file
78 cp -a setup $RPM_BUILD_ROOT/var/lib/gallery
79 ln -s /var/lib/gallery/setup $RPM_BUILD_ROOT%{_appdir}
80 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
81 rm -f $RPM_BUILD_ROOT%{_appdir}/{AUTHORS,ChangeLog*,README}
82
83 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
84 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
85 touch $RPM_BUILD_ROOT%{_sysconfdir}/config.php
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/htaccess
87 ln -s %{_sysconfdir}/htaccess $RPM_BUILD_ROOT%{_appdir}/.htaccess
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %triggerin -- apache1 < 1.3.37-3, apache1-base
93 %webapp_register apache %{_webapp}
94
95 %triggerun -- apache1 < 1.3.37-3, apache1-base
96 %webapp_unregister apache %{_webapp}
97
98 %triggerin -- apache < 2.2.0, apache-base
99 %webapp_register httpd %{_webapp}
100
101 %triggerun -- apache < 2.2.0, apache-base
102 %webapp_unregister httpd %{_webapp}
103
104 %triggerpostun -- %{name} < 1.5.2-0.13
105 /usr/sbin/webapp register httpd %{_webapp}
106 %service -q httpd reload
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog* README
111 %dir %attr(750,root,http) %{_sysconfdir}
112 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
113 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
114 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
115 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/htaccess
116 %dir %{_appdir}
117 %dir /var/lib/gallery
118 %dir %attr(770,root,http) /var/lib/gallery/albums
119 %{_appdir}/.htaccess
120 %{_appdir}/*.php
121 %{_appdir}/*.inc
122 %{_appdir}/classes
123 %{_appdir}/contrib
124 %{_appdir}/css
125 %{_appdir}/docs
126 %{_appdir}/html*
127 %{_appdir}/help
128 %{_appdir}/images
129 %{_appdir}/includes
130 %{_appdir}/java
131 %{_appdir}/js
132 %{_appdir}/layout
133 %{_appdir}/lib
134 %{_appdir}/platform
135 %{_appdir}/skins
136 %{_appdir}/tools
137
138 %dir %{_appdir}/locale
139 %{_appdir}/locale/en_US
140 %lang(pl) %{_appdir}/locale/pl_PL
141
142 %files setup
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_appdir}/*.sh
145 %{_appdir}/setup
146 %{_appdir}/config.php
147 /var/lib/gallery/setup
This page took 0.10472 seconds and 2 git commands to generate.