]> git.pld-linux.org Git - packages/gallery.git/blob - gallery.spec
- up to 2.2.1
[packages/gallery.git] / gallery.spec
1 # TODO:
2 # - use external libs, not the included ones: pear, smarty, adodb
3 # - move to separate packages each: theme, module.
4 Summary:        Web based photo album viewer and creator
5 Summary(pl.UTF-8):      Przeglądarka i generator albumów zdjęć w postaci stron WWW
6 Name:           gallery
7 Version:        2.2.1
8 Release:        1
9 License:        GPL
10 Group:          Applications/Publishing
11 Source0:        http://dl.sourceforge.net/gallery/%{name}-%{version}-full.tar.gz
12 # Source0-md5:  e4501a9cec700f238bddc5791fec0f8c
13 #Source0:       http://galleryupdates.jpmullan.com/G2/%{name}-nightly.tar.gz
14 Source1:        %{name}-apache.conf
15 Patch0:         %{name}-setup.patch
16 URL:            http://gallery.sourceforge.net/
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires:       php(gettext)
19 Requires:       php(pcre)
20 Requires:       webapps
21 Requires:       webserver(php) >= 4.1.0
22 #Suggests:      apache(mod_rewrite)
23 #Suggests:      jhead
24 #Suggests:      jpegtran
25 #Suggests:      php-gd
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _webapps        /etc/webapps
30 %define         _webapp         %{name}
31 %define         _sysconfdir     %{_webapps}/%{_webapp}
32 %define         _appdir         %{_datadir}/%{_webapp}
33
34 %description
35 Gallery is a photo album that includes a config wizard and lets users
36 create and maintain albums via an intuitive Web interface. Photo
37 management includes automatic thumbnail creation, image resizing,
38 rotation, ordering and more. Albums can have read, write, and caption
39 permissions per individual.
40
41 %description -l pl.UTF-8
42 Gallery jest albumem zdjęć, który posiadaj kreatora konfiguracji i
43 pozwala użytkownikom tworzyć i zarządzać albumami przez intuicyjny
44 interfejs WWW. Zarządzanie zdjęciami umożliwia automatyczne tworzenie
45 miniatur, zmianę wielkości obrazów, obrót, zmianę kolejności
46 wyświetlania, itp. Albumy mogą posiadać indywidualne uprawnienia.
47
48 %package setup
49 Summary:        Gallery setup package
50 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Gallery
51 Group:          Applications/WWW
52 Requires:       %{name} = %{version}-%{release}
53 Conflicts:      external-gallery-module
54
55 %description setup
56 Install this package to configure initial Gallery installation. You
57 should uninstall this package when you're done, as it considered
58 insecure to keep the setup files in place.
59
60 %description setup -l pl.UTF-8
61 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Gallery po
62 pierwszej instalacji. Potem należy go odinstalować, jako że
63 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
64
65 %prep
66 %setup -q -n %{name}2
67 %patch0 -p0
68
69 rm -f LICENSE.txt *.bat
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir},/var/lib/gallery/albums}
74
75 cp -a *.{php,inc} $RPM_BUILD_ROOT%{_appdir}
76 cp README.html $RPM_BUILD_ROOT%{_appdir}
77 cp -a images lib modules themes $RPM_BUILD_ROOT%{_appdir}
78 cp -a install upgrade $RPM_BUILD_ROOT%{_appdir}
79
80 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
81 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
82 touch $RPM_BUILD_ROOT%{_sysconfdir}/config.php
83 touch $RPM_BUILD_ROOT%{_sysconfdir}/login.txt
84 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
85 ln -s %{_sysconfdir}/login.txt $RPM_BUILD_ROOT%{_appdir}/login.txt
86
87 ## Cleanup modules that are avaible in separate packages:
88 #for module in exif; do
89 #       rm -rf $RPM_BUILD_ROOT%{_appdir}/modules/$module
90 #done
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %triggerin -- apache1 < 1.3.37-3, apache1-base
96 %webapp_register apache %{_webapp}
97
98 %triggerun -- apache1 < 1.3.37-3, apache1-base
99 %webapp_unregister apache %{_webapp}
100
101 %triggerin -- apache < 2.2.0, apache-base
102 %webapp_register httpd %{_webapp}
103
104 %triggerun -- apache < 2.2.0, apache-base
105 %webapp_unregister httpd %{_webapp}
106
107 %triggerpostun -- %{name} < 1.5.2-0.13
108 /usr/sbin/webapp register httpd %{_webapp}
109 %service -q httpd reload
110
111 %files
112 %defattr(644,root,root,755)
113 %doc README*
114 %dir %attr(750,root,http) %{_sysconfdir}
115 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/login.txt
116 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
117 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
118 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
119 %dir %{_appdir}
120 %dir /var/lib/gallery
121 %dir %attr(770,root,http) /var/lib/gallery/albums
122 %{_appdir}/login.txt
123 %{_appdir}/*.php
124 %{_appdir}/*.inc
125 %{_appdir}/images
126 %{_appdir}/lib
127 %{_appdir}/modules
128 %{_appdir}/themes
129
130 %files setup
131 %defattr(644,root,root,755)
132 %{_appdir}/README.html
133 %{_appdir}/config.php
134 %{_appdir}/install
135 %{_appdir}/upgrade
This page took 0.068946 seconds and 3 git commands to generate.