]> git.pld-linux.org Git - packages/gallery-remote.git/blob - gallery-remote.spec
fa4099f073c04d344ac4c74e5e999138debfdbea
[packages/gallery-remote.git] / gallery-remote.spec
1 Summary:        Gallery Remote - client-side frontend to Gallery
2 Summary(pl):    Gallery Remote - frontend do Gallery dzia³aj±cy po stronie klienta
3 Name:           gallery-remote
4 Version:        1.4.1
5 Release:        0.12
6 License:        GPL v2
7 Group:          Applications/Publishing
8 Source0:        http://dl.sourceforge.net/gallery/GalleryRemote.%{version}.jar
9 # Source0-md5:  763af4f97120f5142222961f02e3943d
10 URL:            http://gallery.menalto.com/modules.php?op=modload&name=phpWiki&file=index&pagename=Gallery%20Remote
11 BuildRequires:  sed >= 4.0
12 Requires:       ImageMagick
13 Requires:       ImageMagick-coder-jpeg
14 Requires:       ImageMagick-coder-jpeg2
15 Requires:       ImageMagick-coder-png
16 Requires:       ImageMagick-coder-tiff
17 Requires:       jre >= 1.4
18 Requires:       libjpeg-progs
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _appdir %{_datadir}/%{name}
23
24 %description
25 Gallery Remote is a client-side Java application that provides users
26 with a rich front-end to Gallery. This application makes it easier to
27 upload images to your Gallery.
28
29 %description -l pl
30 Gallery Remote to aplikacja w Javie dzia³aj±ca po stronie klienta
31 udostêpniaj±ca u¿ytkownikom bogaty frontend do Gallery. Ta aplikacja
32 czyni ³atwiejszym umieszczanie obrazków w Gallery.
33
34 %prep
35 %setup -q -c
36 unzip -qq Disk1/InstData/Resource1.zip
37
38 # use better names
39 mv '$IA_PROJECT_DIR$' %{name}
40
41 cd %{name}
42
43 mv gallery_docs/dist/grpackage html
44 rm -f LICENSE # GPL v2
45 rm -rf */{win32,macos} # wrong os
46
47 # make it configured
48 mv imagemagick/im.properties{.preinstalled,}
49 mv imagemagick/HOWTO HOWTO.imagemagick
50 rm imagemagick/LICENSE # imagemagick license
51
52 # and jpegtran too
53 mv jpegtran/{linux/,}jpegtran.properties
54 rm jpegtran/linux/jpegtran # binary
55 rm jpegtran/jpegtran.preinstalled
56 rm -rf jpegtran/linux
57 sed -i -e '/^jp\.path/s/=.*/=jpegtran/' jpegtran/jpegtran.properties
58 # undos
59 sed -i -e 's,
60 $,,' jpegtran/jpegtran.properties
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 cd %{name}
65
66 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir}}
67 cp -a imagemagick img jpegtran lib $RPM_BUILD_ROOT%{_appdir}
68 cp -a defaults.properties rar*.* $RPM_BUILD_ROOT%{_appdir}
69 cp -a *.jar $RPM_BUILD_ROOT%{_appdir}
70 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
71 #!/bin/sh
72 exec java -cp %{_appdir}/GalleryRemote.jar com.gallery.GalleryRemote.GalleryRemote
73 EOF
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc %{name}/{ChangeLog,README,HOWTO.imagemagick,html}
81 %attr(755,root,root) %{_bindir}/*
82 %{_appdir}
This page took 0.057178 seconds and 2 git commands to generate.