]> git.pld-linux.org Git - packages/galib.git/blob - galib.spec
new version
[packages/galib.git] / galib.spec
1 Summary:        A C++ Library of Genetic Algorithm Components
2 Summary(pl):    Biblioteka C++ funkcji do algorytmów genetycznych
3 Name:           galib
4 Version:        246pre2
5 Release:        1
6 License:        MIT (base library), GPL (GNU portions in examples)
7 Group:          Libraries
8 Source0:        http://lancet.mit.edu/ga/dist/%{name}%{version}.tgz
9 # Source0-md5:  5a19b7692c3c18741cc0a120d36de165
10 URL:            http://lancet.mit.edu/ga/
11 BuildRequires:  libstdc++-devel
12 BuildRequires:  libtool >= 2:1.4d
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 GAlib contains a set of C++ genetic algorithm objects. The library
17 includes tools for using genetic algorithms to do optimization in any
18 C++ program using any representation and genetic operators. The
19 documentation includes an extensive overview of how to implement a
20 genetic algorithm as well as examples illustrating customizations to
21 the GAlib classes.
22
23 %description -l pl
24 GAlib zawiera zbiór obiektów C++ do algorytmów genetycznych.
25 Biblioteka zawiera narzêdzia do u¿ywania algorytmów genetycznych do
26 wykonywania optymalizacji w dowolnym programie C++ przy u¿yciu
27 dowolnej reprezentacji i operatorów genetycznych. Dokumentacja
28 zawiera obszerny opis sposobu implementacji algorytmu genetycznego, a
29 tak¿e przyk³ady ilustruj±ce dostosowanie klas GAliba do swoich
30 potrzeb.
31
32 %package devel
33 Summary:        Header files for GAlib
34 Summary(pl):    Pliki nag³ówkowe biblioteki GAlib
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libstdc++-devel
38
39 %description devel
40 This package contains header files for GAlib.
41
42 %description devel -l pl
43 Ten pakiet zawiera pliki nag³ówkowe biblioteki GAlib.
44
45 %package static
46 Summary:        Static version of GAlib
47 Summary(pl):    Statyczna wersja biblioteki GAlib
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static version of GAlib.
53
54 %description static -l pl
55 Statyczna wersja biblioteki GAlib.
56
57 %prep
58 %setup -q -n %{name}%{version}
59
60 %build
61 %{__make} -C ga \
62         CXX="libtool --mode=compile --tag CXX %{__cxx}" \
63         CXXFLAGS="%{rpmcflags}" \
64         LIB="libga.la" \
65         AR="libtool --mode=link %{__cxx} %{rpmldflags} -rpath %{_libdir} -o libga.la \$(OBJS:.o=.lo) #"
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_libdir}
70
71 %{__make} install -C ga \
72         LIB="libga.la" \
73         INSTALL="libtool --mode=install install" \
74         DESTDIR=$RPM_BUILD_ROOT%{_prefix}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README RELEASE-NOTES LICENSE
85 %attr(755,root,root) %{_libdir}/libga.so.*.*.*
86
87 %files devel
88 %defattr(644,root,root,755)
89 %doc doc/*
90 %attr(755,root,root) %{_libdir}/libga.so
91 %{_libdir}/libga.la
92 %{_includedir}/ga
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/libga.a
This page took 0.066877 seconds and 3 git commands to generate.