]> git.pld-linux.org Git - packages/galib.git/blob - galib.spec
- new release, much improved out-of-the-box behavior with various recent compilers
[packages/galib.git] / galib.spec
1 Summary:        A C++ Library of Genetic Algorithm Components
2 Summary(pl):    Biblioteka C++ funkcji do algorytmów genetycznych
3 Name:           galib
4 Version:        246
5 #%define        bver    pre2
6 Release:        0.1
7 License:        MIT (base library), GPL (GNU portions in examples)
8 Group:          Libraries
9 Source0:        http://lancet.mit.edu/ga/dist/%{name}%{version}.tgz
10 # Source0-md5:  e61efce22161907449b07f8472eb7c7c
11 URL:            http://lancet.mit.edu/ga/
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  libtool >= 2:1.4d
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GAlib contains a set of C++ genetic algorithm objects. The library
18 includes tools for using genetic algorithms to do optimization in any
19 C++ program using any representation and genetic operators. The
20 documentation includes an extensive overview of how to implement a
21 genetic algorithm as well as examples illustrating customizations to
22 the GAlib classes.
23
24 %description -l pl
25 GAlib zawiera zbiór obiektów C++ do algorytmów genetycznych.
26 Biblioteka zawiera narzêdzia do u¿ywania algorytmów genetycznych do
27 wykonywania optymalizacji w dowolnym programie C++ przy u¿yciu
28 dowolnej reprezentacji i operatorów genetycznych. Dokumentacja
29 zawiera obszerny opis sposobu implementacji algorytmu genetycznego, a
30 tak¿e przyk³ady ilustruj±ce dostosowanie klas GAliba do swoich
31 potrzeb.
32
33 %package devel
34 Summary:        Header files for GAlib
35 Summary(pl):    Pliki nag³ówkowe biblioteki GAlib
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libstdc++-devel
39
40 %description devel
41 This package contains header files for GAlib.
42
43 %description devel -l pl
44 Ten pakiet zawiera pliki nag³ówkowe biblioteki GAlib.
45
46 %package static
47 Summary:        Static version of GAlib
48 Summary(pl):    Statyczna wersja biblioteki GAlib
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static version of GAlib.
54
55 %description static -l pl
56 Statyczna wersja biblioteki GAlib.
57
58 %prep
59 %setup -q -n %{name}%{version}
60
61 %build
62 %{__make} -C ga \
63         CXX="libtool --mode=compile --tag CXX %{__cxx}" \
64         CXXFLAGS="%{rpmcflags}" \
65         LIB="libga.la" \
66         AR="libtool --mode=link %{__cxx} %{rpmldflags} -rpath %{_libdir} -o libga.la \$(OBJS:.o=.lo) #"
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_libdir}
71
72 %{__make} install -C ga \
73         LIB="libga.la" \
74         INSTALL="libtool --mode=install install" \
75         DESTDIR=$RPM_BUILD_ROOT%{_prefix}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README RELEASE-NOTES LICENSE
86 %attr(755,root,root) %{_libdir}/libga.so.*.*.*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %doc doc/*
91 %attr(755,root,root) %{_libdir}/libga.so
92 %{_libdir}/libga.la
93 %{_includedir}/ga
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libga.a
This page took 0.069592 seconds and 3 git commands to generate.