]> git.pld-linux.org Git - packages/galib.git/blob - galib.spec
- up to 247
[packages/galib.git] / galib.spec
1 Summary:        A C++ library of genetic algorithm components
2 Summary(pl.UTF-8):      Biblioteka C++ funkcji do algorytmów genetycznych
3 Name:           galib
4 Version:        247
5 Release:        1
6 License:        MIT (base library), GPL (GNU portions in examples)
7 Group:          Libraries
8 Source0:        http://lancet.mit.edu/ga/dist/%{name}%{version}.tgz
9 # Source0-md5:  2b6a28fd06d4c7c4d0bb39c92b2b376c
10 Patch0:         %{name}246_gcc4.patch
11 URL:            http://lancet.mit.edu/ga/
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  libtool >= 2:1.4d
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 GAlib contains a set of C++ genetic algorithm objects. The library
18 includes tools for using genetic algorithms to do optimization in any
19 C++ program using any representation and genetic operators. The
20 documentation includes an extensive overview of how to implement a
21 genetic algorithm as well as examples illustrating customizations to
22 the GAlib classes.
23
24 %description -l pl.UTF-8
25 GAlib zawiera zbiór obiektów C++ do algorytmów genetycznych.
26 Biblioteka zawiera narzędzia do używania algorytmów genetycznych do
27 wykonywania optymalizacji w dowolnym programie C++ przy użyciu
28 dowolnej reprezentacji i operatorów genetycznych. Dokumentacja
29 zawiera obszerny opis sposobu implementacji algorytmu genetycznego, a
30 także przykłady ilustrujące dostosowanie klas GAliba do swoich
31 potrzeb.
32
33 %package devel
34 Summary:        Header files for GAlib
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GAlib
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libstdc++-devel
39
40 %description devel
41 This package contains header files for GAlib.
42
43 %description devel -l pl.UTF-8
44 Ten pakiet zawiera pliki nagłówkowe biblioteki GAlib.
45
46 %package static
47 Summary:        Static version of GAlib
48 Summary(pl.UTF-8):      Statyczna wersja biblioteki GAlib
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static version of GAlib.
54
55 %description static -l pl.UTF-8
56 Statyczna wersja biblioteki GAlib.
57
58 %prep
59 %setup -q -n %{name}%{version}
60 %patch0 -p1
61
62 %build
63 %{__make} -C ga \
64         CXX="libtool --mode=compile --tag CXX %{__cxx}" \
65         CXXFLAGS="%{rpmcflags}" \
66         LIB="libga.la" \
67         AR="libtool --mode=link %{__cxx} %{rpmldflags} -rpath %{_libdir} -o libga.la \$(OBJS:.o=.lo) #"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_libdir}
72
73 %{__make} install -C ga \
74         LIB="libga.la" \
75         INSTALL="libtool --mode=install install" \
76         DESTDIR=$RPM_BUILD_ROOT%{_prefix} \
77         LIB_DEST_DIR=$RPM_BUILD_ROOT%{_libdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc README RELEASE-NOTES LICENSE
88 %attr(755,root,root) %{_libdir}/libga.so.*.*.*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %doc doc/*
93 %attr(755,root,root) %{_libdir}/libga.so
94 %{_libdir}/libga.la
95 %{_includedir}/ga
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/libga.a
This page took 0.073777 seconds and 3 git commands to generate.