]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- release 2 (xulrunner 1.8.1.5)
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # enable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
13 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
15 Name:           galeon
16 Version:        2.0.3
17 Release:        2
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
22 # Source0-md5:  610fe2258e680f68bdf36ce7c1ba2a24
23 Source1:        %{name}-config-tool.1
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-home_etc.patch
26 Patch2:         %{name}-po.patch
27 Patch3:         %{name}-mozilla.patch
28 Patch4:         %{name}-agent.patch
29 URL:            http://galeon.sourceforge.net/
30 BuildRequires:  GConf2-devel >= 2.4.0
31 BuildRequires:  ORBit2-devel >= 2.8.3
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib2-devel >= 1:2.4.4
37 BuildRequires:  gnome-desktop-devel >= 2.9.91
38 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
39 BuildRequires:  gtk+2-devel >= 2:2.4.4
40 BuildRequires:  intltool
41 BuildRequires:  libbonoboui-devel >= 2.4.0
42 BuildRequires:  libglade2-devel >= 1:2.4.0
43 BuildRequires:  libgnomeui-devel >= 2.6.0
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2.6.6
47 BuildRequires:  xulrunner-devel >= 1.8.0.4
48 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpmbuild(macros) >= 1.197
51 BuildRequires:  scrollkeeper >= 0.1.4
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  scrollkeeper
54 Requires(post,preun):   GConf2
55 Requires:       glib2 >= 1:2.4.4
56 Requires:       gtk+2 >= 2:2.4.4
57 Requires:       libbonobo >= 2.4.0
58 %requires_eq_to xulrunner xulrunner-devel
59 Provides:       wwwbrowser
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # can be provided by mozilla or mozilla-embedded
63 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
64 # we have strict deps for it
65 %define         _noautoreq      libxpcom.so
66
67 %if %{with gcc2}
68 %define         __cc            gcc2
69 %define         __cxx           gcc2
70 %endif
71
72 %description
73 GNOME browser based on Gecko (Mozilla rendering engine).
74
75 %description -l pl.UTF-8
76 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
77 interpretacji stron Mozilli).
78
79 %description -l pt_BR.UTF-8
80 O galeon é um browser para o GNOME baseado no mozilla.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88 %patch4 -p1
89
90 # regenerate - didn't compile with ORBit2 2.7.2
91 cd idl
92 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
93 mv Galeon*.[ch] ../src
94
95 %build
96 rm -f missing
97 cp /usr/share/automake/mkinstalldirs .
98 %{__glib_gettextize}
99 %{__intltoolize}
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoheader}
103 %{__autoconf}
104 %{__automake}
105 %configure \
106         --disable-schemas-install \
107         %if %{with nautilus}
108         --enable-nautilus-view=yes
109         %else
110         --enable-nautilus-view=no
111         %endif
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_mandir}/man1
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
122
123 # No components installed now.
124 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
125
126 # galeon-2.0.mo, but gnome/help/galeon
127 %find_lang galeon-2.0 --with-gnome --all-name
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 %scrollkeeper_update_post
134 %gconf_schema_install galeon.schemas
135 %update_desktop_database_post
136
137 %preun
138 %gconf_schema_uninstall galeon.schemas
139
140 %postun
141 %scrollkeeper_update_postun
142 %update_desktop_database_postun
143
144 %files -f galeon-2.0.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README*
147 %attr(755,root,root) %{_bindir}/*
148 %{_libdir}/bonobo/servers/*
149 %{_datadir}/galeon
150 %{_desktopdir}/*.desktop
151 %{_datadir}/gnome-2.0/ui/*.xml
152 %{_omf_dest_dir}/%{name}
153 %{_datadir}/sounds/galeon
154 %{_pixmapsdir}/*
155 %{_sysconfdir}/gconf/schemas/*
156 %{_sysconfdir}/sound/events/*
157 %{_mandir}/man1/*
This page took 0.360239 seconds and 4 git commands to generate.