]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- updated to 2.0.4
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # enable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10 Summary:        Galeon - gecko-based GNOME web browser
11 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
12 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
13 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
14 Name:           galeon
15 Version:        2.0.4
16 Release:        1
17 Epoch:          2
18 License:        GPL
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
21 # Source0-md5:  ee960c2d36b9bc7ab61ee77b1e7ee020
22 Source1:        %{name}-config-tool.1
23 Patch0:         %{name}-desktop.patch
24 Patch1:         %{name}-home_etc.patch
25 Patch2:         %{name}-po.patch
26 Patch3:         %{name}-mozilla.patch
27 Patch4:         %{name}-agent.patch
28 URL:            http://galeon.sourceforge.net/
29 BuildRequires:  GConf2-devel >= 2.4.0
30 BuildRequires:  ORBit2-devel >= 2.8.3
31 BuildRequires:  autoconf >= 2.52
32 BuildRequires:  automake
33 BuildRequires:  bison
34 BuildRequires:  gettext-devel
35 BuildRequires:  glib2-devel >= 1:2.4.4
36 BuildRequires:  gnome-desktop-devel >= 2.9.91
37 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
38 BuildRequires:  gtk+2-devel >= 2:2.4.4
39 BuildRequires:  intltool
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 1:2.4.0
42 BuildRequires:  libgnomeui-devel >= 2.6.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.6.6
46 BuildRequires:  xulrunner-devel >= 1.8.0.4
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(find_lang) >= 1.23
50 BuildRequires:  rpmbuild(macros) >= 1.197
51 BuildRequires:  scrollkeeper >= 0.1.4
52 BuildRequires:  sed >= 4.0
53 Requires(post,postun):  desktop-file-utils
54 Requires(post,postun):  scrollkeeper
55 Requires(post,preun):   GConf2
56 Requires:       glib2 >= 1:2.4.4
57 Requires:       gtk+2 >= 2:2.4.4
58 Requires:       libbonobo >= 2.4.0
59 %requires_eq_to xulrunner xulrunner-devel
60 Provides:       wwwbrowser
61 # sr@Latn vs. sr@latin
62 Conflicts:      glibc-misc < 6:2.7
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # can be provided by mozilla or mozilla-embedded
66 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
67 # we have strict deps for it
68 %define         _noautoreq      libxpcom.so
69
70 %if %{with gcc2}
71 %define         __cc            gcc2
72 %define         __cxx           gcc2
73 %endif
74
75 %description
76 GNOME browser based on Gecko (Mozilla rendering engine).
77
78 %description -l pl.UTF-8
79 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
80 interpretacji stron Mozilli).
81
82 %description -l pt_BR.UTF-8
83 O galeon é um browser para o GNOME baseado no mozilla.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90 %patch3 -p1
91 %patch4 -p1
92
93 sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
94 mv po/sr\@{Latn,latin}.po
95
96 # regenerate - didn't compile with ORBit2 2.7.2
97 cd idl
98 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
99 mv Galeon*.[ch] ../src
100
101 %build
102 cp /usr/share/automake/mkinstalldirs .
103 %{__glib_gettextize}
104 %{__intltoolize}
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoheader}
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         --disable-schemas-install \
112         %if %{with nautilus}
113         --enable-nautilus-view=yes
114         %else
115         --enable-nautilus-view=no
116         %endif
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_mandir}/man1
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
127
128 # No components installed now.
129 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
130
131 # galeon-2.0.mo, but gnome/help/galeon
132 %find_lang galeon-2.0 --with-gnome --with-omf --all-name
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 %scrollkeeper_update_post
139 %gconf_schema_install galeon.schemas
140 %update_desktop_database_post
141
142 %preun
143 %gconf_schema_uninstall galeon.schemas
144
145 %postun
146 %scrollkeeper_update_postun
147 %update_desktop_database_postun
148
149 %files -f galeon-2.0.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS README*
152 %attr(755,root,root) %{_bindir}/*
153 %{_libdir}/bonobo/servers/*
154 %{_datadir}/galeon
155 %{_desktopdir}/*.desktop
156 %{_datadir}/gnome-2.0/ui/*.xml
157 %{_datadir}/sounds/galeon
158 %{_pixmapsdir}/*
159 %{_sysconfdir}/gconf/schemas/galeon.schemas
160 %{_sysconfdir}/sound/events/*
161 %{_mandir}/man1/*
This page took 0.032805 seconds and 3 git commands to generate.