]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- rel. 2 to rebuild with mozilla 1.5a
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.5a
9
10 Summary:        Galeon - gecko-based GNOME web browser
11 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
12 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
13 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
14 Name:           galeon
15 Version:        1.3.7
16 Release:        2
17 Epoch:          2
18 License:        GPL
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
21 # Source0-md5:  9b89ebfb0a4019f0edd3ef227abc111f
22 Source1:        %{name}-config-tool.1
23 URL:            http://galeon.sourceforge.net/
24 Patch0:         %{name}-desktop.patch
25 BuildRequires:  GConf2-devel >= 2.0.0
26 BuildRequires:  ORBit2-devel >= 2.0.0
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  bison
30 BuildRequires:  gettext-devel
31 BuildRequires:  gnome-vfs2-devel >= 2.0.0
32 BuildRequires:  gtk+2-devel >= 2.0.6
33 BuildRequires:  intltool
34 BuildRequires:  libbonobo-devel >= 2.3.1-4
35 BuildRequires:  libbonoboui-devel >= 2.1.1
36 BuildRequires:  libglade2-devel >= 2.0.0
37 BuildRequires:  libgnomeui-devel >= 2.0.5
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libxml2-devel >= 2.4.0
40 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
41 BuildRequires:  nautilus-devel >= 2.0.0
42 BuildRequires:  openssl-devel >= 0.9.7
43 BuildRequires:  scrollkeeper >= 0.1.4
44 BuildRequires:  rpm-build >= 4.1-10
45 Requires:       libbonobo >= 2.3.1-4
46 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
47 Requires(post): GConf2
48 Requires(post): mozilla
49 Requires(post): scrollkeeper
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 # can be provided by mozilla or mozilla-embedded
53 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
54
55 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
56 %define         __cc            gcc2
57 %define         __cxx           gcc2
58 %endif
59
60 %description
61 Gnome browser based on Gecko (Mozilla rendering engine).
62
63 %description -l pl
64 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
65 interpretacji stron Mozilli).
66
67 %description -l pt_BR
68 O galeon é um browser para o gnome baseado no mozilla.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 # regenerate - didn't compile with ORBit2 2.7.2
75 cd idl
76 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
77 mv Galeon*.[ch] ../src
78
79 %build
80 rm -f missing
81 glib-gettextize --copy --force
82 intltoolize --copy --force
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoheader}
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --with-mozilla-libs=%{_libdir} \
90         --with-mozilla-includes=%{_includedir}/mozilla \
91         --with-mozilla-home=%{_libdir}/mozilla \
92         --enable-nls \
93         --disable-included-gettext \
94         --disable-schemas-install \
95         --disable-werror \
96         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
97         --enable-nautilus-view=yes
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_mandir}/man1
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT 
107
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
109
110 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
111
112 # galeon-2.0.mo, but gnome/help/galeon
113 %find_lang galeon-2.0 --with-gnome --all-name
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post
119 /usr/bin/scrollkeeper-update
120 %gconf_schema_install
121
122 %postun -p /usr/bin/scrollkeeper-update
123
124 %files -f galeon-2.0.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog NEWS README*
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/%{name}
129 %{_libdir}/bonobo/servers/*
130 %{_datadir}/galeon
131 %{_desktopdir}/*
132 %{_datadir}/gnome-2.0/ui/*.xml
133 %{_omf_dest_dir}/%{name}
134 %{_datadir}/sounds/galeon
135 %{_pixmapsdir}/*
136 %{_sysconfdir}/gconf/schemas/*
137 %{_sysconfdir}/sound/events/*
138 %{_mandir}/man1/*
This page took 0.030946 seconds and 3 git commands to generate.