]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
b16c0b1e1e3685419f1b68239676856cf6b11da2
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use
5 #                         mozilla instead. To compile wit this option, You
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.5b
9 %define         snap    20030905
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.8
17 Release:        1
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
22 Source0:        http://dl.sf.net/%{name}/%{name}-%{version}.tar.bz2
23 # Source0-md5:  a66a63d33b68f52672a2ab8532b17245
24 Source1:        %{name}-config-tool.1
25 URL:            http://galeon.sourceforge.net/
26 Patch0:         %{name}-desktop.patch
27 BuildRequires:  GConf2-devel >= 2.0.0
28 BuildRequires:  ORBit2-devel >= 2.7.5-1
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  bison
32 BuildRequires:  gettext-devel
33 BuildRequires:  gnome-vfs2-devel >= 2.0.0
34 BuildRequires:  gtk+2-devel >= 2.0.6
35 BuildRequires:  intltool
36 BuildRequires:  libbonobo-devel >= 2.3.1-4
37 BuildRequires:  libbonoboui-devel >= 2.3.3-2
38 BuildRequires:  libglade2-devel >= 2.0.0
39 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libxml2-devel >= 2.4.0
42 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
43 BuildRequires:  nautilus-devel >= 2.3.7-3
44 BuildRequires:  openssl-devel >= 0.9.7
45 BuildRequires:  scrollkeeper >= 0.1.4
46 BuildRequires:  rpm-build >= 4.1-10
47 Requires(post): GConf2
48 Requires(post): mozilla
49 Requires(post): scrollkeeper
50 Requires:       libbonobo >= 2.3.1-4
51 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 # can be provided by mozilla or mozilla-embedded
55 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
56
57 %if %{?_with_gcc2:1}%{!?_with_gcc2:0}
58 %define         __cc            gcc2
59 %define         __cxx           gcc2
60 %endif
61
62 %description
63 GNOME browser based on Gecko (Mozilla rendering engine).
64
65 %description -l pl
66 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
67 interpretacji stron Mozilli).
68
69 %description -l pt_BR
70 O galeon é um browser para o GNOME baseado no mozilla.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 # regenerate - didn't compile with ORBit2 2.7.2
77 cd idl
78 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
79 mv Galeon*.[ch] ../src
80
81 %build
82 rm -f missing
83 glib-gettextize --copy --force
84 intltoolize --copy --force
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoheader}
88 %{__autoconf}
89 %{__automake}
90 %configure \
91         --with-mozilla-libs=%{_libdir} \
92         --with-mozilla-includes=%{_includedir}/mozilla \
93         --with-mozilla-home=%{_libdir}/mozilla \
94         --enable-nls \
95         --disable-included-gettext \
96         --disable-schemas-install \
97         --disable-werror \
98         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
99         --enable-nautilus-view=yes
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_mandir}/man1
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
111
112 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
113
114 # galeon-2.0.mo, but gnome/help/galeon
115 %find_lang galeon-2.0 --with-gnome --all-name
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 /usr/bin/scrollkeeper-update
122 %gconf_schema_install
123
124 %postun -p /usr/bin/scrollkeeper-update
125
126 %files -f galeon-2.0.lang
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README*
129 %attr(755,root,root) %{_bindir}/*
130 %attr(755,root,root) %{_libdir}/%{name}
131 %{_libdir}/bonobo/servers/*
132 %{_datadir}/galeon
133 %{_desktopdir}/*
134 %{_datadir}/gnome-2.0/ui/*.xml
135 %{_omf_dest_dir}/%{name}
136 %{_datadir}/sounds/galeon
137 %{_pixmapsdir}/*
138 %{_sysconfdir}/gconf/schemas/*
139 %{_sysconfdir}/sound/events/*
140 %{_mandir}/man1/*
This page took 0.040029 seconds and 2 git commands to generate.