]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- rel 5
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # disable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
13 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
15 Name:           galeon
16 Version:        2.0.2
17 Release:        5
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
22 # Source0-md5:  43d395aa3e6424d980919942e5499dba
23 Source1:        %{name}-config-tool.1
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-home_etc.patch
26 Patch2:         %{name}-po.patch
27 Patch3:         %{name}-mozilla.patch
28 URL:            http://galeon.sourceforge.net/
29 BuildRequires:  GConf2-devel >= 2.4.0
30 BuildRequires:  ORBit2-devel >= 2.8.3
31 BuildRequires:  autoconf >= 2.52
32 BuildRequires:  automake
33 BuildRequires:  bison
34 BuildRequires:  gettext-devel
35 BuildRequires:  glib2-devel >= 1:2.4.4
36 BuildRequires:  gnome-desktop-devel >= 2.9.91
37 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
38 BuildRequires:  gtk+2-devel >= 2:2.4.4
39 BuildRequires:  intltool
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 1:2.4.0
42 BuildRequires:  libgnomeui-devel >= 2.6.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.6.6
46 BuildRequires:  xulrunner-devel >= 1.8.0.4
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.197
50 BuildRequires:  scrollkeeper >= 0.1.4
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  scrollkeeper
53 Requires(post,preun):   GConf2
54 Requires:       glib2 >= 1:2.4.4
55 Requires:       gtk+2 >= 2:2.4.4
56 Requires:       libbonobo >= 2.4.0
57 %requires_eq_to xulrunner xulrunner-devel
58 Provides:       wwwbrowser
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # can be provided by mozilla or mozilla-embedded
62 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
63
64 %if %{with gcc2}
65 %define         __cc            gcc2
66 %define         __cxx           gcc2
67 %endif
68
69 %description
70 GNOME browser based on Gecko (Mozilla rendering engine).
71
72 %description -l pl.UTF-8
73 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
74 interpretacji stron Mozilli).
75
76 %description -l pt_BR.UTF-8
77 O galeon é um browser para o GNOME baseado no mozilla.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 %patch3 -p1
85
86 # regenerate - didn't compile with ORBit2 2.7.2
87 cd idl
88 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
89 mv Galeon*.[ch] ../src
90
91 %build
92 rm -f missing
93 cp /usr/share/automake/mkinstalldirs .
94 %{__glib_gettextize}
95 %{__intltoolize}
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoheader}
99 %{__autoconf}
100 %{__automake}
101 %configure \
102         --disable-schemas-install \
103         %if %{with nautilus}
104         --enable-nautilus-view=yes
105         %else
106         --enable-nautilus-view=no
107         %endif
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT%{_mandir}/man1
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
118
119 # No components installed now.
120 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
121
122 # galeon-2.0.mo, but gnome/help/galeon
123 %find_lang galeon-2.0 --with-gnome --all-name
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post
129 %scrollkeeper_update_post
130 %gconf_schema_install galeon.schemas
131 %update_desktop_database_post
132
133 %preun
134 %gconf_schema_uninstall galeon.schemas
135
136 %postun
137 %scrollkeeper_update_postun
138 %update_desktop_database_postun
139
140 %files -f galeon-2.0.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README*
143 %attr(755,root,root) %{_bindir}/*
144 %{_libdir}/bonobo/servers/*
145 %{_datadir}/galeon
146 %{_desktopdir}/*.desktop
147 %{_datadir}/gnome-2.0/ui/*.xml
148 %{_omf_dest_dir}/%{name}
149 %{_datadir}/sounds/galeon
150 %{_pixmapsdir}/*
151 %{_sysconfdir}/gconf/schemas/*
152 %{_sysconfdir}/sound/events/*
153 %{_mandir}/man1/*
This page took 0.081582 seconds and 3 git commands to generate.