]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- fix for building with xulrunner 1.9.1.x, taken from gentoo
[packages/galeon.git] / galeon.spec
1 #
2 # TODO:
3 #   - force galeon to use old SSL dialogs using nsIBadCertListener, ie. port
4 #     EphyBadCertRejector from Epiphany, this will fix issues with https sites
5 #     using self signed and expired certificates or mismatches in domain names
6 #
7 # Conditional build:
8 %bcond_with     nautilus        # enable nautilus view
9 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
10                                 # plugin (better get gcc3-compiled one).
11                                 # Flash plugin seems to still not work, use
12                                 # mozilla instead. To compile wit this option, You
13                                 # have to install mozilla compiled with gcc2.
14 #
15 Summary:        Galeon - gecko-based GNOME web browser
16 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
17 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
18 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
19 Name:           galeon
20 Version:        2.0.7
21 Release:        7
22 Epoch:          2
23 License:        GPL
24 Group:          X11/Applications/Networking
25 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
26 # Source0-md5:  2eede1f43e3f6f2ac4ce7d4db99b15b2
27 Source1:        %{name}-config-tool.1
28 Patch0:         %{name}-desktop.patch
29 Patch1:         %{name}-home_etc.patch
30 Patch2:         %{name}-ti-agent.patch
31 Patch3:         %{name}-agent.patch
32 Patch4:         %{name}-libxul.patch
33 Patch5:         %{name}-xul_includes_fix.patch
34 URL:            http://galeon.sourceforge.net/
35 BuildRequires:  GConf2-devel >= 2.4.0
36 BuildRequires:  ORBit2-devel >= 2.8.3
37 BuildRequires:  autoconf >= 2.52
38 BuildRequires:  automake
39 BuildRequires:  bison
40 BuildRequires:  gettext-devel
41 BuildRequires:  glib2-devel >= 1:2.4.4
42 BuildRequires:  gnome-desktop-devel >= 2.9.91
43 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
44 BuildRequires:  gtk+2-devel >= 2:2.4.4
45 BuildRequires:  intltool
46 BuildRequires:  libbonoboui-devel >= 2.4.0
47 BuildRequires:  libglade2-devel >= 1:2.4.0
48 BuildRequires:  libgnomeui-devel >= 2.6.0
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtool
51 BuildRequires:  libxml2-devel >= 2.6.6
52 BuildRequires:  xulrunner-devel >= 1.8.0.4
53 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
54 BuildRequires:  pkgconfig
55 BuildRequires:  rpm >= 4.4.9-56
56 BuildRequires:  rpmbuild(find_lang) >= 1.23
57 BuildRequires:  rpmbuild(macros) >= 1.197
58 BuildRequires:  scrollkeeper >= 0.1.4
59 BuildRequires:  sed >= 4.0
60 Requires(post,postun):  desktop-file-utils
61 Requires(post,postun):  scrollkeeper
62 Requires(post,preun):   GConf2
63 Requires:       glib2 >= 1:2.4.4
64 Requires:       gtk+2 >= 2:2.4.4
65 Requires:       libbonobo >= 2.4.0
66 %requires_eq_to xulrunner xulrunner-devel
67 Provides:       wwwbrowser
68 # sr@Latn vs. sr@latin
69 Conflicts:      glibc-misc < 6:2.7
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 # can be provided by mozilla or mozilla-embedded
73 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
74 # we have strict deps for it
75 %define         _noautoreq      libxpcom.so
76
77 %if %{with gcc2}
78 %define         __cc            gcc2
79 %define         __cxx           gcc2
80 %endif
81
82 %description
83 GNOME browser based on Gecko (Mozilla rendering engine).
84
85 %description -l pl.UTF-8
86 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
87 interpretacji stron Mozilli).
88
89 %description -l pt_BR.UTF-8
90 O galeon é um browser para o GNOME baseado no mozilla.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %if "%{pld_release}" == "ti"
97 %patch2 -p1
98 %else
99 %patch3 -p1
100 %endif
101 %patch4 -p1
102 %patch5 -p1
103
104 sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
105 mv po/sr\@{Latn,latin}.po
106
107 # regenerate - didn't compile with ORBit2 2.7.2
108 cd idl
109 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
110 mv Galeon*.[ch] ../src
111
112 %build
113 cp /usr/share/automake/mkinstalldirs .
114 %{__glib_gettextize}
115 %{__intltoolize}
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoheader}
119 %{__autoconf}
120 %{__automake}
121 %configure \
122         --disable-schemas-install \
123         %if %{with nautilus}
124         --enable-nautilus-view=yes
125         %else
126         --enable-nautilus-view=no
127         %endif
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_mandir}/man1
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
138
139 # No components installed now.
140 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
141
142 # galeon-2.0.mo, but gnome/help/galeon
143 %find_lang galeon-2.0 --with-gnome --with-omf --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 %scrollkeeper_update_post
150 %gconf_schema_install galeon.schemas
151 %update_desktop_database_post
152
153 %preun
154 %gconf_schema_uninstall galeon.schemas
155
156 %postun
157 %scrollkeeper_update_postun
158 %update_desktop_database_postun
159
160 %files -f galeon-2.0.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS ChangeLog NEWS README*
163 %attr(755,root,root) %{_bindir}/*
164 %{_libdir}/bonobo/servers/*
165 %{_datadir}/galeon
166 %{_desktopdir}/*.desktop
167 %{_datadir}/gnome-2.0/ui/*.xml
168 %{_datadir}/sounds/galeon
169 %{_pixmapsdir}/*
170 %{_sysconfdir}/gconf/schemas/galeon.schemas
171 %{_sysconfdir}/sound/events/*
172 %{_mandir}/man1/*
This page took 0.550327 seconds and 3 git commands to generate.