]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- updated to snap 20030404
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.4a
9 %define         snap            20030404
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.3
17 Release:        1.%{snap}
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 #Source0:       http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
22 Source0:        %{name}-%{version}-%{snap}.tar.bz2
23 Source1:        %{name}-config-tool.1
24 URL:            http://galeon.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  GConf2-devel
28 BuildRequires:  ORBit2-devel
29 BuildRequires:  bison
30 BuildRequires:  bonobo-activation-devel >= 2.2.0
31 BuildRequires:  gettext-devel
32 BuildRequires:  gnome-vfs2-devel
33 BuildRequires:  gtk+2-devel >= 2.0.6
34 BuildRequires:  intltool
35 BuildRequires:  libglade2-devel
36 BuildRequires:  libgnomeui-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libxml2-devel
39 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
40 BuildRequires:  nautilus-devel >= 2.0.0
41 BuildRequires:  openssl-devel >= 0.9.7
42 BuildRequires:  scrollkeeper
43 BuildRequires:  bonobo-activation >= 2.2.0
44 BuildRequires:  rpm-build >= 4.1-10
45 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
46 Requires(post): GConf2
47 Requires(post): mozilla
48 Requires(post): scrollkeeper
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 # can be provided by mozilla or mozilla-embedded
52 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
53
54 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
55 %define         __cc            gcc2
56 %define         __cxx           gcc2
57 %endif
58
59 %description
60 Gnome browser based on Gecko (Mozilla rendering engine).
61
62 %description -l pl
63 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
64 interpretacji stron Mozilli).
65
66 %description -l pt_BR
67 O galeon é um browser para o gnome baseado no mozilla.
68
69 %prep
70 %setup -q
71
72 %build
73 rm -f missing
74 glib-gettextize --copy --force
75 intltoolize --copy --force
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoheader}
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         --with-mozilla-libs=%{_libdir} \
83         --with-mozilla-includes=%{_includedir}/mozilla \
84         --with-mozilla-home=%{_libdir}/mozilla \
85         --enable-nls \
86         --disable-included-gettext \
87         --disable-schemas-install \
88         --disable-werror \
89         --with-mozilla-snapshot=1.4a \
90         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
91         --enable-nautilus-view=yes
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_mandir}/man1
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT 
101
102 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
103
104 %find_lang galeon-2.0
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 /usr/bin/scrollkeeper-update
111 umask 022
112 rm -f %{_libdir}/mozilla/component.reg
113 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
114 %gconf_schema_install
115
116 %postun -p /usr/bin/scrollkeeper-update
117
118 %files -f galeon-2.0.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS README*
121 %attr(755,root,root) %{_bindir}/*
122 %{_libdir}/%{name}
123 %{_libdir}/bonobo/servers/*
124 %{_datadir}/galeon
125 %{_datadir}/applications/*
126 %{_datadir}/gnome/help/*
127 %{_datadir}/gnome-2.0/ui/*.xml
128 %{_omf_dest_dir}/%{name}
129 %{_datadir}/sounds/galeon
130 %{_pixmapsdir}/*
131 %{_sysconfdir}/gconf/schemas/*
132 %{_sysconfdir}/sound/events/*
133 %{_mandir}/man1/*
This page took 0.058384 seconds and 3 git commands to generate.