]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- use better way to fix locale name
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # enable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
13 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
15 Name:           galeon
16 Version:        2.0.3
17 Release:        6
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
22 # Source0-md5:  610fe2258e680f68bdf36ce7c1ba2a24
23 Source1:        %{name}-config-tool.1
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-home_etc.patch
26 Patch2:         %{name}-po.patch
27 Patch3:         %{name}-mozilla.patch
28 Patch4:         %{name}-agent.patch
29 URL:            http://galeon.sourceforge.net/
30 BuildRequires:  GConf2-devel >= 2.4.0
31 BuildRequires:  ORBit2-devel >= 2.8.3
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib2-devel >= 1:2.4.4
37 BuildRequires:  gnome-desktop-devel >= 2.9.91
38 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
39 BuildRequires:  gtk+2-devel >= 2:2.4.4
40 BuildRequires:  intltool
41 BuildRequires:  libbonoboui-devel >= 2.4.0
42 BuildRequires:  libglade2-devel >= 1:2.4.0
43 BuildRequires:  libgnomeui-devel >= 2.6.0
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2.6.6
47 BuildRequires:  xulrunner-devel >= 1.8.0.4
48 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
49 BuildRequires:  pkgconfig
50 # support for --with-omf in find_lang.sh
51 BuildRequires:  rpm-build >= 4.4.9-10
52 BuildRequires:  rpmbuild(macros) >= 1.197
53 BuildRequires:  scrollkeeper >= 0.1.4
54 Requires(post,postun):  desktop-file-utils
55 Requires(post,postun):  scrollkeeper
56 Requires(post,preun):   GConf2
57 Requires:       glib2 >= 1:2.4.4
58 Requires:       gtk+2 >= 2:2.4.4
59 Requires:       libbonobo >= 2.4.0
60 %requires_eq_to xulrunner xulrunner-devel
61 Provides:       wwwbrowser
62 # sr@Latn vs. sr@latin
63 Conflicts:      glibc-misc < 6:2.7
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 # can be provided by mozilla or mozilla-embedded
67 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
68 # we have strict deps for it
69 %define         _noautoreq      libxpcom.so
70
71 %if %{with gcc2}
72 %define         __cc            gcc2
73 %define         __cxx           gcc2
74 %endif
75
76 %description
77 GNOME browser based on Gecko (Mozilla rendering engine).
78
79 %description -l pl.UTF-8
80 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
81 interpretacji stron Mozilli).
82
83 %description -l pt_BR.UTF-8
84 O galeon é um browser para o GNOME baseado no mozilla.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93
94 sed -i -e s#sr\@Latn#sr\@latin# configure.in
95 mv po/sr\@{Latn,latin}.po
96
97 # regenerate - didn't compile with ORBit2 2.7.2
98 cd idl
99 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
100 mv Galeon*.[ch] ../src
101
102 %build
103 rm -f missing
104 cp /usr/share/automake/mkinstalldirs .
105 %{__glib_gettextize}
106 %{__intltoolize}
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoheader}
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         --disable-schemas-install \
114         %if %{with nautilus}
115         --enable-nautilus-view=yes
116         %else
117         --enable-nautilus-view=no
118         %endif
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_mandir}/man1
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
129
130 # No components installed now.
131 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
132
133 # galeon-2.0.mo, but gnome/help/galeon
134 %find_lang galeon-2.0 --with-gnome --with-omf --all-name
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 %scrollkeeper_update_post
141 %gconf_schema_install galeon.schemas
142 %update_desktop_database_post
143
144 %preun
145 %gconf_schema_uninstall galeon.schemas
146
147 %postun
148 %scrollkeeper_update_postun
149 %update_desktop_database_postun
150
151 %files -f galeon-2.0.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README*
154 %attr(755,root,root) %{_bindir}/*
155 %{_libdir}/bonobo/servers/*
156 %{_datadir}/galeon
157 %{_desktopdir}/*.desktop
158 %{_datadir}/gnome-2.0/ui/*.xml
159 %{_datadir}/sounds/galeon
160 %{_pixmapsdir}/*
161 %{_sysconfdir}/gconf/schemas/galeon.schemas
162 %{_sysconfdir}/sound/events/*
163 %{_mandir}/man1/*
This page took 0.083418 seconds and 3 git commands to generate.