]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
763e11b9a0d9d669129eed0eaea73ffa5d21a94d
[packages/galeon.git] / galeon.spec
1
2 %define         minmozver       0.9.9
3
4 Summary:        Galeon - gecko-based GNOME web browser
5 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
6 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
7 Name:           galeon
8 Version:        1.2.1
9 Release:        6
10 Epoch:          2
11 License:        GPL
12 Group:          X11/Applications/Networking
13 Source0:        http://prdownloads.sourceforge.net/galeon/%{name}-%{version}.tar.gz
14 Source1:        %{name}-config-tool.1
15 Patch0:         %{name}-mozilla_five_home.patch
16 Patch1:         %{name}-am_fix.patch
17 Patch2:         %{name}-vfs.patch
18 URL:            http://galeon.sourceforge.net/
19 BuildRequires:  GConf-devel >= 1.0.4-1
20 BuildRequires:  ORBit-devel >= 0.5.0
21 BuildRequires:  bison
22 BuildRequires:  gdk-pixbuf-devel >= 0.10.
23 BuildRequires:  gettext-devel
24 BuildRequires:  gnome-core-devel >= 1.2.0
25 BuildRequires:  gnome-libs-devel >= 1.2.0
26 BuildRequires:  gnome-vfs-devel >= 0.5
27 BuildRequires:  intltool
28 BuildRequires:  libglade-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libxml-devel >= 1.8.7
31 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
32 BuildRequires:  oaf-devel >= 0.6.2
33 BuildRequires:  openssl-devel
34 BuildRequires:  scrollkeeper
35 Requires:       GConf >= 1.0.4-1
36 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
37 Prereq:         scrollkeeper
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # can be provided by mozilla or mozilla-embedded
41 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
42
43 %define         _prefix         /usr/X11R6
44 %define         _mandir         %{_prefix}/man
45 %define         _sysconfdir     /etc/X11/GNOME
46 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
47
48 %description
49 Gnome browser based on Gecko (Mozilla rendering engine).
50
51 %description -l pl
52 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
53 interpretacji stron Mozilli).
54
55 %description -l pt_BR
56 O galeon é um browser para o gnome baseado no mozilla.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63
64 %build
65 rm -f missing
66 xml-i18n-toolize --copy --force
67 gettextize --copy --force
68 aclocal -I %{_aclocaldir}/gnome
69 autoconf
70 automake -a -c -f
71 %configure \
72         --with-mozilla-libs=%{_libdir} \
73         --with-mozilla-includes=%{_includedir}/mozilla \
74         --with-mozilla-home=%{_libdir}/mozilla \
75         --enable-nls \
76         --disable-included-gettext \
77         --disable-install-schemas \
78         --disable-werror \
79         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
80         --enable-nautilus-view=no
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT \
89         Networkdir=%{_applnkdir}/Network/WWW \
90         omf_dest_dir=%{_omf_dest_dir}/%{name}
91
92 mv -f $RPM_BUILD_ROOT%{_bindir}/galeon-bin $RPM_BUILD_ROOT%{_bindir}/galeon
93
94 install -d $RPM_BUILD_ROOT%{_mandir}/man1
95 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
96
97 gzip -9nf AUTHORS ChangeLog NEWS README
98
99 %find_lang %{name} --with-gnome
100
101 %post
102 /usr/bin/scrollkeeper-update
103 umask 022
104 rm -f %{_libdir}/mozilla/component.reg
105 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
106 gconftool --shutdown
107 GCONF_CONFIG_SOURCE=xml::%{_sysconfdir}/gconf/gconf.xml.defaults gconftool --makefile-install-rule %{_sysconfdir}/gconf/schemas/galeon.schemas 2>dev/null >/dev/null
108
109 %postun -p /usr/bin/scrollkeeper-update
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files -f %{name}.lang
115 %defattr(644,root,root,755)
116 %doc *.gz
117 %attr(755,root,root) %{_bindir}/*
118 %{_applnkdir}/Network/WWW/*
119 %{_libdir}/%{name}
120 %{_datadir}/galeon
121 %{_datadir}/gnome/help/galeon-manual
122 %{_datadir}/gnome/ui/*.xml
123 %{_datadir}/oaf/*
124 %{_omf_dest_dir}/%{name}
125 %{_datadir}/sounds/galeon
126 %{_pixmapsdir}/*
127 %{_sysconfdir}/gconf/schemas/*
128 %{_sysconfdir}/sound/events/*
129 %{_mandir}/man1/*
This page took 0.024247 seconds and 2 git commands to generate.