]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- fixed desktop entry,
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 # _with_gcc2            - compile using gcc2 to get working java plugin.
4 #                         Flash plugin seems to still doesn't work, use 
5 #                         mozilla instead. To compile wit this option, You 
6 #                         have to install mozilla compiled with gcc2.
7 #
8 %define         minmozver       1.4b
9 %define         snap            20030518
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
13 Summary(pt_BR): O galeon é um browser para o gnome baseado no mozilla
14 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
15 Name:           galeon
16 Version:        1.3.5
17 #Release:       1.%{snap}.1
18 Release:        2
19 Epoch:          2
20 License:        GPL
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sf.net/galeon/%{name}-%{version}.tar.bz2
23 # Source0-md5:  6d0a503e82e0c676712859ee273dcd81
24 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
25 Source1:        %{name}-config-tool.1
26 URL:            http://galeon.sourceforge.net/
27 Patch0:         %{name}-desktop.patch
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  GConf2-devel >= 2.0.0
31 BuildRequires:  ORBit2-devel >= 2.0.0
32 BuildRequires:  bison
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnome-vfs2-devel >= 2.0.0
35 BuildRequires:  gtk+2-devel >= 2.0.6
36 BuildRequires:  intltool
37 BuildRequires:  libbonobo-devel >= 2.3.1-4
38 BuildRequires:  libbonoboui-devel >= 2.1.1
39 BuildRequires:  libglade2-devel >= 2.0.0
40 BuildRequires:  libgnomeui-devel >= 2.0.5
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libxml2-devel >= 2.4.0
43 BuildRequires:  mozilla-embedded-devel >= %{minmozver}
44 BuildRequires:  nautilus-devel >= 2.0.0
45 BuildRequires:  openssl-devel >= 0.9.7
46 BuildRequires:  scrollkeeper >= 0.1.4
47 BuildRequires:  rpm-build >= 4.1-10
48 Requires:       libbonobo >= 2.3.1-4
49 Requires:       mozilla-embedded = %(rpm -q --qf '%{VERSION}' --whatprovides mozilla-embedded)
50 Requires(post): GConf2
51 Requires(post): mozilla
52 Requires(post): scrollkeeper
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # can be provided by mozilla or mozilla-embedded
56 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
57
58 %if%{?_with_gcc2:1}%{!?_with_gcc2:0}
59 %define         __cc            gcc2
60 %define         __cxx           gcc2
61 %endif
62
63 %description
64 Gnome browser based on Gecko (Mozilla rendering engine).
65
66 %description -l pl
67 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
68 interpretacji stron Mozilli).
69
70 %description -l pt_BR
71 O galeon é um browser para o gnome baseado no mozilla.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 rm -f missing
79 glib-gettextize --copy --force
80 intltoolize --copy --force
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoheader}
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         --with-mozilla-libs=%{_libdir} \
88         --with-mozilla-includes=%{_includedir}/mozilla \
89         --with-mozilla-home=%{_libdir}/mozilla \
90         --enable-nls \
91         --disable-included-gettext \
92         --disable-schemas-install \
93         --disable-werror \
94         --with-mozilla-snapshot=1.4b \
95         --enable-gconf-source=%{_sysconfdir}/gconf/schemas \
96         --enable-nautilus-view=yes
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_mandir}/man1
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT 
106
107 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
108
109 %find_lang galeon-2.0
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 /usr/bin/scrollkeeper-update
116 umask 022
117 rm -f %{_libdir}/mozilla/component.reg
118 MOZILLA_FIVE_HOME=%{_libdir}/mozilla regxpcom
119 %gconf_schema_install
120
121 %postun -p /usr/bin/scrollkeeper-update
122
123 %files -f galeon-2.0.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README*
126 %attr(755,root,root) %{_bindir}/*
127 %{_libdir}/%{name}
128 %{_libdir}/bonobo/servers/*
129 %{_datadir}/galeon
130 %{_datadir}/applications/*
131 %{_datadir}/gnome/help/*
132 %{_datadir}/gnome-2.0/ui/*.xml
133 %{_omf_dest_dir}/%{name}
134 %{_datadir}/sounds/galeon
135 %{_pixmapsdir}/*
136 %{_sysconfdir}/gconf/schemas/*
137 %{_sysconfdir}/sound/events/*
138 %{_mandir}/man1/*
This page took 0.045442 seconds and 3 git commands to generate.