]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- updated to 2.0.6, dropped obsolete mozilla and build_fix patches
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # enable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10 Summary:        Galeon - gecko-based GNOME web browser
11 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
12 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
13 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
14 Name:           galeon
15 Version:        2.0.6
16 Release:        1
17 Epoch:          2
18 License:        GPL
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
21 # Source0-md5:  7723816d29edac94945e5fd9a2a402f8
22 Source1:        %{name}-config-tool.1
23 Patch0:         %{name}-desktop.patch
24 Patch1:         %{name}-home_etc.patch
25 Patch2:         %{name}-ti-agent.patch
26 Patch3:         %{name}-agent.patch
27 Patch4:         %{name}-libxul.patch
28 URL:            http://galeon.sourceforge.net/
29 BuildRequires:  GConf2-devel >= 2.4.0
30 BuildRequires:  ORBit2-devel >= 2.8.3
31 BuildRequires:  autoconf >= 2.52
32 BuildRequires:  automake
33 BuildRequires:  bison
34 BuildRequires:  gettext-devel
35 BuildRequires:  glib2-devel >= 1:2.4.4
36 BuildRequires:  gnome-desktop-devel >= 2.9.91
37 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
38 BuildRequires:  gtk+2-devel >= 2:2.4.4
39 BuildRequires:  intltool
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 1:2.4.0
42 BuildRequires:  libgnomeui-devel >= 2.6.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.6.6
46 BuildRequires:  xulrunner-devel >= 1.8.0.4
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpm >= 4.4.9-56
50 BuildRequires:  rpmbuild(find_lang) >= 1.23
51 BuildRequires:  rpmbuild(macros) >= 1.197
52 BuildRequires:  scrollkeeper >= 0.1.4
53 BuildRequires:  sed >= 4.0
54 Requires(post,postun):  desktop-file-utils
55 Requires(post,postun):  scrollkeeper
56 Requires(post,preun):   GConf2
57 Requires:       glib2 >= 1:2.4.4
58 Requires:       gtk+2 >= 2:2.4.4
59 Requires:       libbonobo >= 2.4.0
60 %requires_eq_to xulrunner xulrunner-devel
61 Provides:       wwwbrowser
62 # sr@Latn vs. sr@latin
63 Conflicts:      glibc-misc < 6:2.7
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 # can be provided by mozilla or mozilla-embedded
67 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
68 # we have strict deps for it
69 %define         _noautoreq      libxpcom.so
70
71 %if %{with gcc2}
72 %define         __cc            gcc2
73 %define         __cxx           gcc2
74 %endif
75
76 %description
77 GNOME browser based on Gecko (Mozilla rendering engine).
78
79 %description -l pl.UTF-8
80 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
81 interpretacji stron Mozilli).
82
83 %description -l pt_BR.UTF-8
84 O galeon é um browser para o GNOME baseado no mozilla.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %if "%{pld_release}" == "ti"
91 %patch2 -p1
92 %else
93 %patch3 -p1
94 %endif
95 %patch4 -p1
96
97 sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
98 mv po/sr\@{Latn,latin}.po
99
100 # regenerate - didn't compile with ORBit2 2.7.2
101 cd idl
102 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
103 mv Galeon*.[ch] ../src
104
105 %build
106 cp /usr/share/automake/mkinstalldirs .
107 %{__glib_gettextize}
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoheader}
112 %{__autoconf}
113 %{__automake}
114 %configure \
115         --disable-schemas-install \
116         %if %{with nautilus}
117         --enable-nautilus-view=yes
118         %else
119         --enable-nautilus-view=no
120         %endif
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_mandir}/man1
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
131
132 # No components installed now.
133 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
134
135 # galeon-2.0.mo, but gnome/help/galeon
136 %find_lang galeon-2.0 --with-gnome --with-omf --all-name
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 %scrollkeeper_update_post
143 %gconf_schema_install galeon.schemas
144 %update_desktop_database_post
145
146 %preun
147 %gconf_schema_uninstall galeon.schemas
148
149 %postun
150 %scrollkeeper_update_postun
151 %update_desktop_database_postun
152
153 %files -f galeon-2.0.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README*
156 %attr(755,root,root) %{_bindir}/*
157 %{_libdir}/bonobo/servers/*
158 %{_datadir}/galeon
159 %{_desktopdir}/*.desktop
160 %{_datadir}/gnome-2.0/ui/*.xml
161 %{_datadir}/sounds/galeon
162 %{_pixmapsdir}/*
163 %{_sysconfdir}/gconf/schemas/galeon.schemas
164 %{_sysconfdir}/sound/events/*
165 %{_mandir}/man1/*
This page took 0.416155 seconds and 3 git commands to generate.