]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- up to 2.0.0
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # disable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        2.0.0
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
24 # Source0-md5:  5106e037bb52bdb234b3fc09c1e0a3f3
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-po.patch
30 Patch3:         %{name}-mozilla.patch
31 URL:            http://galeon.sourceforge.net/
32 BuildRequires:  GConf2-devel >= 2.4.0
33 BuildRequires:  ORBit2-devel >= 2.8.3
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.4.4
39 BuildRequires:  gnome-desktop-devel >= 2.9.91
40 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
41 BuildRequires:  gtk+2-devel >= 2:2.4.4
42 BuildRequires:  intltool
43 BuildRequires:  libbonoboui-devel >= 2.4.0
44 BuildRequires:  libglade2-devel >= 1:2.4.0
45 BuildRequires:  libgnomeui-devel >= 2.6.0
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 2.6.6
49 BuildRequires:  mozilla-devel >= %{minmozver}
50 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
51 BuildRequires:  pkgconfig
52 BuildRequires:  rpmbuild(macros) >= 1.197
53 BuildRequires:  scrollkeeper >= 0.1.4
54 Requires(post,preun):   GConf2
55 Requires(post,postun):  desktop-file-utils
56 Requires(post,postun):  scrollkeeper
57 Requires:       glib2 >= 1:2.4.4
58 Requires:       gtk+2 >= 2:2.4.4
59 Requires:       libbonobo >= 2.4.0
60 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # can be provided by mozilla or mozilla-embedded
64 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
65
66 %if %{with gcc2}
67 %define         __cc            gcc2
68 %define         __cxx           gcc2
69 %endif
70
71 %description
72 GNOME browser based on Gecko (Mozilla rendering engine).
73
74 %description -l pl
75 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
76 interpretacji stron Mozilli).
77
78 %description -l pt_BR
79 O galeon é um browser para o GNOME baseado no mozilla.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p1
87
88 # regenerate - didn't compile with ORBit2 2.7.2
89 cd idl
90 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
91 mv Galeon*.[ch] ../src
92
93 %build
94 rm -f missing
95 cp /usr/share/automake/mkinstalldirs .
96 %{__glib_gettextize}
97 %{__intltoolize}
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoheader}
101 %{__autoconf}
102 %{__automake}
103 %configure \
104         --disable-schemas-install \
105         %if %{with nautilus}
106         --enable-nautilus-view=yes
107         %else
108         --enable-nautilus-view=no
109         %endif
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_mandir}/man1
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
120
121 # No components installed now.
122 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
123
124 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
125
126 # galeon-2.0.mo, but gnome/help/galeon
127 %find_lang galeon-2.0 --with-gnome --all-name
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 %scrollkeeper_update_post
134 %gconf_schema_install galeon.schemas
135 %update_desktop_database_post
136
137 %preun
138 %gconf_schema_uninstall galeon.schemas
139
140 %postun
141 %scrollkeeper_update_postun
142 %update_desktop_database_postun
143
144 %files -f galeon-2.0.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README*
147 %attr(755,root,root) %{_bindir}/*
148 %{_libdir}/bonobo/servers/*
149 %{_datadir}/galeon
150 %{_desktopdir}/*
151 %{_datadir}/gnome-2.0/ui/*.xml
152 %{_omf_dest_dir}/%{name}
153 %{_datadir}/sounds/galeon
154 %{_pixmapsdir}/*
155 %{_sysconfdir}/gconf/schemas/*
156 %{_sysconfdir}/sound/events/*
157 %{_mandir}/man1/*
This page took 0.135316 seconds and 3 git commands to generate.