]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- rel 6 (mozilla-firefox 1.5.0.7)
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without  mozilla_firefox # build without mozilla-firefox-devel
4 %bcond_with     nautilus        # disable nautilus view
5 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
6                                 # plugin (better get gcc3-compiled one).
7                                 # Flash plugin seems to still not work, use
8                                 # mozilla instead. To compile wit this option, You
9                                 # have to install mozilla compiled with gcc2.
10 #
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        2.0.1
19 Release:        6
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
24 # Source0-md5:  34d6e3a6ee78f9e4d12736e5d81b462b
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-po.patch
30 Patch3:         %{name}-mozilla.patch
31 URL:            http://galeon.sourceforge.net/
32 BuildRequires:  GConf2-devel >= 2.4.0
33 BuildRequires:  ORBit2-devel >= 2.8.3
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.4.4
39 BuildRequires:  gnome-desktop-devel >= 2.9.91
40 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
41 BuildRequires:  gtk+2-devel >= 2:2.4.4
42 BuildRequires:  intltool
43 BuildRequires:  libbonoboui-devel >= 2.4.0
44 BuildRequires:  libglade2-devel >= 1:2.4.0
45 BuildRequires:  libgnomeui-devel >= 2.6.0
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 2.6.6
49 %if %{with mozilla_firefox}
50 BuildRequires:  mozilla-firefox-devel
51 %else
52 BuildRequires:  mozilla-devel >= 5:1.7
53 %endif
54 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
55 BuildRequires:  pkgconfig
56 BuildRequires:  rpmbuild(macros) >= 1.197
57 BuildRequires:  scrollkeeper >= 0.1.4
58 Requires(post,postun):  desktop-file-utils
59 Requires(post,postun):  scrollkeeper
60 Requires(post,preun):   GConf2
61 Requires:       glib2 >= 1:2.4.4
62 Requires:       gtk+2 >= 2:2.4.4
63 Requires:       libbonobo >= 2.4.0
64 %if %{with mozilla_firefox}
65 %requires_eq    mozilla-firefox
66 %else
67 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
68 %endif
69 Provides:       wwwbrowser
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 # can be provided by mozilla or mozilla-embedded
73 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
74
75 %if %{with gcc2}
76 %define         __cc            gcc2
77 %define         __cxx           gcc2
78 %endif
79
80 %description
81 GNOME browser based on Gecko (Mozilla rendering engine).
82
83 %description -l pl
84 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
85 interpretacji stron Mozilli).
86
87 %description -l pt_BR
88 O galeon é um browser para o GNOME baseado no mozilla.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96
97 # regenerate - didn't compile with ORBit2 2.7.2
98 cd idl
99 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
100 mv Galeon*.[ch] ../src
101
102 %build
103 rm -f missing
104 cp /usr/share/automake/mkinstalldirs .
105 %{__glib_gettextize}
106 %{__intltoolize}
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoheader}
110 %{__autoconf}
111 %{__automake}
112 %configure \
113         --disable-schemas-install \
114         %if %{with nautilus}
115         --enable-nautilus-view=yes
116         %else
117         --enable-nautilus-view=no
118         %endif
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_mandir}/man1
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
129
130 # No components installed now.
131 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
132
133 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
134
135 # galeon-2.0.mo, but gnome/help/galeon
136 %find_lang galeon-2.0 --with-gnome --all-name
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 %scrollkeeper_update_post
143 %gconf_schema_install galeon.schemas
144 %update_desktop_database_post
145
146 %preun
147 %gconf_schema_uninstall galeon.schemas
148
149 %postun
150 %scrollkeeper_update_postun
151 %update_desktop_database_postun
152
153 %files -f galeon-2.0.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README*
156 %attr(755,root,root) %{_bindir}/*
157 %{_libdir}/bonobo/servers/*
158 %{_datadir}/galeon
159 %{_desktopdir}/*
160 %{_datadir}/gnome-2.0/ui/*.xml
161 %{_omf_dest_dir}/%{name}
162 %{_datadir}/sounds/galeon
163 %{_pixmapsdir}/*
164 %{_sysconfdir}/gconf/schemas/*
165 %{_sysconfdir}/sound/events/*
166 %{_mandir}/man1/*
This page took 0.110301 seconds and 3 git commands to generate.