]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- up to 2.0.1
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # disable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        2.0.1
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
24 # Source0-md5:  34d6e3a6ee78f9e4d12736e5d81b462b
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-po.patch
30 Patch3:         %{name}-mozilla.patch
31 URL:            http://galeon.sourceforge.net/
32 BuildRequires:  GConf2-devel >= 2.4.0
33 BuildRequires:  ORBit2-devel >= 2.8.3
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.4.4
39 BuildRequires:  gnome-desktop-devel >= 2.9.91
40 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
41 BuildRequires:  gtk+2-devel >= 2:2.4.4
42 BuildRequires:  intltool
43 BuildRequires:  libbonoboui-devel >= 2.4.0
44 BuildRequires:  libglade2-devel >= 1:2.4.0
45 BuildRequires:  libgnomeui-devel >= 2.6.0
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 2.6.6
49 BuildRequires:  mozilla-devel >= %{minmozver}
50 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
51 BuildRequires:  pkgconfig
52 BuildRequires:  rpmbuild(macros) >= 1.197
53 BuildRequires:  scrollkeeper >= 0.1.4
54 Requires(post,preun):   GConf2
55 Requires(post,postun):  desktop-file-utils
56 Requires(post,postun):  scrollkeeper
57 Requires:       glib2 >= 1:2.4.4
58 Requires:       gtk+2 >= 2:2.4.4
59 Requires:       libbonobo >= 2.4.0
60 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
61 Provides:       wwwbrowser
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # can be provided by mozilla or mozilla-embedded
65 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
66
67 %if %{with gcc2}
68 %define         __cc            gcc2
69 %define         __cxx           gcc2
70 %endif
71
72 %description
73 GNOME browser based on Gecko (Mozilla rendering engine).
74
75 %description -l pl
76 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
77 interpretacji stron Mozilli).
78
79 %description -l pt_BR
80 O galeon é um browser para o GNOME baseado no mozilla.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88
89 # regenerate - didn't compile with ORBit2 2.7.2
90 cd idl
91 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
92 mv Galeon*.[ch] ../src
93
94 %build
95 rm -f missing
96 cp /usr/share/automake/mkinstalldirs .
97 %{__glib_gettextize}
98 %{__intltoolize}
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoheader}
102 %{__autoconf}
103 %{__automake}
104 %configure \
105         --disable-schemas-install \
106         %if %{with nautilus}
107         --enable-nautilus-view=yes
108         %else
109         --enable-nautilus-view=no
110         %endif
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_mandir}/man1
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
121
122 # No components installed now.
123 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
124
125 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
126
127 # galeon-2.0.mo, but gnome/help/galeon
128 %find_lang galeon-2.0 --with-gnome --all-name
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 %scrollkeeper_update_post
135 %gconf_schema_install galeon.schemas
136 %update_desktop_database_post
137
138 %preun
139 %gconf_schema_uninstall galeon.schemas
140
141 %postun
142 %scrollkeeper_update_postun
143 %update_desktop_database_postun
144
145 %files -f galeon-2.0.lang
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog NEWS README*
148 %attr(755,root,root) %{_bindir}/*
149 %{_libdir}/bonobo/servers/*
150 %{_datadir}/galeon
151 %{_desktopdir}/*
152 %{_datadir}/gnome-2.0/ui/*.xml
153 %{_omf_dest_dir}/%{name}
154 %{_datadir}/sounds/galeon
155 %{_pixmapsdir}/*
156 %{_sysconfdir}/gconf/schemas/*
157 %{_sysconfdir}/sound/events/*
158 %{_mandir}/man1/*
This page took 0.042118 seconds and 3 git commands to generate.