]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- use %pld_release macro and apply proper agent patch, BR: rpm >= 4.4.9-56
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # enable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10 Summary:        Galeon - gecko-based GNOME web browser
11 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
12 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
13 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
14 Name:           galeon
15 Version:        2.0.5
16 Release:        4
17 Epoch:          2
18 License:        GPL
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
21 # Source0-md5:  bbddb89ad1ba08a62e03bceab5a38d93
22 Source1:        %{name}-config-tool.1
23 Patch0:         %{name}-desktop.patch
24 Patch1:         %{name}-home_etc.patch
25 Patch2:         %{name}-mozilla.patch
26 Patch3:         %{name}-build_fix.patch
27 Patch4:         %{name}-ti-agent.patch
28 Patch5:         %{name}-agent.patch
29 URL:            http://galeon.sourceforge.net/
30 BuildRequires:  GConf2-devel >= 2.4.0
31 BuildRequires:  ORBit2-devel >= 2.8.3
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib2-devel >= 1:2.4.4
37 BuildRequires:  gnome-desktop-devel >= 2.9.91
38 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
39 BuildRequires:  gtk+2-devel >= 2:2.4.4
40 BuildRequires:  intltool
41 BuildRequires:  libbonoboui-devel >= 2.4.0
42 BuildRequires:  libglade2-devel >= 1:2.4.0
43 BuildRequires:  libgnomeui-devel >= 2.6.0
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2.6.6
47 BuildRequires:  xulrunner-devel >= 1.8.0.4
48 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(find_lang) >= 1.23
52 BuildRequires:  rpmbuild(macros) >= 1.197
53 BuildRequires:  scrollkeeper >= 0.1.4
54 BuildRequires:  sed >= 4.0
55 Requires(post,postun):  desktop-file-utils
56 Requires(post,postun):  scrollkeeper
57 Requires(post,preun):   GConf2
58 Requires:       glib2 >= 1:2.4.4
59 Requires:       gtk+2 >= 2:2.4.4
60 Requires:       libbonobo >= 2.4.0
61 %requires_eq_to xulrunner xulrunner-devel
62 Provides:       wwwbrowser
63 # sr@Latn vs. sr@latin
64 Conflicts:      glibc-misc < 6:2.7
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 # can be provided by mozilla or mozilla-embedded
68 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
69 # we have strict deps for it
70 %define         _noautoreq      libxpcom.so
71
72 %if %{with gcc2}
73 %define         __cc            gcc2
74 %define         __cxx           gcc2
75 %endif
76
77 %description
78 GNOME browser based on Gecko (Mozilla rendering engine).
79
80 %description -l pl.UTF-8
81 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
82 interpretacji stron Mozilli).
83
84 %description -l pt_BR.UTF-8
85 O galeon é um browser para o GNOME baseado no mozilla.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 %patch3 -p1
93 %if "%{pld_release}" == "ti"
94 %patch4 -p1
95 %else
96 %patch5 -p1
97 %endif
98
99 sed -i -e 's#sr\@Latn#sr\@latin#' configure.in
100 mv po/sr\@{Latn,latin}.po
101
102 # regenerate - didn't compile with ORBit2 2.7.2
103 cd idl
104 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
105 mv Galeon*.[ch] ../src
106
107 %build
108 cp /usr/share/automake/mkinstalldirs .
109 %{__glib_gettextize}
110 %{__intltoolize}
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoheader}
114 %{__autoconf}
115 %{__automake}
116 %configure \
117         --disable-schemas-install \
118         %if %{with nautilus}
119         --enable-nautilus-view=yes
120         %else
121         --enable-nautilus-view=no
122         %endif
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_mandir}/man1
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
133
134 # No components installed now.
135 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
136
137 # galeon-2.0.mo, but gnome/help/galeon
138 %find_lang galeon-2.0 --with-gnome --with-omf --all-name
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %scrollkeeper_update_post
145 %gconf_schema_install galeon.schemas
146 %update_desktop_database_post
147
148 %preun
149 %gconf_schema_uninstall galeon.schemas
150
151 %postun
152 %scrollkeeper_update_postun
153 %update_desktop_database_postun
154
155 %files -f galeon-2.0.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog NEWS README*
158 %attr(755,root,root) %{_bindir}/*
159 %{_libdir}/bonobo/servers/*
160 %{_datadir}/galeon
161 %{_desktopdir}/*.desktop
162 %{_datadir}/gnome-2.0/ui/*.xml
163 %{_datadir}/sounds/galeon
164 %{_pixmapsdir}/*
165 %{_sysconfdir}/gconf/schemas/galeon.schemas
166 %{_sysconfdir}/sound/events/*
167 %{_mandir}/man1/*
This page took 0.140824 seconds and 3 git commands to generate.