]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
3c09256e40a28a3f5979dfa5b35f869fbe0725e0
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # disable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.7
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.21
19 Release:        5
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
24 # Source0-md5:  5106e037bb52bdb234b3fc09c1e0a3f3
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-po.patch
30 Patch3:         %{name}-mozilla.patch
31 URL:            http://galeon.sourceforge.net/
32 BuildRequires:  GConf2-devel >= 2.4.0
33 BuildRequires:  ORBit2-devel >= 2.8.3
34 BuildRequires:  autoconf >= 2.52
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  gettext-devel
38 BuildRequires:  glib2-devel >= 1:2.4.4
39 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
40 BuildRequires:  gtk+2-devel >= 2:2.4.4
41 BuildRequires:  intltool
42 BuildRequires:  libbonoboui-devel >= 2.4.0
43 BuildRequires:  libglade2-devel >= 1:2.4.0
44 BuildRequires:  libgnomeui-devel >= 2.6.0
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool
47 BuildRequires:  libxml2-devel >= 2.6.6
48 BuildRequires:  mozilla-devel >= %{minmozver}
49 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
50 BuildRequires:  pkgconfig
51 BuildRequires:  rpmbuild(macros) >= 1.197
52 BuildRequires:  scrollkeeper >= 0.1.4
53 Requires(post,preun):   GConf2
54 Requires(post,postun):  desktop-file-utils
55 Requires(post,postun):  scrollkeeper
56 Requires:       glib2 >= 1:2.4.4
57 Requires:       gtk+2 >= 2:2.4.4
58 Requires:       libbonobo >= 2.4.0
59 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # can be provided by mozilla or mozilla-embedded
63 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
64
65 %if %{with gcc2}
66 %define         __cc            gcc2
67 %define         __cxx           gcc2
68 %endif
69
70 %description
71 GNOME browser based on Gecko (Mozilla rendering engine).
72
73 %description -l pl
74 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
75 interpretacji stron Mozilli).
76
77 %description -l pt_BR
78 O galeon é um browser para o GNOME baseado no mozilla.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 %patch3 -p1
86
87 # regenerate - didn't compile with ORBit2 2.7.2
88 cd idl
89 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
90 mv Galeon*.[ch] ../src
91
92 %build
93 rm -f missing
94 cp /usr/share/automake/mkinstalldirs .
95 %{__glib_gettextize}
96 %{__intltoolize}
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoheader}
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --disable-schemas-install \
104         %if %{with nautilus}
105         --enable-nautilus-view=yes
106         %else
107         --enable-nautilus-view=no
108         %endif
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT%{_mandir}/man1
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
119
120 # No components installed now.
121 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
122
123 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
124
125 # galeon-2.0.mo, but gnome/help/galeon
126 %find_lang galeon-2.0 --with-gnome --all-name
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 %scrollkeeper_update_post
133 %gconf_schema_install galeon.schemas
134 %update_desktop_database_post
135
136 %preun
137 %gconf_schema_uninstall galeon.schemas
138
139 %postun
140 %scrollkeeper_update_postun
141 %update_desktop_database_postun
142
143 %files -f galeon-2.0.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README*
146 %attr(755,root,root) %{_bindir}/*
147 %{_libdir}/bonobo/servers/*
148 %{_datadir}/galeon
149 %{_desktopdir}/*
150 %{_datadir}/gnome-2.0/ui/*.xml
151 %{_omf_dest_dir}/%{name}
152 %{_datadir}/sounds/galeon
153 %{_pixmapsdir}/*
154 %{_sysconfdir}/gconf/schemas/*
155 %{_sysconfdir}/sound/events/*
156 %{_mandir}/man1/*
This page took 1.463784 seconds and 2 git commands to generate.