]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
- updated to 20040320 snap (for mozilla-1.7b)
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.6
11 %define         snap    20040320
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.13a
19 Release:        2.%{snap}.1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        %{name}-%{version}-%{snap}.tar.bz2
24 # Source0-md5:  92d333b32e791a58b4e701ed8f512a2c
25 #Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-locale-names.patch
30 URL:            http://galeon.sourceforge.net/
31 BuildRequires:  GConf2-devel >= 2.4.0
32 BuildRequires:  ORBit2-devel >= 2.8.3
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  bison
36 BuildRequires:  gettext-devel
37 BuildRequires:  gnome-vfs2-devel >= 2.4.0
38 BuildRequires:  gtk+2-devel >= 2.2.0
39 BuildRequires:  intltool
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 2.0.1
42 BuildRequires:  libgnomeui-devel >= 2.4.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.4.0
46 BuildRequires:  mozilla-devel >= %{minmozver}
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  rpm-build >= 4.1-10
49 BuildRequires:  scrollkeeper >= 0.1.4
50 Requires(post): GConf2
51 Requires(post): scrollkeeper
52 Requires:       libbonobo >= 2.4.0
53 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 # can be provided by mozilla or mozilla-embedded
57 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
58
59 %if %{with gcc2}
60 %define         __cc            gcc2
61 %define         __cxx           gcc2
62 %endif
63
64 %description
65 GNOME browser based on Gecko (Mozilla rendering engine).
66
67 %description -l pl
68 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
69 interpretacji stron Mozilli).
70
71 %description -l pt_BR
72 O galeon é um browser para o GNOME baseado no mozilla.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79
80 mv po/{no,nb}.po
81
82 # regenerate - didn't compile with ORBit2 2.7.2
83 cd idl
84 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
85 mv Galeon*.[ch] ../src
86
87 %build
88 rm -f missing
89 cp /usr/share/automake/mkinstalldirs .
90 glib-gettextize --copy --force
91 intltoolize --copy --force
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoheader}
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --disable-schemas-install \
99         %if %{with nautilus}
100         --enable-nautilus-view=yes
101         %else
102         --enable-nautilus-view=no
103         %endif
104         
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT%{_mandir}/man1
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
115
116 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
117
118 # galeon-2.0.mo, but gnome/help/galeon
119 %find_lang galeon-2.0 --with-gnome --all-name
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post
125 /usr/bin/scrollkeeper-update
126 %gconf_schema_install
127
128 %postun -p /usr/bin/scrollkeeper-update
129
130 %files -f galeon-2.0.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README*
133 %attr(755,root,root) %{_bindir}/*
134 %attr(755,root,root) %{_libdir}/%{name}
135 %{_libdir}/bonobo/servers/*
136 %{_datadir}/galeon
137 %{_desktopdir}/*
138 %{_datadir}/gnome-2.0/ui/*.xml
139 %{_omf_dest_dir}/%{name}
140 %{_datadir}/sounds/galeon
141 %{_pixmapsdir}/*
142 %{_sysconfdir}/gconf/schemas/*
143 %{_sysconfdir}/sound/events/*
144 %{_mandir}/man1/*
This page took 0.042652 seconds and 3 git commands to generate.