]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
29936838abed9d5dca7104283b80cab5a0cca25b
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilus        # enable nautilus view
4 %bcond_with     gcc2            # compile using gcc2 to get working gcc2-compiled java
5                                 # plugin (better get gcc3-compiled one).
6                                 # Flash plugin seems to still not work, use
7                                 # mozilla instead. To compile wit this option, You
8                                 # have to install mozilla compiled with gcc2.
9 #
10
11 Summary:        Galeon - gecko-based GNOME web browser
12 Summary(pl.UTF-8):      Galeon - przeglądarka WWW dla GNOME
13 Summary(pt_BR.UTF-8):   O galeon é um browser para o GNOME baseado no mozilla
14 Summary(zh_CN.UTF-8):   基于Gecko的GNOME流览器
15 Name:           galeon
16 Version:        2.0.3
17 Release:        6
18 Epoch:          2
19 License:        GPL
20 Group:          X11/Applications/Networking
21 Source0:        http://dl.sourceforge.net/galeon/%{name}-%{version}.tar.bz2
22 # Source0-md5:  610fe2258e680f68bdf36ce7c1ba2a24
23 Source1:        %{name}-config-tool.1
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-home_etc.patch
26 Patch2:         %{name}-po.patch
27 Patch3:         %{name}-mozilla.patch
28 Patch4:         %{name}-agent.patch
29 URL:            http://galeon.sourceforge.net/
30 BuildRequires:  GConf2-devel >= 2.4.0
31 BuildRequires:  ORBit2-devel >= 2.8.3
32 BuildRequires:  autoconf >= 2.52
33 BuildRequires:  automake
34 BuildRequires:  bison
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib2-devel >= 1:2.4.4
37 BuildRequires:  gnome-desktop-devel >= 2.9.91
38 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
39 BuildRequires:  gtk+2-devel >= 2:2.4.4
40 BuildRequires:  intltool
41 BuildRequires:  libbonoboui-devel >= 2.4.0
42 BuildRequires:  libglade2-devel >= 1:2.4.0
43 BuildRequires:  libgnomeui-devel >= 2.6.0
44 BuildRequires:  libstdc++-devel
45 BuildRequires:  libtool
46 BuildRequires:  libxml2-devel >= 2.6.6
47 BuildRequires:  xulrunner-devel >= 1.8.0.4
48 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpmbuild(macros) >= 1.197
51 BuildRequires:  scrollkeeper >= 0.1.4
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  scrollkeeper
54 Requires(post,preun):   GConf2
55 Requires:       glib2 >= 1:2.4.4
56 Requires:       gtk+2 >= 2:2.4.4
57 Requires:       libbonobo >= 2.4.0
58 %requires_eq_to xulrunner xulrunner-devel
59 Provides:       wwwbrowser
60 # sr@Latn vs. sr@latin
61 Conflicts:      glibc-misc < 6:2.7
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # can be provided by mozilla or mozilla-embedded
65 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
66 # we have strict deps for it
67 %define         _noautoreq      libxpcom.so
68
69 %if %{with gcc2}
70 %define         __cc            gcc2
71 %define         __cxx           gcc2
72 %endif
73
74 %description
75 GNOME browser based on Gecko (Mozilla rendering engine).
76
77 %description -l pl.UTF-8
78 Galeon jest przeglądarką WWW bazującą na Gecko (mechanizmie
79 interpretacji stron Mozilli).
80
81 %description -l pt_BR.UTF-8
82 O galeon é um browser para o GNOME baseado no mozilla.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch4 -p1
91
92 # regenerate - didn't compile with ORBit2 2.7.2
93 cd idl
94 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
95 mv Galeon*.[ch] ../src
96
97 %build
98 rm -f missing
99 cp /usr/share/automake/mkinstalldirs .
100 %{__glib_gettextize}
101 %{__intltoolize}
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoheader}
105 %{__autoconf}
106 %{__automake}
107 %configure \
108         --disable-schemas-install \
109         %if %{with nautilus}
110         --enable-nautilus-view=yes
111         %else
112         --enable-nautilus-view=no
113         %endif
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT%{_mandir}/man1
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
124
125 # No components installed now.
126 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
127
128 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
129         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
130 # galeon-2.0.mo, but gnome/help/galeon
131 %find_lang galeon-2.0 --with-gnome --all-name
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 %scrollkeeper_update_post
138 %gconf_schema_install galeon.schemas
139 %update_desktop_database_post
140
141 %preun
142 %gconf_schema_uninstall galeon.schemas
143
144 %postun
145 %scrollkeeper_update_postun
146 %update_desktop_database_postun
147
148 %files -f galeon-2.0.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README*
151 %attr(755,root,root) %{_bindir}/*
152 %{_libdir}/bonobo/servers/*
153 %{_datadir}/galeon
154 %{_desktopdir}/*.desktop
155 %{_datadir}/gnome-2.0/ui/*.xml
156 %{_omf_dest_dir}/%{name}
157 %{_datadir}/sounds/galeon
158 %{_pixmapsdir}/*
159 %{_sysconfdir}/gconf/schemas/*
160 %{_sysconfdir}/sound/events/*
161 %{_mandir}/man1/*
This page took 0.083327 seconds and 2 git commands to generate.