]> git.pld-linux.org Git - packages/galeon.git/blob - galeon.spec
0b7e5f649f19c370a2cbb236b60737866f0c3fd8
[packages/galeon.git] / galeon.spec
1 #
2 # Conditional build:
3 %bcond_without nautilus # disable nautilus view
4 %bcond_with gcc2        # compile using gcc2 to get working gcc2-compiled java
5                         # plugin (better get gcc3-compiled one).
6                         # Flash plugin seems to still not work, use
7                         # mozilla instead. To compile wit this option, You
8                         # have to install mozilla compiled with gcc2.
9 #
10 %define         minmozver       5:1.6
11 %define         snap    20040117
12
13 Summary:        Galeon - gecko-based GNOME web browser
14 Summary(pl):    Galeon - przegl±darka WWW dla GNOME
15 Summary(pt_BR): O galeon é um browser para o GNOME baseado no mozilla
16 Summary(zh_CN): »ùÓÚGeckoµÄGNOMEÁ÷ÀÀÆ÷
17 Name:           galeon
18 Version:        1.3.13a
19 Release:        1
20 Epoch:          2
21 License:        GPL
22 Group:          X11/Applications/Networking
23 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  c29bdfb23fdafddfcfb6ae7fc6c822fd
25 #Source0:       %{name}-%{version}-%{snap}.tar.bz2
26 Source1:        %{name}-config-tool.1
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-locale-names.patch
30 URL:            http://galeon.sourceforge.net/
31 BuildRequires:  GConf2-devel >= 2.4.0
32 BuildRequires:  ORBit2-devel >= 2.8.3
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  bison
36 BuildRequires:  gettext-devel
37 BuildRequires:  gnome-vfs2-devel >= 2.4.0
38 BuildRequires:  gtk+2-devel >= 2.2.0
39 BuildRequires:  intltool
40 BuildRequires:  libbonoboui-devel >= 2.4.0
41 BuildRequires:  libglade2-devel >= 2.0.1
42 BuildRequires:  libgnomeui-devel >= 2.4.0
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool
45 BuildRequires:  libxml2-devel >= 2.4.0
46 BuildRequires:  mozilla-devel >= %{minmozver}
47 %{?with_nautilus:BuildRequires: nautilus-devel >= 2.4.0}
48 BuildRequires:  openssl-devel >= 0.9.7c
49 BuildRequires:  rpm-build >= 4.1-10
50 BuildRequires:  scrollkeeper >= 0.1.4
51 Requires(post): GConf2
52 Requires(post): scrollkeeper
53 Requires:       libbonobo >= 2.4.0
54 Requires:       mozilla = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla)
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # can be provided by mozilla or mozilla-embedded
58 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
59
60 %if %{with gcc2}
61 %define         __cc            gcc2
62 %define         __cxx           gcc2
63 %endif
64
65 %description
66 GNOME browser based on Gecko (Mozilla rendering engine).
67
68 %description -l pl
69 Galeon jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
70 interpretacji stron Mozilli).
71
72 %description -l pt_BR
73 O galeon é um browser para o GNOME baseado no mozilla.
74
75 %prep
76 %setup -q -n %{name}-1.3.13
77 %patch0 -p1
78 %patch1 -p1
79 %patch2 -p1
80
81 mv po/{no,nb}.po
82
83 # regenerate - didn't compile with ORBit2 2.7.2
84 cd idl
85 orbit-idl-2 -I /usr/share/idl/bonobo-2.0 -I /usr/share/idl/bonobo-activation-2.0 Galeon*.idl
86 mv Galeon*.[ch] ../src
87
88 %build
89 rm -f missing
90 glib-gettextize --copy --force
91 intltoolize --copy --force
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoheader}
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --disable-schemas-install \
99         %if %{with nautilus}
100         --enable-nautilus-view=yes
101         %else
102         --enable-nautilus-view=no
103         %endif
104         
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_mandir}/man1
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/man1
116
117 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/components/*.la
118
119 # galeon-2.0.mo, but gnome/help/galeon
120 %find_lang galeon-2.0 --with-gnome --all-name
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 /usr/bin/scrollkeeper-update
127 %gconf_schema_install
128
129 %postun -p /usr/bin/scrollkeeper-update
130
131 %files -f galeon-2.0.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README*
134 %attr(755,root,root) %{_bindir}/*
135 %attr(755,root,root) %{_libdir}/%{name}
136 %{_libdir}/bonobo/servers/*
137 %{_datadir}/galeon
138 %{_desktopdir}/*
139 %{_datadir}/gnome-2.0/ui/*.xml
140 %{_omf_dest_dir}/%{name}
141 %{_datadir}/sounds/galeon
142 %{_pixmapsdir}/*
143 %{_sysconfdir}/gconf/schemas/*
144 %{_sysconfdir}/sound/events/*
145 %{_mandir}/man1/*
This page took 0.06098 seconds and 2 git commands to generate.