]> git.pld-linux.org Git - packages/gai.git/blob - gai.spec
- unified bcond name: gl -> opengl
[packages/gai.git] / gai.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # without GNOME support
4 %bcond_without  opengl  # without OpenGL support
5 %bcond_without  rox     # without ROX support
6 %bcond_without  sdl     # without SDL support
7 #
8 Summary:        General Applet Interface library
9 Summary(pl.UTF-8):      Ogólna biblioteka interfejsu apletu
10 Name:           gai
11 Version:        0.5.8
12 Release:        1
13 License:        LGPL
14 Group:          X11/Libraries
15 Source0:        http://dl.sourceforge.net/sourceforge/gai/%{name}-%{version}.tar.bz2
16 # Source0-md5:  29d90cb37fe5341009b27ffd09f871cb
17 Patch0:         %{name}-opt.patch
18 Patch1:         %{name}-libdir.patch
19 URL:            http://gai.sourceforge.net/
20 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2}
21 BuildRequires:  autoconf >= 2.53
22 %{?with_opengl:BuildRequires:   gtkglext-devel >= 1.0}
23 %{?with_gnome:BuildRequires:    gnome-panel-devel >= 2.4.0}
24 BuildRequires:  gtk+2-devel >= 1:2.0
25 BuildRequires:  pkgconfig
26 %{?with_rox:BuildRequires:      rox >= 2.1}
27 %{?with_rox:BuildRequires:      which}
28 BuildRequires:  zlib-devel
29 %{?with_gnome:Provides: gai(gnome) = %{version}-%{release}}
30 %{?with_rox:Provides:   gai(rox) = %{version}-%{release}}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
34
35 %description
36 This library is intended to simplify the development and use of
37 dockapps. With this library the programmer can focus on what the
38 applet shall do, not on the interface.
39
40 %description -l pl.UTF-8
41 Zamiarem tej biblioteki jest uproszczenie tworzenia i używania
42 apletów. Przy pomocy tej biblioteki programista może się skupić na tym
43 co aplet powinien robić a nie na jego interfejsie.
44
45 %package devel
46 Summary:        Development files for the GAI
47 Summary(pl.UTF-8):      Pliki rozwojowe dla GAI
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 %if %{with gnome}
51 Requires:       gnome-panel-devel >= 2.4.0
52 Requires:       gai(gnome) = %{version}-%{release}
53 Provides:       gai-devel(gnome) = %{version}-%{release}
54 %endif
55 %{?with_opengl:Requires:        gtkglext-devel >= 1.0}
56 %if %{with rox}
57 Requires:       gai(rox) = %{version}-%{release}
58 Provides:       gai-devel(rox) = %{version}-%{release}
59 %endif
60 Requires:       gtk+2-devel >= 2.0
61
62 %description devel
63 Header files required for development using GAI.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe wymagane do tworzenia programów z użyciem GAI.
67
68 %prep
69 %setup -q 
70 %patch0 -p1
71 %patch1 -p1
72
73 %build
74 %{__autoconf}
75 %configure \
76         %{!?with_opengl:--disable-gl} \
77         %{!?with_gnome:--disable-gnome} \
78         %{!?with_rox:--disable-rox} \
79         %{!?with_sdl:--disable-sdl}
80
81 %{__make} \
82         OPT="%{rpmcflags} -fPIC"
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT \
89         PREFIX=%{_prefix} \
90         LIBDIR=%{_libdir}
91
92 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93 cp -rf examples/[!C]* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog README README.gai THANKS TODO WINDOWMANAGERS 
104 %attr(755,root,root) %{_libdir}/libgai.so.*.*.*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %doc docs/*
109 %attr(755,root,root) %{_libdir}/libgai.so
110 %{_includedir}/gai
111 %{_pkgconfigdir}/gai.pc
112 %{_examplesdir}/%{name}-%{version}
This page took 0.06696 seconds and 3 git commands to generate.