]> git.pld-linux.org Git - packages/gai.git/blob - gai.spec
- updated to 0.5.8
[packages/gai.git] / gai.spec
1 #
2 # Conditional build:
3 %bcond_without  gl      # without OpenGL support
4 %bcond_without  gnome   # without GNOME support
5 %bcond_without  rox     # without ROX support
6 %bcond_without  sdl     # without SDL support
7 #
8 Summary:        General Applet Interface library
9 Summary(pl):    Ogólna biblioteka interfejsu apletu
10 Name:           gai
11 Version:        0.5.8
12 Release:        1
13 License:        LGPL
14 Group:          X11/Libraries
15 Source0:        http://dl.sourceforge.net/sourceforge/gai/%{name}-%{version}.tar.bz2
16 # Source0-md5:  29d90cb37fe5341009b27ffd09f871cb
17 Patch0:         %{name}-opt.patch
18 URL:            http://gai.sourceforge.net/
19 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2}
20 BuildRequires:  autoconf >= 2.53
21 %{?with_gl:BuildRequires:       gtkglext-devel >= 1.0}
22 %{?with_gnome:BuildRequires:    gnome-panel-devel >= 2.4.0}
23 BuildRequires:  gtk+2-devel >= 2.0
24 BuildRequires:  pkgconfig
25 %{?with_rox:BuildRequires:      rox >= 2.1}
26 BuildRequires:  zlib-devel
27 %{?with_gnome:Provides: gai(gnome) = %{version}-%{release}}
28 %{?with_rox:Provides:   gai(rox) = %{version}-%{release}}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
32
33 %description
34 This library is intended to simplify the development and use of
35 dockapps. With this library the programmer can focus on what the
36 applet shall do, not on the interface.
37
38 %description -l pl
39 Zamiarem tej biblioteki jest uproszczenie tworzenia i u¿ywania
40 apletów. Przy pomocy tej biblioteki programista mo¿e siê skupiæ na tym
41 co aplet powinien robiæ a nie na jego interfejsie.
42
43 %package devel
44 Summary:        Development files for the GAI
45 Summary(pl):    Pliki rozwojowe dla GAI
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 %if %{with gnome}
49 Requires:       gnome-panel-devel >= 2.4.0
50 Requires:       gai(gnome) = %{version}-%{release}
51 Provides:       gai-devel(gnome) = %{version}-%{release}
52 %endif
53 %{?with_gl:Requires:    gtkglext-devel >= 1.0}
54 %if %{with rox}
55 Requires:       gai(rox) = %{version}-%{release}
56 Provides:       gai-devel(rox) = %{version}-%{release}
57 %endif
58 Requires:       gtk+2-devel >= 2.0
59
60 %description devel
61 Header files required for development using GAI.
62
63 %description devel -l pl
64 Pliki nag³ówkowe wymagane do tworzenia programów z u¿yciem GAI.
65
66 %prep
67 %setup -q 
68 %patch0 -p1
69
70 %build
71 %{__autoconf}
72 %configure \
73         %{!?with_gl:--disable-gl} \
74         %{!?with_gnome:--disable-gnome} \
75         %{!?with_rox:--disable-rox} \
76         %{!?with_sdl:--disable-sdl}
77
78 %{__make} \
79         OPT="%{rpmcflags}"
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         PREFIX=$RPM_BUILD_ROOT%{_prefix}
86
87 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88 cp -rf examples/[!C]* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog README README.gai THANKS TODO WINDOWMANAGERS 
99 %attr(755,root,root) %{_libdir}/libgai.so.*.*.*
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc docs/*
104 %attr(755,root,root) %{_libdir}/libgai.so
105 %{_includedir}/gai
106 %{_pkgconfigdir}/gai.pc
107 %{_examplesdir}/%{name}-%{version}
This page took 0.041373 seconds and 3 git commands to generate.