]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- obsolete
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl.UTF-8):      Narzędzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR.UTF-8):   Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.9.9
6 Release:        2
7 Epoch:          2
8 License:        LGPL v2.1+
9 Group:          Libraries
10 Source0:        http://download.savannah.gnu.org/releases/g-wrap/%{name}-%{version}.tar.gz
11 # Source0-md5:  9014d7ed8d395ff335a6a4bf5778ed4e
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-srfi-35-fixes.patch
14 URL:            http://www.nongnu.org/g-wrap/
15 BuildRequires:  autoconf >= 2.50
16 BuildRequires:  automake >= 1.5
17 BuildRequires:  glib2-devel >= 2.0
18 BuildRequires:  guile-devel >= 5:1.8.3
19 BuildRequires:  libffi-devel
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 BuildRequires:  texinfo
23 Requires:       guile >= 5:1.8.3
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a tool for specifying types, functions, and constants to
28 import into a Scheme interpreter, and for generating code (in C) to
29 interface these to the Guile and RScheme interpreters in particular.
30
31 %description -l pl.UTF-8
32 To jest narzędzie do specyfikowania typów, funkcji i stałych dla
33 interpretera Scheme i generowania kodu (w C) do udostępnienia ich dla
34 interpreterów Guile i RScheme.
35
36 %description -l pt_BR.UTF-8
37 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
38 para importação em um interpretador scheme e para geração de código em
39 C para fazer a interface com os interpretadores guile e rscheme.
40
41 %package devel
42 Summary:        Headers for developing programs using g-wrap
43 Summary(pl.UTF-8):      Pliki nagłówkowe do rozwijnia programów z użyciem g-wrap
44 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para o g-wrap
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Requires:       guile-devel >= 5:1.8
48
49 %description devel
50 headers for developing programs using g-wrap.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe do rozwijania programów z użyciem g-wrap.
54
55 %description devel -l pt_BR.UTF-8
56 Arquivos de inclusao e bibliotecas para o g-wrap.
57
58 %package static
59 Summary:        Static libraries for developing programs using g-wrap
60 Summary(pl.UTF-8):      Biblioteki statyczne g-wrap
61 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com g-wrap
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
64
65 %description static
66 Static libraries for developing programs using g-wrap.
67
68 %description static -l pl.UTF-8
69 Statyczne biblioteki g-wrap.
70
71 %description static -l pt_BR.UTF-8
72 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p0
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         --disable-Werror
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 rm -f $RPM_BUILD_ROOT%{_libdir}/g-wrap/modules/libgw-*.{a,la}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post devel     -p      /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %postun devel   -p      /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog NEWS README THANKS TODO
113 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so.*.*.*
114 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so.*.*.*
115 %dir %{_libdir}/g-wrap
116 %dir %{_libdir}/g-wrap/modules
117 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-gw-glib.so*
118 %attr(755,root,root) %{_libdir}/g-wrap/modules/libgw-guile-standard.so*
119 %{_datadir}/guile/site/g-wrap
120 %{_datadir}/guile/site/g-wrap.scm
121 %{_infodir}/g-wrap.info*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/g-wrap-config
126 %attr(755,root,root) %{_libdir}/libgwrap-core-runtime.so
127 %attr(755,root,root) %{_libdir}/libgwrap-guile-runtime.so
128 %{_libdir}/libgwrap-core-runtime.la
129 %{_libdir}/libgwrap-guile-runtime.la
130 %{_includedir}/g-wrap
131 %{_includedir}/g-wrap-wct.h
132 %{_pkgconfigdir}/g-wrap-2.0-guile.pc
133 %{_aclocaldir}/g-wrap.m4
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libgwrap-guile-runtime.a
138 %{_libdir}/libgwrap-core-runtime.a
This page took 0.052297 seconds and 3 git commands to generate.