]> git.pld-linux.org Git - packages/g-wrap.git/blob - g-wrap.spec
- orphaned, outdated
[packages/g-wrap.git] / g-wrap.spec
1 Summary:        A utility for automatically generating glue code to export C libraries to Guile Scheme and RScheme
2 Summary(pl):    Narzêdzie do eksportowania bibliotek C do interpreterów Scheme
3 Summary(pt_BR): Um utilitário para geração automática de código para exportar bibliotecas C para guile scheme e rscheme
4 Name:           g-wrap
5 Version:        1.3.4
6 Release:        5
7 Epoch:          2
8 License:        LGPL
9 Group:          Libraries
10 Source0:        http://www.gnucash.org/pub/g-wrap/source/%{name}-%{version}.tar.gz
11 # Source0-md5:  bf29b8b563cc27d9f7fd90a6243653aa
12 Patch0:         %{name}-info.patch
13 Patch1:         %{name}-ac_am_cflags.patch
14 Patch2:         %{name}-am18.patch
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  glib-devel >= 1.0
18 BuildRequires:  guile-devel >= 1.4.1
19 # guile-gtk for gtk wrappers
20 BuildRequires:  libtool
21 BuildRequires:  slib
22 BuildRequires:  texinfo
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This is a tool for specifying types, functions, and constants to
27 import into a Scheme interpreter, and for generating code (in C) to
28 interface these to the Guile and RScheme interpreters in particular.
29
30 %description -l pl
31 To jest narzêdzie do specyfikowania typów, funkcji i sta³ych dla
32 interpretera Scheme i generowania kodu (w C) do udostêpnienia ich dla
33 interpreterów Guile i RScheme.
34
35 %description -l pt_BR
36 O g-wrap é uma ferramenta para especificar tipos, funções e constantes
37 para importação em um interpretador scheme e para geração de código em
38 C para fazer a interface com os interpretadores guile e rscheme.
39
40 %package devel
41 Summary:        Headers for developing programs using g-wrap
42 Summary(pl):    Pliki nag³ówkowe do rozwijnia programów z u¿yciem g-wrap
43 Summary(pt_BR): Arquivos de inclusão e bibliotecas para o g-wrap
44 Group:          Development/Libraries
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46 Requires:       guile-devel >= 1.4.1
47
48 %description devel
49 headers for developing programs using g-wrap.
50
51 %description devel -l pl
52 Pliki nag³ówkowe do rozwijania programów z u¿yciem g-wrap.
53
54 %description devel -l pt_BR
55 Arquivos de inclusao e bibliotecas para o g-wrap.
56
57 %package static
58 Summary:        Static libraries for developing programs using g-wrap
59 Summary(pl):    Biblioteki statyczne g-wrap
60 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com g-wrap
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
63
64 %description static
65 Static libraries for developing programs using g-wrap.
66
67 %description static -l pl
68 Statyczne biblioteki g-wrap.
69
70 %description static -l pt_BR
71 Bibliotecas estáticas para desenvolvimento com a biblioteca g-wrap.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # modules
96 rm -f $RPM_BUILD_ROOT%{_libdir}/libgw-*.a
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post devel
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
106
107 %postun devel
108 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
109
110 %files
111 %defattr(644,root,root,755)
112 %doc NEWS README ChangeLog
113 # libs
114 %attr(755,root,root) %{_libdir}/libgwrap-glib.so.*.*.*
115 %attr(755,root,root) %{_libdir}/libgwrap-wct.so.*.*.*
116 # modules (lt)dlopened by .so OR .la
117 %attr(755,root,root) %{_libdir}/libgw-glib.so.*.*.*
118 #%attr(755,root,root) %{_libdir}/libgw-gtk.so.*.*.*
119 %attr(755,root,root) %{_libdir}/libgw-standard.so.*.*.*
120 %attr(755,root,root) %{_libdir}/libgw-wct.so.*.*.*
121 %attr(755,root,root) %{_libdir}/libgw-glib.so
122 #%attr(755,root,root) %{_libdir}/libgw-gtk.so
123 %attr(755,root,root) %{_libdir}/libgw-standard.so
124 %attr(755,root,root) %{_libdir}/libgw-wct.so
125 %{_libdir}/libgw-glib.la
126 #%{_libdir}/libgw-gtk.la
127 %{_libdir}/libgw-standard.la
128 %{_libdir}/libgw-wct.la
129 %{_datadir}/guile/g-wrap
130 %{_datadir}/guile/g-wrap.scm
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/g-wrap-config
135 %attr(755,root,root) %{_libdir}/libgwrap-glib.so
136 %attr(755,root,root) %{_libdir}/libgwrap-wct.so
137 %{_libdir}/libgwrap-glib.la
138 %{_libdir}/libgwrap-wct.la
139 %{_includedir}/g-wrap
140 %{_infodir}/*.info*
141 %{_aclocaldir}/*.m4
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libgwrap-glib.a
146 %{_libdir}/libgwrap-wct.a
This page took 1.997317 seconds and 3 git commands to generate.