]> git.pld-linux.org Git - packages/fwupd.git/blob - fwupd.spec
- updated to 0.1.3
[packages/fwupd.git] / fwupd.spec
1 #
2 # Conditional build:
3 %bcond_without  colorhug        # ColorHug support
4 %bcond_without  efi             # UEFI support
5 %bcond_without  static_libs     # static library
6 #
7 %ifnarch %{ix86} %{x8664} arm aarch64 ia64
8 %undefine       with_efi
9 %endif
10 Summary:        System daemon for installing device firmware
11 Summary(pl.UTF-8):      Demon systemowy do instalowania firmware'u urządzeń
12 Name:           fwupd
13 Version:        0.1.3
14 Release:        1
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  a438a739c2f375c8268d2b726efd2bf2
19 Patch0:         %{name}-sh.patch
20 URL:            https://github.com/hughsie/fwupd
21 BuildRequires:  appstream-glib-devel >= 0.3.5
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.9
24 %{?with_colorhug:BuildRequires: colord-devel >= 1.2.9}
25 BuildRequires:  docbook-utils
26 %{?with_efi:BuildRequires:      fwupdate-devel}
27 BuildRequires:  gcab-devel
28 BuildRequires:  gettext-tools >= 0.17
29 BuildRequires:  glib2-devel >= 1:2.36.0
30 BuildRequires:  gobject-introspection-devel >= 0.9.8
31 BuildRequires:  gpgme-devel
32 BuildRequires:  intltool >= 0.35.0
33 BuildRequires:  libgpg-error-devel
34 %{?with_colorhug:BuildRequires: libgusb-devel >= 0.2.2}
35 BuildRequires:  libtool
36 BuildRequires:  libxslt-progs
37 BuildRequires:  pkgconfig
38 BuildRequires:  polkit-devel >= 0.103
39 BuildRequires:  rpmbuild(macros) >= 1.644
40 BuildRequires:  sqlite3-devel >= 3
41 BuildRequires:  tar >= 1:1.22
42 BuildRequires:  udev-glib-devel
43 BuildRequires:  xz
44 Requires:       %{name}-libs = %{version}-%{release}
45 Requires:       appstream-glib >= 0.3.5
46 %{?with_colorhug:Requires:      colord-libs >= 1.2.9}
47 %{?with_colorhug:Requires:      libgusb >= 0.2.2}
48 Requires:       polkit >= 0.103
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 fwupd is a simple daemon to allow session software to update device
53 firmware on your local machine. It's designed for desktops, but this
54 project is probably quite interesting for phones, tablets and server
55 farms.
56
57 %description -l pl.UTF-8
58 fwupd to prosty demon pozwalający programom sesyjnym na aktualizację
59 firmware'u urządzeń na maszynie lokalnej. Jest zaprojektowany dla
60 komputerów osobistych, ale może być interesujący także dla telefonów,
61 tabletów i farm serwerów.
62
63 %package libs
64 Summary:        Library for fwupd device firmware installing daemon
65 Summary(pl.UTF-8):      Biblioteka dla demona fwupd instalującego aktualizacje firmware'u
66 Group:          Libraries
67 Requires:       glib2-devel >= 1:2.36.0
68
69 %description libs
70 Library for fwupd device firmware installing daemon.
71
72 %description libs -l pl.UTF-8
73 Biblioteka dla demona fwupd instalującego aktualizacje firmware'u.
74
75 %package devel
76 Summary:        Header files for fwupd library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fwupd
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       glib2-devel >= 1:2.36.0
81
82 %description devel
83 Header files for fwupd library.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki fwupd.
87
88 %package static
89 Summary:        Static fwupd library
90 Summary(pl.UTF-8):      Statyczna biblioteka fwupd
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Static fwupd library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka fwupd.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-silent-rules \
112         %{!?with_static_libs:--disable-static} \
113         %{!?with_efi:--disable-uefi} \
114         --with-systemdsystemunitdir=%{systemdunitdir}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # obsoleted by pkg-config
124 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfwupd.la
125
126 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{hi_IN,hi}
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   libs -p /sbin/ldconfig
134 %postun libs -p /sbin/ldconfig
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS MAINTAINERS NEWS README.md
139 %attr(755,root,root) %{_bindir}/fwupdmgr
140 %attr(755,root,root) %{_libexecdir}/fwupd
141 %dir /etc/pki/fwupd
142 /etc/pki/fwupd/GPG-KEY-Hughski-Limited
143 %{systemdunitdir}/fwupd.service
144 %{systemdunitdir}/fwupd-offline-update.service
145 %{systemdunitdir}/system-update.target.wants/fwupd-offline-update.service
146 /etc/dbus-1/system.d/org.freedesktop.fwupd.conf
147 %{_datadir}/dbus-1/system-services/org.freedesktop.fwupd.service
148 %{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
149 %{_datadir}/polkit-1/rules.d/org.freedesktop.fwupd.rules
150 %dir /var/lib/fwupd
151 %{_mandir}/man1/fwupdmgr.1*
152
153 %files libs
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libfwupd.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libfwupd.so.1
157 %{_libdir}/girepository-1.0/Fwupd-1.0.typelib
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libfwupd.so
162 %{_includedir}/fwupd-1
163 %{_datadir}/gir-1.0/Fwupd-1.0.gir
164 %{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
165 %{_pkgconfigdir}/fwupd.pc
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libfwupd.a
171 %endif
This page took 0.041387 seconds and 4 git commands to generate.