]> git.pld-linux.org Git - packages/fwupd.git/blob - fwupd.spec
- updated to 0.5.1
[packages/fwupd.git] / fwupd.spec
1 #
2 # Conditional build:
3 %bcond_without  colorhug        # ColorHug support
4 %bcond_without  efi             # UEFI support
5 %bcond_without  static_libs     # static library
6 #
7 %ifnarch %{ix86} %{x8664} arm aarch64 ia64
8 %undefine       with_efi
9 %endif
10 Summary:        System daemon for installing device firmware
11 Summary(pl.UTF-8):      Demon systemowy do instalowania firmware'u urządzeń
12 Name:           fwupd
13 Version:        0.5.1
14 Release:        1
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  0ea513d26bb22f874535d051692b0808
19 Patch0:         %{name}-sh.patch
20 URL:            https://github.com/hughsie/fwupd
21 BuildRequires:  appstream-glib-devel >= 0.5.0
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.9
24 %{?with_colorhug:BuildRequires: colord-devel >= 1.2.9}
25 BuildRequires:  docbook-utils
26 %{?with_efi:BuildRequires:      fwupdate-devel}
27 BuildRequires:  gcab-devel
28 BuildRequires:  gettext-tools >= 0.17
29 BuildRequires:  glib2-devel >= 1:2.45.8
30 BuildRequires:  gobject-introspection-devel >= 0.9.8
31 BuildRequires:  gpgme-devel
32 BuildRequires:  intltool >= 0.35.0
33 BuildRequires:  libarchive-devel
34 BuildRequires:  libgpg-error-devel
35 BuildRequires:  libgusb-devel >= 0.2.2
36 BuildRequires:  libsoup-devel >= 2.52
37 BuildRequires:  libtool
38 BuildRequires:  libxslt-progs
39 BuildRequires:  pkgconfig
40 BuildRequires:  polkit-devel >= 0.103
41 BuildRequires:  rpmbuild(macros) >= 1.644
42 BuildRequires:  sqlite3-devel >= 3
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  udev-glib-devel
45 BuildRequires:  xz
46 Requires:       %{name}-libs = %{version}-%{release}
47 Requires:       appstream-glib >= 0.5.0
48 %{?with_colorhug:Requires:      colord-libs >= 1.2.9}
49 Requires:       libgusb >= 0.2.2
50 Requires:       libsoup >= 2.52
51 Requires:       polkit >= 0.103
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 fwupd is a simple daemon to allow session software to update device
56 firmware on your local machine. It's designed for desktops, but this
57 project is probably quite interesting for phones, tablets and server
58 farms.
59
60 %description -l pl.UTF-8
61 fwupd to prosty demon pozwalający programom sesyjnym na aktualizację
62 firmware'u urządzeń na maszynie lokalnej. Jest zaprojektowany dla
63 komputerów osobistych, ale może być interesujący także dla telefonów,
64 tabletów i farm serwerów.
65
66 %package libs
67 Summary:        Library for fwupd device firmware installing daemon
68 Summary(pl.UTF-8):      Biblioteka dla demona fwupd instalującego aktualizacje firmware'u
69 Group:          Libraries
70 Requires:       glib2-devel >= 1:2.45.8
71
72 %description libs
73 Library for fwupd device firmware installing daemon.
74
75 %description libs -l pl.UTF-8
76 Biblioteka dla demona fwupd instalującego aktualizacje firmware'u.
77
78 %package devel
79 Summary:        Header files for fwupd library
80 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fwupd
81 Group:          Development/Libraries
82 Requires:       %{name}-libs = %{version}-%{release}
83 Requires:       glib2-devel >= 1:2.45.8
84
85 %description devel
86 Header files for fwupd library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki fwupd.
90
91 %package static
92 Summary:        Static fwupd library
93 Summary(pl.UTF-8):      Statyczna biblioteka fwupd
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static fwupd library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka fwupd.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106
107 %build
108 %{__libtoolize}
109 %{__aclocal} -I m4
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --disable-silent-rules \
115         %{!?with_static_libs:--disable-static} \
116         %{!?with_efi:--disable-uefi} \
117         --with-systemdunitdir=%{systemdunitdir}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 # obsoleted by pkg-config
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfwupd.la
128
129 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{hi_IN,hi}
130
131 %find_lang %{name}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   libs -p /sbin/ldconfig
137 %postun libs -p /sbin/ldconfig
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS MAINTAINERS NEWS README.md
142 %attr(755,root,root) %{_bindir}/fwupdmgr
143 %attr(755,root,root) %{_libexecdir}/fwupd
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fwupd.conf
145 %dir /etc/pki/fwupd
146 /etc/pki/fwupd/GPG-KEY-Hughski-Limited
147 /etc/pki/fwupd/GPG-KEY-Linux-Vendor-Firmware-Service
148 %dir /etc/pki/fwupd-metadata
149 /etc/pki/fwupd-metadata/GPG-KEY-Linux-Vendor-Firmware-Service
150 %{systemdunitdir}/fwupd.service
151 %{systemdunitdir}/fwupd-offline-update.service
152 %{systemdunitdir}/system-update.target.wants/fwupd-offline-update.service
153 /lib/udev/rules.d/90-fwupd-devices.rules
154 /etc/dbus-1/system.d/org.freedesktop.fwupd.conf
155 %{_datadir}/dbus-1/system-services/org.freedesktop.fwupd.service
156 %{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
157 %{_datadir}/polkit-1/rules.d/org.freedesktop.fwupd.rules
158 %dir /var/lib/fwupd
159 %{_mandir}/man1/fwupdmgr.1*
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libfwupd.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libfwupd.so.1
165 %{_libdir}/girepository-1.0/Fwupd-1.0.typelib
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libfwupd.so
170 %{_includedir}/fwupd-1
171 %{_datadir}/gir-1.0/Fwupd-1.0.gir
172 %{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
173 %{_pkgconfigdir}/fwupd.pc
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libfwupd.a
179 %endif
This page took 0.126736 seconds and 4 git commands to generate.