]> git.pld-linux.org Git - packages/fwupd.git/blob - fwupd.spec
- updated to 0.5.4
[packages/fwupd.git] / fwupd.spec
1 #
2 # Conditional build:
3 %bcond_without  colorhug        # ColorHug support
4 %bcond_without  efi             # UEFI support
5 %bcond_without  static_libs     # static library
6 #
7 %ifnarch %{ix86} %{x8664} arm aarch64 ia64
8 %undefine       with_efi
9 %endif
10 Summary:        System daemon for installing device firmware
11 Summary(pl.UTF-8):      Demon systemowy do instalowania firmware'u urządzeń
12 Name:           fwupd
13 Version:        0.5.4
14 Release:        1
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  84dff90d5a9eef2ab09c49aa242a5cd7
19 Patch0:         %{name}-sh.patch
20 URL:            https://github.com/hughsie/fwupd
21 BuildRequires:  appstream-glib-devel >= 0.5.2
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.9
24 %{?with_colorhug:BuildRequires: colord-devel >= 1.2.9}
25 BuildRequires:  docbook-utils
26 %{?with_efi:BuildRequires:      fwupdate-devel >= 0.5}
27 BuildRequires:  gcab-devel
28 BuildRequires:  gettext-tools >= 0.17
29 BuildRequires:  glib2-devel >= 1:2.45.8
30 BuildRequires:  gobject-introspection-devel >= 0.9.8
31 BuildRequires:  gpgme-devel
32 BuildRequires:  intltool >= 0.35.0
33 BuildRequires:  libarchive-devel
34 BuildRequires:  libgpg-error-devel
35 BuildRequires:  libgusb-devel >= 0.2.2
36 BuildRequires:  libsoup-devel >= 2.52
37 BuildRequires:  libtool
38 BuildRequires:  libxslt-progs
39 BuildRequires:  pkgconfig
40 BuildRequires:  polkit-devel >= 0.103
41 BuildRequires:  rpmbuild(macros) >= 1.644
42 BuildRequires:  sqlite3-devel >= 3
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  udev-glib-devel
45 BuildRequires:  xz
46 Requires:       %{name}-libs = %{version}-%{release}
47 Requires:       appstream-glib >= 0.5.2
48 %{?with_colorhug:Requires:      colord-libs >= 1.2.9}
49 %{?with_efi:Requires:   fwupdate-libs >= 0.5}
50 Requires:       libgusb >= 0.2.2
51 Requires:       libsoup >= 2.52
52 Requires:       polkit >= 0.103
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 fwupd is a simple daemon to allow session software to update device
57 firmware on your local machine. It's designed for desktops, but this
58 project is probably quite interesting for phones, tablets and server
59 farms.
60
61 %description -l pl.UTF-8
62 fwupd to prosty demon pozwalający programom sesyjnym na aktualizację
63 firmware'u urządzeń na maszynie lokalnej. Jest zaprojektowany dla
64 komputerów osobistych, ale może być interesujący także dla telefonów,
65 tabletów i farm serwerów.
66
67 %package libs
68 Summary:        Library for fwupd device firmware installing daemon
69 Summary(pl.UTF-8):      Biblioteka dla demona fwupd instalującego aktualizacje firmware'u
70 Group:          Libraries
71 Requires:       glib2-devel >= 1:2.45.8
72
73 %description libs
74 Library for fwupd device firmware installing daemon.
75
76 %description libs -l pl.UTF-8
77 Biblioteka dla demona fwupd instalującego aktualizacje firmware'u.
78
79 %package devel
80 Summary:        Header files for fwupd library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fwupd
82 Group:          Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84 Requires:       glib2-devel >= 1:2.45.8
85
86 %description devel
87 Header files for fwupd library.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe biblioteki fwupd.
91
92 %package static
93 Summary:        Static fwupd library
94 Summary(pl.UTF-8):      Statyczna biblioteka fwupd
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static fwupd library.
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka fwupd.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107
108 %build
109 %{__libtoolize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --disable-silent-rules \
116         %{!?with_static_libs:--disable-static} \
117         %{!?with_efi:--disable-uefi} \
118         --with-systemdunitdir=%{systemdunitdir}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # obsoleted by pkg-config
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfwupd.la
129
130 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{hi_IN,hi}
131
132 %find_lang %{name}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS MAINTAINERS NEWS README.md
143 %attr(755,root,root) %{_bindir}/fwupdmgr
144 %attr(755,root,root) %{_libexecdir}/fwupd
145 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fwupd.conf
146 %dir /etc/pki/fwupd
147 /etc/pki/fwupd/GPG-KEY-Hughski-Limited
148 /etc/pki/fwupd/GPG-KEY-Linux-Vendor-Firmware-Service
149 %dir /etc/pki/fwupd-metadata
150 /etc/pki/fwupd-metadata/GPG-KEY-Linux-Vendor-Firmware-Service
151 %{systemdunitdir}/fwupd.service
152 %{systemdunitdir}/fwupd-offline-update.service
153 %{systemdunitdir}/system-update.target.wants/fwupd-offline-update.service
154 /lib/udev/rules.d/90-fwupd-devices.rules
155 /etc/dbus-1/system.d/org.freedesktop.fwupd.conf
156 %{_datadir}/dbus-1/system-services/org.freedesktop.fwupd.service
157 %{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
158 %{_datadir}/polkit-1/rules.d/org.freedesktop.fwupd.rules
159 %dir /var/lib/fwupd
160 %{_mandir}/man1/fwupdmgr.1*
161
162 %files libs
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libfwupd.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libfwupd.so.1
166 %{_libdir}/girepository-1.0/Fwupd-1.0.typelib
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libfwupd.so
171 %{_includedir}/fwupd-1
172 %{_datadir}/gir-1.0/Fwupd-1.0.gir
173 %{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
174 %{_pkgconfigdir}/fwupd.pc
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libfwupd.a
180 %endif
This page took 0.069526 seconds and 4 git commands to generate.