]> git.pld-linux.org Git - packages/fwupd.git/blob - fwupd.spec
- new
[packages/fwupd.git] / fwupd.spec
1 #
2 # Conditional build:
3 %bcond_without  colorhug        # ColorHug support
4 %bcond_without  efi             # UEFI support
5 %bcond_without  static_libs     # static library
6 #
7 %ifnarch %{ix86} %{x8664} arm aarch64 ia64
8 %undefine       with_efi
9 %endif
10 Summary:        System daemon for installing device firmware
11 Summary(pl.UTF-8):      Demon systemowy do instalowania firmware'u urządzeń
12 Name:           fwupd
13 Version:        0.1.1
14 Release:        1
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
18 # Source0-md5:  87819887a63bbf953e9ee4e3aa54359a
19 URL:            https://github.com/hughsie/fwupd
20 BuildRequires:  appstream-glib-devel >= 0.3.5
21 %{?with_colorhug:BuildRequires: colord-devel >= 1.2.9}
22 BuildRequires:  docbook-utils
23 %{?with_efi:BuildRequires:      fwupdate-devel}
24 BuildRequires:  gcab-devel
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.36.0
27 BuildRequires:  gobject-introspection-devel >= 0.9.8
28 BuildRequires:  intltool >= 0.35.0
29 %{?with_colorhug:BuildRequires: libgusb-devel >= 0.2.2}
30 BuildRequires:  libxslt-progs
31 BuildRequires:  pkgconfig
32 BuildRequires:  polkit-devel >= 0.103
33 BuildRequires:  rpmbuild(macros) >= 1.644
34 BuildRequires:  sqlite3-devel >= 3
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  udev-glib-devel
37 BuildRequires:  xz
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       appstream-glib >= 0.3.5
40 %{?with_colorhug:Requires:      colord-libs >= 1.2.9}
41 %{?with_colorhug:Requires:      libgusb >= 0.2.2}
42 Requires:       polkit >= 0.103
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 fwupd is a simple daemon to allow session software to update device
47 firmware on your local machine. It's designed for desktops, but this
48 project is probably quite interesting for phones, tablets and server
49 farms.
50
51 %description -l pl.UTF-8
52 fwupd to prosty demon pozwalający programom sesyjnym na aktualizację
53 firmware'u urządzeń na maszynie lokalnej. Jest zaprojektowany dla
54 komputerów osobistych, ale może być interesujący także dla telefonów,
55 tabletów i farm serwerów.
56
57 %package libs
58 Summary:        Library for fwupd device firmware installing daemon
59 Summary(pl.UTF-8):      Biblioteka dla demona fwupd instalującego aktualizacje firmware'u
60 Group:          Libraries
61 Requires:       glib2-devel >= 1:2.36.0
62
63 %description libs
64 Library for fwupd device firmware installing daemon.
65
66 %description libs -l pl.UTF-8
67 Biblioteka dla demona fwupd instalującego aktualizacje firmware'u.
68
69 %package devel
70 Summary:        Header files for fwupd library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki fwupd
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.36.0
75
76 %description devel
77 Header files for fwupd library.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe biblioteki fwupd.
81
82 %package static
83 Summary:        Static fwupd library
84 Summary(pl.UTF-8):      Statyczna biblioteka fwupd
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Static fwupd library.
90
91 %description static -l pl.UTF-8
92 Statyczna biblioteka fwupd.
93
94 %prep
95 %setup -q
96
97 %build
98 %configure \
99         %{!?with_static_libs:--disable-static} \
100         %{!?with_efi:--disable-uefi} \
101         --with-systemdsystemunitdir=%{systemdunitdir}
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # obsoleted by pkg-config
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfwupd.la
112
113 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{hi_IN,hi}
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   libs -p /sbin/ldconfig
121 %postun libs -p /sbin/ldconfig
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS MAINTAINERS NEWS README.md
126 %attr(755,root,root) %{_bindir}/fwupdmgr
127 %attr(755,root,root) %{_libexecdir}/fwupd
128 %{systemdunitdir}/fwupd.service
129 /etc/dbus-1/system.d/org.freedesktop.fwupd.conf
130 %{_datadir}/dbus-1/system-services/org.freedesktop.fwupd.service
131 %{_datadir}/polkit-1/actions/org.freedesktop.fwupd.policy
132 %{_datadir}/polkit-1/rules.d/org.freedesktop.fwupd.rules
133 %dir /var/lib/fwupd
134 %{_mandir}/man1/fwupdmgr.1*
135
136 %files libs
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libfwupd.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libfwupd.so.1
140 %{_libdir}/girepository-1.0/Fwupd-1.0.typelib
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libfwupd.so
145 %{_includedir}/fwupd-1
146 %{_datadir}/gir-1.0/Fwupd-1.0.gir
147 %{_datadir}/dbus-1/interfaces/org.freedesktop.fwupd.xml
148 %{_pkgconfigdir}/fwupd.pc
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libfwupd.a
154 %endif
This page took 0.079734 seconds and 3 git commands to generate.