]> git.pld-linux.org Git - packages/fuse.git/blobdiff - fuse.spec
- updated to 1.3.8
[packages/fuse.git] / fuse.spec
index fbcd8366c19b2f0eeb43dbfcd68e02a4c1c4f585..63479dc4334cb0fdb52ce03be48f7c3c2570be38 100644 (file)
--- a/fuse.spec
+++ b/fuse.spec
@@ -5,38 +5,41 @@
 %bcond_without gtk2    # GTK+ 2 version
 %bcond_without gtk3    # GTK+ 3 version
 %bcond_without sdl     # SDL version
+%bcond_without libao   # libao instead of alsa
 #
+%define                libspectrumver  1.3.6
 Summary:       Free Unix Spectrum Emulator
 Summary(pl.UTF-8):     Darmowy uniksowy emulator ZX Spectrum
 Name:          fuse
-Version:       1.3.4
+Version:       1.3.8
 Release:       1
 License:       GPL v2+
 Group:         Applications/Emulators
 Source0:       http://downloads.sourceforge.net/fuse-emulator/%{name}-%{version}.tar.gz
-# Source0-md5: 300fb52f5e86fa2e4b01163fa5d74a7b
+# Source0-md5: 278bb7d77360be3cdc839276217a584d
 Source1:       ti_m397.rom
 # Source1-md5: 8c61b20e1f7666ff80ad7f48bb2b10c0
-Patch0:                fuse-1.1.1-2.patch
+Patch0:                %{name}-1.1.1-2.patch
 URL:           http://fuse-emulator.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.4
-BuildRequires: alsa-lib-devel
+%{!?with_libao:BuildRequires:  alsa-lib-devel}
 BuildRequires: autoconf >= 2.59-9
 BuildRequires: automake
 BuildRequires: glib2-devel >= 1:2.20.0
+%{?with_fb:BuildRequires:      gpm-devel}
 %{?with_gtk2:BuildRequires:    gtk+2-devel >= 2:2.18.0}
 %{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.0}
-%{?with_fb:BuildRequires:      gpm-devel}
+%{?with_libao:BuildRequires:   libao-devel}
 BuildRequires: libjsw-devel
 BuildRequires: libmount-devel
 BuildRequires: libpng-devel
 BuildRequires: libsamplerate-devel
-BuildRequires: libspectrum-devel >= 1.3.2
+BuildRequires: libspectrum-devel >= %{libspectrumver}
 BuildRequires: libtool >= 2:2
 BuildRequires: libxml2-devel >= 2.0.0
 BuildRequires: perl-base
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.673
+BuildRequires: rpmbuild(macros) >= 1.697
 BuildRequires: sed >= 4.0
 %{?with_svga:BuildRequires:    svgalib-devel}
 BuildRequires: xorg-lib-libX11-devel
@@ -69,7 +72,7 @@ Summary:      Free Unix Spectrum Emulator (common files)
 Summary(pl.UTF-8):     Darmowy uniksowy emulator ZX Spectrum (pliki wspólne)
 Group:         Applications/Emulators
 Requires:      glib2 >= 1:2.20.0
-Requires:      libspectrum >= 1.3.2
+Requires:      libspectrum >= %{libspectrumver}
 Suggests:      fdd3000e
 
 %description common
@@ -279,19 +282,17 @@ Bashowe dopełnianie składni poleceń emulatora FUSE.
 %{__sed} -i -e '/^complete /s/ fuse$/ fuse-fb fuse-gtk fuse-gtk3 fuse-sdl fuse-svga/' data/shell-completion/bash/fuse
 
 %build
-#%{__libtoolize}
-#%{__aclocal} -I m4
-#%{__autoconf}
-#%{__autoheader}
-#%{__automake}
-
+%define        common_opts \\\
+       --disable-silent-rules \\\
+       --with-bash-completion-dir=%{bash_compdir} \\\
+       %{nil}
 # SDL
 %if %{with sdl}
 mkdir build-sdl
 cd build-sdl
 ../%configure \
+       %{common_opts} \
        --program-suffix=-sdl \
-       --with-bash-completion-dir=%{bash_compdir} \
        --with-sdl
 %{__make}
 cd ..
@@ -302,8 +303,8 @@ cd ..
 mkdir build-svga
 cd build-svga
 ../%configure \
+       %{common_opts} \
        --program-suffix=-svga \
-       --with-bash-completion-dir=%{bash_compdir} \
        --with-svgalib
 %{__make}
 cd ..
@@ -314,8 +315,12 @@ cd ..
 mkdir build-fb
 cd build-fb
 ../%configure \
+       %{common_opts} \
        --program-suffix=-fb \
-       --with-bash-completion-dir=%{bash_compdir} \
+%if %{with libao}
+       --without-alsa \
+       --with-libao \
+%endif
        --with-fb
 %{__make}
 cd ..
@@ -326,8 +331,12 @@ cd ..
 mkdir build-gtk2
 cd build-gtk2
 ../%configure  \
+       %{common_opts} \
        --program-suffix=-gtk \
-       --with-bash-completion-dir=%{bash_compdir} \
+%if %{with libao}
+       --without-alsa \
+       --with-libao \
+%endif
        --with-gtk
 %{__make}
 cd ..
@@ -338,9 +347,13 @@ cd ..
 mkdir build-gtk3
 cd build-gtk3
 ../%configure  \
+       %{common_opts} \
        --enable-gtk3 \
        --program-suffix=-gtk3 \
-       --with-bash-completion-dir=%{bash_compdir} \
+%if %{with libao}
+       --without-alsa \
+       --with-libao \
+%endif
        --with-gtk
 %{__make}
 cd ..
@@ -373,14 +386,14 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files common
 %defattr(644,root,root,755)
-%doc README THANKS AUTHORS keysyms.dat keysyms.pl hacking/*.txt
+%doc README THANKS AUTHORS ChangeLog keysyms.dat keysyms.pl hacking/*.txt
 %{_datadir}/%{name}
 
 %if %{with fb}
This page took 0.115056 seconds and 4 git commands to generate.