]> git.pld-linux.org Git - packages/ftpfs.git/blob - ftpfs.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/ftpfs.git] / ftpfs.spec
1 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
2 %define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
3 %define         smpstr          %{?_with_smp:-smp}
4 %define         smp             %{?_with_smp:1}%{!?_with_smp:0}
5
6 Summary:        FTP File System 
7 Summary(pl):    System plików FTP 
8 Name:           ftpfs
9 Version:        0.6.0
10 Release:        2
11 License:        GPL
12 Group:          Base/Kernel
13 Source0:        http://ftp1.sourceforge.net/ftpfs/%{name}-%{version}-k2.4.tar.gz
14 Patch0:         %{name}-opt.patch
15 %{!?no_dist_kernel:BuildRequires:       kernel-headers >= 2.4}
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 FTP File System is a Linux kernel module, enhancing the VFS with FTP
20 volume mounting capabilities. That is, you can "mount" FTP shared
21 directories in your very personal file system and take advantage of
22 local files ops.
23
24 %description -l pl
25 System plików FTP jest modu³em j±dra rozszerzaj±cym VFS o mo¿liwo¶æ
26 montowania wolumenów FTP. Oznacza to, ¿e mo¿esz podmontowaæ katalogi
27 FTP do swojego systemu plików i korzystaæ z nich jak z plików
28 lokalnych.
29
30 %package -n kernel%{smpstr}-net-ftpfs
31 Summary:        FTP File System - kernel module
32 Summary(pl):    System plików FTP - modu³ j±dra
33 Release:        %{release}@%{_kernel_ver_str}
34 Group:          Base/Kernel
35 Prereq:         /sbin/depmod
36 Obsoletes:      ftpfs
37 Provides:       ftpfs = %{version}
38
39 %description -n kernel%{smpstr}-net-ftpfs
40 FTP File System is a Linux kernel module, enhancing the VFS with FTP
41 volume mounting capabilities. That is, you can "mount" FTP shared
42 directories in your very personal file system and take advantage of
43 local files ops. This package contains ftpfs kernel module.
44
45 %description -n kernel%{smpstr}-net-ftpfs -l pl
46 System plików FTP jest modu³em j±dra rozszerzaj±cym VFS o mo¿liwo¶æ
47 montowania wolumenów FTP. Oznacza to, ¿e mo¿esz podmontowaæ katalogi
48 FTP do swojego systemu plików i korzystaæ z nich jak z plików
49 lokalnych. Ten pakiet zawiera modu³ j±dra do ftpfs.
50
51 %package -n ftpmount
52 Summary:        FTP File System mounting utility
53 Summary(pl):    Narzêdzie do montowania systemów plików FTP
54 Group:          Applications/System
55 Requires:       ftpfs = %{version}
56
57 %description -n ftpmount
58 FTP File System mounting utility.
59
60 %description -n ftpmount -l pl
61 Narzêdzie do montowania systemów plików FTP.
62
63 %prep
64 %setup -q -n ftpfs-%{version}-k2.4
65 %patch -p1
66
67 %build
68 %{__make} OPT="%{rpmcflags}"
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 install -D ftpfs/ftpfs.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/ftpfs.o
74 install -D ftpmount/ftpmount $RPM_BUILD_ROOT%{_sbindir}/ftpmount
75
76 gzip -9nf CHANGELOG TODO ftpmount/README
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post -n kernel%{smpstr}-net-ftpfs
82 /sbin/depmod -a
83
84 %postun -n kernel%{smpstr}-net-ftpfs
85 /sbin/depmod -a
86         
87 %files -n kernel%{smpstr}-net-ftpfs
88 %defattr(644,root,root,755)
89 %doc docs *.gz
90 /lib/modules/*/*/*
91
92 %files -n ftpmount
93 %defattr(644,root,root,755)
94 %doc ftpmount/*.gz
95 %attr(755,root,root) %{_sbindir}/ftpmount
This page took 0.070786 seconds and 3 git commands to generate.