]> git.pld-linux.org Git - packages/fstrm.git/blame - fstrm.spec
- rebuild with libevent 2.1.9
[packages/fstrm.git] / fstrm.spec
CommitLineData
ae52c48b
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_without static_libs # don't build static libraries
5#
6Summary: C implementation of the Frame Streams transport protocol
7Summary(pl.UTF-8): Implementacja protokołu transportowego Frame Streams w języku C
8Name: fstrm
f44646ae 9Version: 0.3.1
fb313858 10Release: 2
f44646ae 11License: Apache v2.0
ae52c48b 12Group: Libraries
f44646ae
JB
13#Source0Download: https://github.com/farsightsec/fstrm/releases
14Source0: https://github.com/farsightsec/fstrm/archive/v%{version}/%{name}-%{version}.tar.gz
15# Source0-md5: 8159053635f307b38cdc21ea34a8fca3
ae52c48b 16URL: https://github.com/farsightsec/fstrm
f44646ae
JB
17BuildRequires: autoconf >= 2.64
18BuildRequires: automake >= 1:1.11
ae52c48b
JB
19BuildRequires: doxygen
20BuildRequires: libevent-devel >= 2
f44646ae 21BuildRequires: libtool >= 2:2
ae52c48b
JB
22BuildRequires: pkgconfig
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26Frame Streams is a light weight, binary clean protocol that allows for
27the transport of arbitrarily encoded data payload sequences with
28minimal framing overhead - just four bytes per data frame. Frame
29Streams does not specify an encoding format for data frames and can be
30used with any data serialization format that produces byte sequences,
31such as Protocol Buffers, XML, JSON, MessagePack, YAML, etc.
32
33fstrm is an optimized C implementation of Frame Streams that includes
34a fast, lockless circular queue implementation and exposes library
35interfaces for setting up a dedicated Frame Streams I/O thread and
36asynchronously submitting data frames for transport from worker
37threads. It was originally written to facilitate the addition of high
38speed binary logging to DNS servers written in C using the dnstap log
39format.
40
41%description -l pl.UTF-8
42Frame Streams to lekki, bezpieczny dla binariów protokół pozwalający
43na przesyłanie dowolnie zakodowanych sekwencji danych z minimalnym
44narzutem na ramki - tylko cztery bajty na jedną. Frame Streams nie
45określają formatu kodowania ramek danych i mogą być używane z dowolnym
46formatem serializacji tworzącym sekwencje bajtów, takim jak Protocol
47Buffers, XML, JSON, MessagePack, YAML itp.
48
49fstrm to zoptymalizowana implementacja Frame Streams w języku C,
50zawierająca szybką, pozbawioną blokad kolejkę cykliczną; udostępnia
51interfejsy biblioteczne do ustawiania dedykowanego wątku we/wy oraz
52asynchronicznego przekazywania ramek danych do przesłania z wątków
53roboczych. Pierwotnie powstała, aby ułatwić dodanie bardzo szybkiego,
54binarnego logowania w serwerach DNS, napisanych w C, przy użyciu
55formatu logu dnstap.
56
57%package devel
58Summary: Header files for fstrm library
59Summary(pl.UTF-8): Pliki nagłówkowe biblioteki fstrm
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62
63%description devel
64Header files for fstrm library.
65
66%description devel -l pl.UTF-8
67Pliki nagłówkowe biblioteki fstrm.
68
69%package static
70Summary: Static fstrm library
71Summary(pl.UTF-8): Statyczna biblioteka fstrm
72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74
75%description static
76Static fstrm library.
77
78%description static -l pl.UTF-8
79Statyczna biblioteka fstrm.
80
81%prep
82%setup -q
83
84%build
f44646ae
JB
85%{__libtoolize}
86%{__aclocal} -I m4
87%{__autoconf}
88%{__autoheader}
89%{__automake}
ae52c48b
JB
90%configure \
91 --disable-silent-rules \
92 %{!?with_static_libs:--disable-static}
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
97
98%{__make} install \
99 DESTDIR=$RPM_BUILD_ROOT
100
101# obsoleted by pkg-config
102%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfstrm.la
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
112%doc COPYRIGHT ChangeLog README.md
113%attr(755,root,root) %{_bindir}/fstrm_capture
114%attr(755,root,root) %{_bindir}/fstrm_dump
115%attr(755,root,root) %{_libdir}/libfstrm.so.*.*.*
116%attr(755,root,root) %ghost %{_libdir}/libfstrm.so.0
117
118%files devel
119%defattr(644,root,root,755)
120%attr(755,root,root) %{_libdir}/libfstrm.so
121%{_includedir}/fstrm
122%{_includedir}/fstrm.h
123%{_pkgconfigdir}/libfstrm.pc
124
125%if %{with static_libs}
126%files static
127%defattr(644,root,root,755)
128%{_libdir}/libfstrm.a
129%endif
This page took 0.132891 seconds and 4 git commands to generate.