]> git.pld-linux.org Git - packages/fsplib.git/blob - fsplib.spec
- added bcond without static_libs
[packages/fsplib.git] / fsplib.spec
1 %bcond_without  static_libs     # don't build static library
2 Summary:        fsp library
3 Summary(pl):    Biblioteka fsp
4 Name:           fsplib
5 Version:        0.6
6 Release:        1
7 License:        BSD-like (see COPYING)
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/fsp/%{name}-%{version}.tar.gz
10 # Source0-md5:  18f837120b5a185840dd16555728dc30
11 URL:            http://fsp.sourceforge.net/fsplib.html
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This is C library which support talking with FSP server using FSP v2
19 protocol and provides POSIX-like file manipulation interface.
20
21 For more information about FSP protocol see
22 <http://fsp.sourceforge.net/>.
23
24 For library and API info see http://fsp.sourceforge.net/fsplib.html .
25
26 %description -l pl
27 To jest biblioteka napisana w C, która obs³uguje "rozmowê" z serwerem
28 FSP przy u¿yciu wersji 2 protoko³u i dostarcza interfejsu operacji na
29 plikach podobnego do POSIX.
30
31 Wiêcej informacji o protokole FSP mo¿na znale¼æ na
32 <http://fsp.sourceforge.net/>.
33
34 Informacje o bibliotece i API znajduj± siê na
35 http://fsp.sourceforge.net/fsplib.html .
36
37 %package devel
38 Summary:        Header files for FSP library
39 Summary(pl):    Pliki nag³ówkowe biblioteki FSP
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for FSP library.
45
46 %description devel -l pl
47 Pliki nag³ówkowe biblioteki FSP.
48
49 %package static
50 Summary:        Static FSP library
51 Summary(pl):    Statyczna biblioteka FSP
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static FSP library.
57
58 %description static -l pl
59 Statyczna biblioteka FSP.
60
61 %prep
62 %setup -c -q
63
64 %build
65 autoreconf -i
66 %{__libtoolize}
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         --enable-shared \
71         %{!?with_static_libs:--disable-static}
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog COPYING NEWS README TODO
89 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
90
91 %files devel
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_libdir}/lib*.so
94 %{_libdir}/lib*.la
95 %{_includedir}/*
96
97 %if %{with static_libs}
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
101 %endif
This page took 0.086213 seconds and 3 git commands to generate.