]> git.pld-linux.org Git - packages/frox.git/blob - frox.spec
- Req user-frox
[packages/frox.git] / frox.spec
1
2 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
3 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
4 %if %{_kernel24}
5 %define         _kernel_series  2.4
6 %else
7 %define         _kernel_series  2.2
8 %endif
9
10 Summary:        Transparent FTP proxy
11 Summary(pl):    Prze¼roczyste proxy FTP
12 Name:           frox
13 Version:        0.7.6
14 Release:        1@%{_kernel_series}
15 License:        GPL
16 Group:          Networking/Daemons
17 Source0:        http://frox.sourceforge.net/download/%{name}-%{version}.tar.bz2
18 Source1:        %{name}.init
19 Source2:        %{name}.sysconfig
20 Patch0:         %{name}-config.patch
21 URL:            http://frox.sourceforge.net/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 PreReq:         rc-scripts
25 Requires(pre):  user-frox
26 Requires(post,preun):   /sbin/chkconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Frox is transparent FTP proxy. It also has support for non-transparent
31 connections, caching of anonymous ftp, and active --> passive
32 conversion of data connections.
33
34 %description -l pl
35 Frox to prze¼roczyste proxy FTP, posiada równie¿ wsparcie do
36 nie-transparentnych po³aczen, buforowania anonimowego ftp, i konwersji
37 aktywne-pasywne polaczenia.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42
43 %build
44 %{__aclocal}
45 %{__autoconf}
46 %configure \
47         --enable-http-cache \
48         --enable-local-cache \
49         %{?_kernel24:--enable-libiptc} \
50         %{?!_kernel24:--disable-libiptc} \
51         --enable-transparent-data \
52         --enable-configfile=%{_sysconfdir}/frox.conf
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_mandir}/man{5,8}} \
58         $RPM_BUILD_ROOT/var/lib/frox
59
60 %{__make} install DESTDIR=$RPM_BUILD_ROOT
61 install src/frox.conf   $RPM_BUILD_ROOT%{_sysconfdir}/frox.conf
62
63 install doc/frox.man    $RPM_BUILD_ROOT%{_mandir}/man8/frox.8
64 install doc/frox.conf.man       $RPM_BUILD_ROOT%{_mandir}/man5/frox.5
65 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/frox
66 install %{SOURCE2}      $RPM_BUILD_ROOT/etc/sysconfig/frox
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 /sbin/chkconfig --add frox
73 if [ -f /var/lock/subsys/frox ]; then
74         /etc/rc.d/init.d/frox restart >&2
75 else
76         echo "Run \"/etc/rc.d/init.d/frox start\" to start frox daemons."
77 fi
78
79 %preun
80 if [ "$1" = "0" ]; then
81         if [ -f /var/lock/subsys/frox ]; then
82                 /etc/rc.d/init.d/frox stop >&2
83         fi
84         /sbin/chkconfig --del frox
85 fi
86
87 %files
88 %defattr(644,root,root,755)
89 %doc doc/{FAQ,README.transdata,RELEASE,SECURITY,TODO}
90 %attr(754,root,root) /etc/rc.d/init.d/frox
91 %attr(750,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/frox
92 %attr(640,root,frox) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/frox.conf
93 %attr(755,root,root) %{_sbindir}/frox
94 %attr(770,root,frox) /var/lib/frox
95 %{_mandir}/man*/*
This page took 1.115232 seconds and 4 git commands to generate.