]> git.pld-linux.org Git - packages/frox.git/blob - frox.spec
- Version: 0.7.5
[packages/frox.git] / frox.spec
1 Summary:        Transparent FTP proxy
2 Summary(pl):    Prze¼roczyste proxy FTP
3 Name:           frox
4 Version:        0.7.5
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://frox.sourceforge.net/download/%{name}-%{version}.tar.bz2
9 Source1:        %{name}.init
10 Source2:        %{name}.conf
11 URL:            http://frox.sourceforge.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 Prereq:         rc-scripts
15 Prereq:         /sbin/chkconfig
16 BuildConflicts: kernel-headers < 2.3.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Frox is transparent FTP proxy. It also has support for non-transparent
21 connections, caching of anonymous ftp, and active --> passive
22 conversion of data connections.
23
24 %description -l pl
25 Frox to prze¼roczyste proxy FTP, posiada równie¿ wsparcie do
26 nie-transparentnych po³aczen, buforowania anonimowego ftp, i konwersji
27 aktywne-pasywne polaczenia.
28
29 %prep
30 %setup -q
31
32 %build
33 aclocal
34 %{__autoconf}
35 %configure \
36         --enable-http-cache \
37         --enable-local-cache \
38         --enable-libiptc \
39         --enable-transparent-data \
40         --enable-configfile=%{_sysconfdir}/frox.conf
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_mandir}/man8} \
46         $RPM_BUILD_ROOT/var/cache/frox/0{1,2,3,4,5,6,7,8,9,0,a,b,c,d,e,f}
47
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 install doc/frox.man    $RPM_BUILD_ROOT%{_mandir}/man8/frox.8
51 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/frox
52 install %{SOURCE2}      $RPM_BUILD_ROOT%{_sysconfdir}/frox.conf
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %pre
58 if [ ! -n "`getgid frox`" ]; then
59         /usr/sbin/groupadd -g 97 -r -f frox 1>&2 || :
60 fi
61
62 if [ ! -n "`id -u frox 2>/dev/null`" ]; then
63         /usr/sbin/useradd -M -o -r -u 97 -s /bin/false \
64                 -g squid -c "FROX ftp caching daemon" -d /var/cache/frox frox 1>&2 || :
65 fi
66
67 %post
68 /sbin/chkconfig --add frox
69 if [ -f /var/lock/subsys/frox ]; then
70         /etc/rc.d/init.d/frox restart >&2
71 else
72         echo "Run \"/etc/rc.d/init.d/frox start\" to start frox daemons."
73 fi
74
75 %preun
76 if [ "$1" = "0" ]; then
77         if [ -f /var/lock/subsys/frox ]; then
78                 /etc/rc.d/init.d/frox stop >&2
79         fi
80         /sbin/chkconfig --del frox
81 fi
82
83 %postun
84 # If package is being erased for the last time.
85 if [ "$1" = "0" ]; then
86         /usr/sbin/userdel frox 2> /dev/null
87         /usr/sbin/groupdel frox 2> /dev/null
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc doc/{FAQ,README.transdata,RELEASE,SECURITY,TODO}
93 %attr(754,root,root) /etc/rc.d/init.d/frox
94 %attr(640,root,frox) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/frox.conf
95 %attr(755,root,root) %{_sbindir}/frox
96 %attr(750,frox,frox) %dir /var/cache/frox
97 %{_mandir}/man*/*
This page took 0.042076 seconds and 4 git commands to generate.