]> git.pld-linux.org Git - packages/frox.git/blob - frox.spec
- massive attack: adding Source-md5
[packages/frox.git] / frox.spec
1
2 %define         _kernel_ver     %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
3 %define         _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
4 %if %{_kernel24}
5 %define         _kernel_series  2.4
6 %else
7 %define         _kernel_series  2.2
8 %endif
9
10 Summary:        Transparent FTP proxy
11 Summary(pl):    Prze¼roczyste proxy FTP
12 Name:           frox
13 Version:        0.7.6
14 Release:        1@%{_kernel_series}
15 License:        GPL
16 Group:          Networking/Daemons
17 Source0:        http://frox.sourceforge.net/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  1df290dbb766f5ce661eb52d5ddf7ca5
19 Source1:        %{name}.init
20 Source2:        %{name}.sysconfig
21 Patch0:         %{name}-config.patch
22 URL:            http://frox.sourceforge.net/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 PreReq:         rc-scripts
26 Requires(pre): /usr/bin/getgid
27 Requires(pre): /bin/id
28 Requires(pre): /usr/sbin/groupadd
29 Requires(pre): /usr/sbin/useradd
30 Requires(postun):      /usr/sbin/userdel
31 Requires(postun):      /usr/sbin/groupdel
32 Requires(post,preun):   /sbin/chkconfig
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Frox is transparent FTP proxy. It also has support for non-transparent
37 connections, caching of anonymous ftp, and active --> passive
38 conversion of data connections.
39
40 %description -l pl
41 Frox to prze¼roczyste proxy FTP, posiada równie¿ wsparcie do
42 nie-transparentnych po³aczen, buforowania anonimowego ftp, i konwersji
43 aktywne-pasywne polaczenia.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48
49 %build
50 %{__aclocal}
51 %{__autoconf}
52 %configure \
53         --enable-http-cache \
54         --enable-local-cache \
55         %{?_kernel24:--enable-libiptc} \
56         %{?!_kernel24:--disable-libiptc} \
57         --enable-transparent-data \
58         --enable-configfile=%{_sysconfdir}/frox.conf
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig,%{_mandir}/man{5,8}} \
64         $RPM_BUILD_ROOT/var/lib/frox
65
66 %{__make} install DESTDIR=$RPM_BUILD_ROOT
67 install src/frox.conf   $RPM_BUILD_ROOT%{_sysconfdir}/frox.conf
68
69 install doc/frox.man    $RPM_BUILD_ROOT%{_mandir}/man8/frox.8
70 install doc/frox.conf.man       $RPM_BUILD_ROOT%{_mandir}/man5/frox.5
71 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/frox
72 install %{SOURCE2}      $RPM_BUILD_ROOT/etc/sysconfig/frox
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %pre
78 if [ ! -n "`getgid frox`" ]; then
79        /usr/sbin/groupadd -g 97 -r -f frox 1>&2 || :
80 fi
81
82 if [ ! -n "`id -u frox 2>/dev/null`" ]; then
83        /usr/sbin/useradd -M -o -r -u 97 -s /bin/false \
84                -g frox -c "FROX ftp caching daemon" -d /var/cache/frox frox 1>&2 || :
85 fi
86
87 %post
88 /sbin/chkconfig --add frox
89 if [ -f /var/lock/subsys/frox ]; then
90         /etc/rc.d/init.d/frox restart >&2
91 else
92         echo "Run \"/etc/rc.d/init.d/frox start\" to start frox daemons."
93 fi
94
95 %preun
96 if [ "$1" = "0" ]; then
97         if [ -f /var/lock/subsys/frox ]; then
98                 /etc/rc.d/init.d/frox stop >&2
99         fi
100         /sbin/chkconfig --del frox
101 fi
102
103 %postun
104 if [ "$1" = "0" ]; then
105        /usr/sbin/userdel frox 2> /dev/null
106        /usr/sbin/groupdel frox 2> /dev/null
107 fi
108
109 %files
110 %defattr(644,root,root,755)
111 %doc doc/{FAQ,README.transdata,RELEASE,SECURITY,TODO}
112 %attr(754,root,root) /etc/rc.d/init.d/frox
113 %attr(750,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/frox
114 %attr(640,root,frox) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/frox.conf
115 %attr(755,root,root) %{_sbindir}/frox
116 %attr(770,root,frox) /var/lib/frox
117 %{_mandir}/man*/*
This page took 0.120127 seconds and 4 git commands to generate.