]> git.pld-linux.org Git - packages/frox.git/blob - frox.spec
- added automake, autoconf to BuildRequires.
[packages/frox.git] / frox.spec
1 Summary:        Transparent FTP proxy
2 Summary(pl):    Prze¼roczyste proxy FTP
3 Name:           frox
4 Version:        0.6.5
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/frox/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.conf
13 URL:            http://frox.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 Prereq:         rc-scripts
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Frox is transparent FTP proxy. It also has support for non-transparent
21 connections, caching of anonymous ftp, and active --> passive
22 conversion of data connections.
23
24 %description -l pl
25 Frox to prze¼roczyste proxy FTP, posiada równie¿ wsparcie do
26 nie-transparentnych po³aczen, buforowania anonimowego ftp, i konwersji
27 aktywne-pasywne polaczenia.
28
29 %prep
30 %setup -q
31
32 %build
33 aclocal
34 autoconf
35 %configure \
36         --enable-http-cache \
37         --enable-local-cache \
38         --enable-libiptc \
39         --enable-transparent-data \
40         --enable-configfile=%{_sysconfdir}/frox.conf
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_mandir}/man8} \
46         $RPM_BUILD_ROOT/var/cache/frox/0{1,2,3,4,5,6,7,8,9,0,a,b,c,d,e,f}
47
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 install doc/frox.man    $RPM_BUILD_ROOT%{_mandir}/man8/frox.8
51 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/frox
52 install %{SOURCE2}      $RPM_BUILD_ROOT%{_sysconfdir}/frox.conf
53
54 gzip -9nf doc/{FAQ,README.transdata,RELEASE,SECURITY,TODO}
55
56 %pre
57 if [ ! -n "`getgid frox`" ]; then
58         /usr/sbin/groupadd -g 97 -r -f frox 1>&2 || :
59 fi
60
61 if [ ! -n "`id -u frox 2>/dev/null`" ]; then
62         /usr/sbin/useradd -M -o -r -u 97 -s /bin/false \
63                 -g squid -c "FROX ftp caching daemon" -d /var/cache/frox frox 1>&2 || :
64 fi              
65
66 %post
67 /sbin/chkconfig --add frox
68 if [ -f /var/lock/subsys/frox ]; then
69         /etc/rc.d/init.d/frox restart >&2
70 else
71         echo "Run \"/etc/rc.d/init.d/frox start\" to start frox daemons."
72 fi
73
74 %postun
75 # If package is being erased for the last time.
76 if [ "$1" = "0" ]; then
77         /usr/sbin/userdel frox 2> /dev/null
78         /usr/sbin/groupdel frox 2> /dev/null
79 fi              
80
81 %preun
82 if [ "$1" = "0" ]; then
83         if [ -f /var/lock/subsys/frox ]; then
84                 /etc/rc.d/init.d/frox stop >&2
85         fi
86         /sbin/chkconfig --del frox
87 fi
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc doc/*.gz
95 %attr(754,root,root) /etc/rc.d/init.d/frox
96 %attr(640,root,frox) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/frox.conf
97 %attr(755,root,root) %{_sbindir}/frox
98 %attr(750,frox,frox) %dir /var/cache/frox
99 %{_mandir}/man*/*
This page took 0.048564 seconds and 4 git commands to generate.