]> git.pld-linux.org Git - packages/frontline.git/blob - frontline.spec
- switched to vfolders, .so perms, strict internal deps
[packages/frontline.git] / frontline.spec
1 #
2 # Conditional build:
3 %bcond_with     gimp    # build GIMP (1.2.x only) plugin
4 #
5 Summary:        GUI FRONT end for autotrace that extracts outLINE from images
6 Summary(pl):    Graficzny interfejs do autotrace wyci±gaj±cego obrysy z obrazków
7 Name:           frontline
8 Version:        0.5.4
9 Release:        6
10 License:        GPL
11 Group:          X11/Applications/Graphics
12 Source0:        http://dl.sourceforge.net/autotrace/%{name}-%{version}.tar.gz
13 # Source0-md5:  5fc2c3459b153dbc2b3138c1133f927e
14 Patch0:         %{name}-shared.patch
15 URL:            http://autotrace.sourceforge.net/frontline/
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  autotrace-devel >= 0.31.1
19 BuildRequires:  gettext-devel
20 %{?with_gimp:BuildRequires:     gimp-devel >= 1:1.2.1}
21 %{?with_gimp:BuildRequires:     gimp-devel < 1.3}
22 BuildRequires:  gnome-libs-devel >= 1.4.0
23 BuildRequires:  imlib-devel >= 1.8.2
24 BuildRequires:  libart_lgpl >= 2.3.8
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 Requires:       %{name}-libs = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %if %{with gimp}
32 %define         gimpplugindir   %(gimptool --gimpplugindir)
33 %endif
34
35 %description
36 Frontline provides a GTK+/GNOME based GUI front end for autotrace
37 (http://autotrace.sourceforge.net/). This package contains the
38 `frontline' command, which runs as a stand alone program. It will work
39 well with GNOME desktop and nautilus.
40
41 %description -l pl
42 Frontline udostêpnia oparty na GTK+/GNOME graficzny interfejs do
43 autotrace (http://autotrace.sourceforge.net/). Ten pakiet zawiera
44 polecenie "frontline", dzia³aj±ce jako samodzielny program. Dzia³a
45 dobrze z pulpitem GNOME i nautilusem.
46
47 %package libs
48 Summary:        Frontline shared libraries
49 Summary(pl):    Biblioteki wspó³dzielone Frontline
50 Group:          X11/Libraries
51
52 %description libs
53 This package contains Frontline shared libraries, used by all versions
54 of Frontline GUI.
55
56 %description libs -l pl
57 Ten program zawiera biblioteki wspó³dzielone Frontline, u¿ywane przez
58 wszystkie wersje interfejsu Frontline.
59
60 %package devel
61 Summary:        Frontline development files
62 Summary(pl):    Pliki dla programistów u¿ywaj±cych Frontline
63 Group:          X11/Development/Libraries
64 Requires:       %{name}-libs = %{version}-%{release}
65
66 %description devel
67 Frontline development files.
68
69 %description devel -l pl
70 Pliki dla programistów u¿ywaj±cych Frontline.
71
72 %package static
73 Summary:        Frontline static libraries
74 Summary(pl):    Biblioteki statyczne Frontline
75 Group:          X11/Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Frontline static libraries.
80
81 %description static -l pl
82 Biblioteki statyczne Frontline.
83
84 %package -n gimp-plugin-frontline
85 Summary:        GIMP Frontline plugin
86 Summary(pl):    Wtyczka Frontline dla GIMPa
87 Group:          X11/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89
90 %description -n gimp-plugin-frontline
91 GIMP frontline plugin - you can launch frontline from the GIMP menu.
92
93 %description -n gimp-plugin-frontline -l pl
94 Wtyczka frontline dla GIMPa - pozwala na uruchomienie frontline z menu
95 GIMPa.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100
101 echo 'Categories=Graphics;VectorGraphics;' >> frontline.desktop
102
103 %build
104 %{!?with_gimp:echo 'AC_DEFUN([AM_PATH_GIMP],[$3])' >> acinclude.m4}
105 %{__gettextize}
106 %{__libtoolize}
107 %{__aclocal} -I %{_aclocaldir}/gnome
108 %{__autoconf}
109 %{__automake}
110 %configure
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         Graphicsdir=%{_desktopdir} \
119         m4datadir=%{_aclocaldir} \
120         pkgconfigdir=%{_pkgconfigdir}
121
122 for f in CHANGES README TODO ; do
123         mv -f gundo/$f ${f}.gundo
124 done
125
126 %find_lang %{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   libs -p /sbin/ldconfig
132 %postun libs -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/frontline
137 %{_datadir}/mime-info/*
138 %{_desktopdir}/*.desktop
139
140 %files libs -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS BUGS ChangeLog NEWS README TODO {CHANGES,README,TODO}.gundo
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
144 %{_pixmapsdir}/*.png
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/frontline-config
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_libdir}/lib*.la
151 %{_includedir}/frontline
152 %{_includedir}/gundo
153 %{_aclocaldir}/frontline.m4
154 %{_pkgconfigdir}/frontline.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
159
160 %if %{with gimp}
161 %files -n gimp-plugin-frontline
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{gimpplugindir}/plug-ins/trace
164 %endif
This page took 0.109735 seconds and 3 git commands to generate.