]> git.pld-linux.org Git - packages/frogatto.git/commitdiff
- added no_fbo_assert.patch(ugly hack that makes game playable on R200 GFX card)
authorKrzysztof Krakowiak <evil@pld-linux.org>
Wed, 2 May 2012 21:29:04 +0000 (21:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    frogatto-no_fbo_assert.patch -> 1.1
    frogatto.spec -> 1.8

frogatto-no_fbo_assert.patch [new file with mode: 0644]
frogatto.spec

diff --git a/frogatto-no_fbo_assert.patch b/frogatto-no_fbo_assert.patch
new file mode 100644 (file)
index 0000000..0f62244
--- /dev/null
@@ -0,0 +1,11 @@
+--- frogatto-1.1.1/src/texture_frame_buffer.cpp.orig   2012-05-02 23:03:34.654597749 +0200
++++ frogatto-1.1.1/src/texture_frame_buffer.cpp        2012-05-02 23:05:23.709618026 +0200
+@@ -94,7 +94,7 @@
+       // check FBO status
+       GLenum status = EXT_CALL(glCheckFramebufferStatus)(EXT_MACRO(GL_FRAMEBUFFER));
+-      ASSERT_EQ(status, EXT_MACRO(GL_FRAMEBUFFER_COMPLETE));
++//    ASSERT_EQ(status, EXT_MACRO(GL_FRAMEBUFFER_COMPLETE));
+       // switch back to window-system-provided framebuffer
+       EXT_CALL(glBindFramebuffer)(EXT_MACRO(GL_FRAMEBUFFER), video_framebuffer_id);
index 68a98ff6b7c2652822b723cc0e718f29623ac638..7dfd32c3f357b5199a0b1c6b252ac39b0a5a9ec1 100644 (file)
@@ -1,7 +1,7 @@
 Summary:       An open-source "platformer" game
 Name:          frogatto
 Version:       1.1.1
-Release:       6
+Release:       7
 License:       GPL v3+
 Group:         X11/Applications/Games
 Source0:       http://www.frogatto.com/files/%{name}-%{version}.tar.bz2
@@ -9,6 +9,7 @@ Source0:        http://www.frogatto.com/files/%{name}-%{version}.tar.bz2
 Patch0:                %{name}-makefile.patch
 Patch1:                %{name}-assertion.patch
 Patch2:                %{name}-libpng15.patch
+Patch3:                %{name}-no_fbo_assert.patch
 URL:           http://www.frogatto.com/
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
@@ -36,6 +37,7 @@ however, we're not trying to clone any specific game.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # fix linking with our boost libs
 %{__sed} -i 's,-mt,,g' Makefile
This page took 0.070317 seconds and 4 git commands to generate.